Author Topic: xfce4 power manager screen brightness problem  (Read 2010 times)

Offline CluelessOne

  • Newly Subscribed
  • *
  • Posts: 7
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
xfce4 power manager screen brightness problem
« on: January 16, 2016, 07:42:21 am »
Hi all,
I am using an EEE 1000 H with peppermint 6 and xfce4 power manager. My problem is screen display brightness setting is  not persistent after reboot / shutdown. After reboot / shutdown it always start on the maximum. Brightness level setting is set at 10% (that survives any reboot).
Thanks

Online VinDSL

  • Administrator
  • Hero
  • *****
  • Posts: 5898
  • Karma: 1160
  • Team Peppermint
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: xfce4 power manager screen brightness problem
« Reply #1 on: January 16, 2016, 09:56:35 am »
Don't know if this will help you, or not ...

I recently upgraded my Eee PC 1000HD to Peppermint 6.  I'm using the default mate-power-manager.

Here's how I took care of the brightness problem at boot, on my rig:

Open a terminal and type ...

Code: [Select]
sudo -i
Then type ...

Code: [Select]
gedit /etc/rc.local
Add the following code to the file and save ...

Code: [Select]
#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

# Don't start bluetooth on every boot.

rfkill block bluetooth

# This will reduce display brightness on boot.  **WARNING**
# Don't make the value of brightness greater than the max_brightness
# value as it will error out with an Invalid argument. Start with a
# value of 1000 and increase it from there.
 
echo 5000 > /sys/class/backlight/intel_backlight/brightness

# IMPORTANT - DO NOT REMOVE THE FOLLOWING !!!

exit 0

Reboot
« Last Edit: January 16, 2016, 10:00:49 am by VinDSL »

Offline CluelessOne

  • Newly Subscribed
  • *
  • Posts: 7
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: xfce4 power manager screen brightness problem
« Reply #2 on: January 16, 2016, 04:12:03 pm »
If I understand correctly this script turns off bluetooth and set some value to brightness setting at the end of a session.
Does this setting survives reboot? Why at the end of session? Shouldn't it be at the start of session?
Do I have to turn off bluetooth at the end of session?
Does this mean on BIOS the bluetooth adapter disabled?
Thanks.

Online VinDSL

  • Administrator
  • Hero
  • *****
  • Posts: 5898
  • Karma: 1160
  • Team Peppermint
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: xfce4 power manager screen brightness problem
« Reply #3 on: January 17, 2016, 09:33:38 am »
On my Eee PC, this setup script starts working at boot, and kicks in during the plymouth screen.  And, yes, it survives a boot.  All is fine, until the power saver blanks the screen, then the display returns to full illumination when awakening, requiring the user to turn down the brightness via the Fn+F5 key.  After that, you're good for the remainder of the session.

It's a ghetto solution, to be sure, and doesn't correctly address the real issue, which is, the kernel no longer passes ACPI information to the Asus bios, so the eeepc_laptop module never loads at boot.

I'll see if I can find the workaround.  It was a simple solution, if I remember correctly.  It's been several years since I did a fresh install on my Eee PC. LoL

BTW, I'm disabling bluetooth because 1) I never use it, and 2) It sucks a lot of power from the battery.   Comment that line out, if you use bluetooth.   ;)

Online VinDSL

  • Administrator
  • Hero
  • *****
  • Posts: 5898
  • Karma: 1160
  • Team Peppermint
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: xfce4 power manager screen brightness problem
« Reply #4 on: January 17, 2016, 12:12:51 pm »
Okay, I remember now.  I was missing a piece of the puzzle ...   :D

The workaround:

Code: [Select]
sudo -i
Code: [Select]
gedit /etc/default/grub
Change the lne:

Code: [Select]
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
To:

Code: [Select]
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor acpi_osi=Linux"
Save & Close


Update Grub:

Code: [Select]
update-grub
Now, tweak the rc.local file (from the post above):

Code: [Select]
gedit /etc/rc.local
I changed the brightness value to 6500

Code: [Select]
#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

# Don't start bluetooth on every boot.

rfkill block bluetooth

# This will reduce display brightness on boot.  **WARNING**
# Don't make the value of brightness greater than the max_brightness
# value as it will error out with an Invalid argument. Start with a
# value of 1000 and increase it from there.
 
echo 6500 > /sys/class/backlight/intel_backlight/brightness

# IMPORTANT - DO NOT REMOVE THE FOLLOWING !!!

exit 0

Save & Close

Reboot


After you log back into the Peppermint session, go to Menu -> System Tools -> Power Management


Here are the settings I used in the Power Management tool:








That's it ! 

Once again, this how I tamed the display on my Asus Eee PC 1000HD beast.   Results my vary, depending on the model you own.

I tested my Eee PC on battery power & AC wall power, and the settings survived multiple reboots, even after the screen saver proggie blanked the display.  Also, most of the Fn hotkeys are working now - at least all of the ones I normally use.  I haven't fully tested the hotkeys on an external monitor, and so forth, but it looks like I have everything back to where it was, pre-Peppermint 6.

Now, I need to get ZSH and git setup, which is always fun.  I think I'll save that for another day.  LoL  :D

Anyway, give that a whirl and see if it works for you, too ...

Online VinDSL

  • Administrator
  • Hero
  • *****
  • Posts: 5898
  • Karma: 1160
  • Team Peppermint
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: xfce4 power manager screen brightness problem
« Reply #5 on: January 17, 2016, 04:28:16 pm »
As an aside ...

I've been running the Eee PC for several hours, listening to streaming music vids on DubTrack.fm.  I wanted to make sure the workaround is stable (it is).

To this day, I am still totally amazed at how great the TFT LCD displays in these things look (once you tweak the settings).

This is the best looking display in the house, and at my workplace for that matter.   No kidding !  Amazing !!!

The dark-themed Peppermint 6 install is the icing on the cake.  Looks as sharp as a 10-inch smartphone.

Just saying ...  8)
« Last Edit: January 17, 2016, 04:31:18 pm by VinDSL »