Choose style:

Author Topic: Problems with HPLIP [SOLVED]  (Read 1602 times)

0 Members and 1 Guest are viewing this topic.

Offline VirgoMale8

  • nOOb
  • *
  • Posts: 5
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Problems with HPLIP [SOLVED]
« on: January 08, 2016, 09:40:16 am »
I'm having problems installing my HP3520 All-In-One Deskjet printer using HPLIP.  First HPLIP does 't recognize PeppermintOS.  It tries to identify it as Linux Mint 6.  Secondly, it will not continue until I enter a root password.  I did not install a root account.  What password do I use for the root account anyway?
« Last Edit: January 08, 2016, 06:20:35 pm by AndyInMokum, Reason: Marking topic as solved. »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26468
  • Karma: 2871
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Problems with HPLIP
« Reply #1 on: January 08, 2016, 11:56:23 am »
Why are you trying to install hplip from the web ? .. it's available in the default repositories, just open a terminal and run:
Code: [Select]
sudo apt-get install hplip hplip-gui
Then go to

menu > Preferences > HPLIP Toolbox

to configure your printer.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline VirgoMale8

  • nOOb
  • *
  • Posts: 5
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Problems with HPLIP
« Reply #2 on: January 08, 2016, 04:04:54 pm »
Thanks. The printer and scanner work fine now.

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4870
  • Karma: 1035
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 10 (64-bit)
Re: Problems with HPLIP
« Reply #3 on: January 08, 2016, 06:19:31 pm »
Hi VirgoMale8, welcome to the Peppermint Forum.  If you're having issues or need any help installing software from the repositories.  Please don't hesitate to ask questions.  That's why we're here.  There will always be someone here happy to help you out  ;).

If you feel a topic has been resolved.  Please remember to mark it as [SOLVED] in the subject line of the original post.  I've done this for you this time - many thanks and have fun  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline scifidude79

  • Global Moderator
  • Hero
  • *****
  • Posts: 4029
  • Karma: 863
    • View Profile
  • Peppermint version(s): Peppermint 9
Re: Problems with HPLIP
« Reply #4 on: January 09, 2016, 10:04:30 am »
Why are you trying to install hplip from the web ? .. it's available in the default repositories, just open a terminal and run:
Code: [Select]
sudo apt-get install hplip hplip-gui

Really, all you need is this:

Code: [Select]
sudo apt-get install hplip-gui

When you run that, hplip will be automatically installed as a dependency for hplip-gui.  (I have two HP printers and that always works for me ;) )