Choose style:

Author Topic: revisiting KVM disabled by bios... [reSOLVED]  (Read 2582 times)

0 Members and 1 Guest are viewing this topic.

Offline spence

  • Administrator
  • Hero
  • *****
  • Posts: 2624
  • Karma: 316
  • peppermint user since 2010
    • View Profile
  • Peppermint version(s): PMVIII, PMIX, PMX Respins
revisiting KVM disabled by bios... [reSOLVED]
« on: December 16, 2015, 11:07:07 pm »
given my 70 to 90 second boot/reboot times, i'm wondering if there is a way to stop receiving the error message KVM disabled by bios... are we able to turn off the search for this, like i was able to turn off the search for BTRFS? yes that's me asking the same question in google plus ;~)

EDIT finally figured out what had happened to my colors, chromium seems to have javascript disabled by default everywhere, or was that me? hmmmm  :-\
« Last Edit: December 20, 2015, 08:40:43 pm by spence »
spence
PeppermintOS 8,9 & 10 Respins currently installed  on:
'16 Antec Aria rebuild
PMX Respin on '18 Asus VivoBook


Do not despair, grasshopper...
    with patience all will be revealed...
       Through pain, enlightenment will come.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: revisiting KVM disabled by bios...
« Reply #1 on: December 17, 2015, 09:16:06 am »
Is there nothing in your BIOS about enabling "Virtualization Technology" or similar ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline spence

  • Administrator
  • Hero
  • *****
  • Posts: 2624
  • Karma: 316
  • peppermint user since 2010
    • View Profile
  • Peppermint version(s): PMVIII, PMIX, PMX Respins
Re: revisiting KVM disabled by bios...
« Reply #2 on: December 18, 2015, 02:47:24 pm »
nothing that i recollect... but wouldn't enabling something for which i have no use (nor any understanding) slow the machine even further? the disabling message comes up 5 times as the 2012 hp laptop boots or reboots...

EDIT
just rebooted... there is a section in bios for enabling, but in the section HP warns it should remain turned off unless virtualization software is installed or in use... would prefer to turn the search off... curiously, the warning only appeared a single time after going into the bios...
« Last Edit: December 18, 2015, 02:57:57 pm by spence »
spence
PeppermintOS 8,9 & 10 Respins currently installed  on:
'16 Antec Aria rebuild
PMX Respin on '18 Asus VivoBook


Do not despair, grasshopper...
    with patience all will be revealed...
       Through pain, enlightenment will come.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: revisiting KVM disabled by bios...
« Reply #3 on: December 19, 2015, 09:13:17 am »
Can't see why they'd suggest that, but okay.

What's the output from:
Code: [Select]
lsmod | grep kvm
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline spence

  • Administrator
  • Hero
  • *****
  • Posts: 2624
  • Karma: 316
  • peppermint user since 2010
    • View Profile
  • Peppermint version(s): PMVIII, PMIX, PMX Respins
Re: revisiting KVM disabled by bios...
« Reply #4 on: December 19, 2015, 04:47:14 pm »
If you think enabling kvm won't be problematical, I'm willing to give it a go after backing some schtuff up...

Code: [Select]
sean@hpG6 ~ $ lsmod | grep kvm
kvm                   532480  0
irqbypass              16384  1 kvm

spence
PeppermintOS 8,9 & 10 Respins currently installed  on:
'16 Antec Aria rebuild
PMX Respin on '18 Asus VivoBook


Do not despair, grasshopper...
    with patience all will be revealed...
       Through pain, enlightenment will come.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: revisiting KVM disabled by bios...
« Reply #5 on: December 19, 2015, 06:58:23 pm »
I've never known it cause a problem .. in any case the kernel is ALREADY loading the driver for it, so enabling it in hardware will make no difference to what Peppermint is already doing.

AFAIK there are no Linux HVT rootkits or malware .. but at the end of the day it has to be your call.



If you'd rather not enable it, maybe we can just blacklist the kvm kernel module (driver) .. let me know if you'd rather try this first.
« Last Edit: December 19, 2015, 07:10:34 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline spence

  • Administrator
  • Hero
  • *****
  • Posts: 2624
  • Karma: 316
  • peppermint user since 2010
    • View Profile
  • Peppermint version(s): PMVIII, PMIX, PMX Respins
Re: revisiting KVM disabled by bios...
« Reply #6 on: December 20, 2015, 12:20:34 am »
i went ahead and enabled virtualization via the bios... shaved 10 seconds off boot/reboot. Guess I'll try this for a bit... whoever is monitoring the peppermint fan page on G+ suggested blacklisting and sent me a link for doing that... would that save me any more boot time vs just enabling? 
spence
PeppermintOS 8,9 & 10 Respins currently installed  on:
'16 Antec Aria rebuild
PMX Respin on '18 Asus VivoBook


Do not despair, grasshopper...
    with patience all will be revealed...
       Through pain, enlightenment will come.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: revisiting KVM disabled by bios...
« Reply #7 on: December 20, 2015, 09:30:18 am »
I doubt it .. and I posted that on G+ ;)
(it was an untested suggestion .. not so much a definite solution)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline spence

  • Administrator
  • Hero
  • *****
  • Posts: 2624
  • Karma: 316
  • peppermint user since 2010
    • View Profile
  • Peppermint version(s): PMVIII, PMIX, PMX Respins
Re: revisiting KVM disabled by bios...
« Reply #8 on: December 20, 2015, 08:40:07 pm »
I doubt it .. and I posted that on G+ ;)
(it was an untested suggestion .. not so much a definite solution)

rather figured it'd be you monitoring g+   8)

... i've not done much there... but have been poking around in it ever since FB flagged my account for being in violation of the "real names policy" ... ... ... thus far, nobody i know with a gmail e'mail addy uses it... 

i know my 50-90 second boots or reboots are a first world problem... so if blacklisting isn't likely to shave, then i'll relent for now...

speaking of first word problems...  https://youtu.be/-bIEwHxiGlA

spence
PeppermintOS 8,9 & 10 Respins currently installed  on:
'16 Antec Aria rebuild
PMX Respin on '18 Asus VivoBook


Do not despair, grasshopper...
    with patience all will be revealed...
       Through pain, enlightenment will come.

Offline VinDSL

  • Administrator
  • Hero
  • *****
  • Posts: 5722
  • Karma: 1077
  • Team Peppermint
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: revisiting KVM disabled by bios... [reSOLVED]
« Reply #9 on: December 22, 2015, 11:27:30 am »
Bwahahahaha!

This video (above) is why I don't tether myself to a 'smart' phone ...   :D