Author Topic: Can't install Steam (SOLVED)  (Read 2097 times)

0 Members and 1 Guest are viewing this topic.

Offline rickc

  • Jr. Member
  • **
  • Posts: 60
  • Karma: 10
    • View Profile
  • Peppermint version(s): 9
Can't install Steam (SOLVED)
« on: December 08, 2015, 02:44:31 pm »
Hello!

I'm not new to linux but I'm new to Peppermint.  Really happy...except I can't install Steam!  I've not had this issue on other ubuntu or debian distros

Have done a fresh system install (64 bit Peppermint 6),  updated the system and rebooted

Steam will not install via synaptic - I get a message saying fix broken packages first.  I can install anything else ok and I don't think anything can be broken?

I've tried installing it via the .deb file at Steams website, but that fails due to missing dependancies.

There is a solved thread about this under applications, which I've followed and tried everything.   In my case this is not a hardware issue as this laptop can run steam using LXLE or Sparky Linux

This is driving me nuts, any help greatly appreciated!!!

Many thanks
Rick
« Last Edit: December 09, 2015, 11:42:37 am by rickc »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Can't install Steam
« Reply #1 on: December 08, 2015, 04:41:21 pm »
you haven't said what the missing dependencies are ? on the 3.16

First run:
Code: [Select]
uname -a
and check you're on the 3.16 kernel .. if you are, continue below, otherwise stop now and post your kernel version.

If you are,  try this (in 64bit Peppermint 6):
Code: [Select]
sudo apt-get install libc6:i386 libgl1-mesa-dri-lts-utopic:i386 libgl1-mesa-glx-lts-utopic:i386 libglapi-mesa-lts-utopic:i386
then
Code: [Select]
sudo apt-get install steam
now see if steam will start:
Code: [Select]
steam
« Last Edit: December 08, 2015, 04:46:40 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline rickc

  • Jr. Member
  • **
  • Posts: 60
  • Karma: 10
    • View Profile
  • Peppermint version(s): 9
Re: Can't install Steam
« Reply #2 on: December 08, 2015, 06:21:49 pm »
Thankyou.  Yes I am on the 3.16 kernel

I followed your suggestion and got the following error (so wouldn't then let me install steam)

Code: [Select]
libc6:i386 is already the newest version.
libgl1-mesa-dri-lts-utopic:i386 is already the newest version.
libglapi-mesa-lts-utopic:i386 is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 libgl1-mesa-glx-lts-utopic:i386 : Depends: libudev1:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

« Last Edit: February 24, 2016, 05:14:40 pm by AndyInMokum »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Can't install Steam
« Reply #3 on: December 08, 2015, 06:53:42 pm »
can you install aptitude:
Code: [Select]
sudo apt-get install aptitude
then post the output from:
Code: [Select]
sudo aptitude install -s libc6:i386 libgl1-mesa-dri-lts-utopic:i386 libgl1-mesa-glx-lts-utopic:i386 libglapi-mesa-lts-utopic:i386
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline rickc

  • Jr. Member
  • **
  • Posts: 60
  • Karma: 10
    • View Profile
  • Peppermint version(s): 9
Re: Can't install Steam
« Reply #4 on: December 09, 2015, 02:33:40 am »
The following NEW packages will be installed:
  libcgmanager0:i386{a} libgl1-mesa-glx-lts-utopic:i386 libudev1:i386{a}
0 packages upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 207 kB of archives. After unpacking 1,032 kB will be used.
Do you want to continue? [Y/n/?]

When I do Y I simply get

 Would download/install/remove packages



Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Can't install Steam
« Reply #5 on: December 09, 2015, 08:25:21 am »
Yeah that's because we told it to only do a "simulated" run .. I didn't want aptitude to actually do the installing, as apt wouldn't have been fully aware of the changes .. I only wanted to "see" what aptitude would have done to resolve the situation.

Run:
Code: [Select]
sudo apt-get install libcgmanager0:i386 libgl1-mesa-glx-lts-utopic:i386 libudev1:i386 libc6:i386 libgl1-mesa-dri-lts-utopic:i386 libglapi-mesa-lts-utopic:i386
then
Code: [Select]
sudo apt-get install steam
then
Code: [Select]
steam
« Last Edit: December 09, 2015, 08:30:07 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline rickc

  • Jr. Member
  • **
  • Posts: 60
  • Karma: 10
    • View Profile
  • Peppermint version(s): 9
Re: Can't install Steam
« Reply #6 on: December 09, 2015, 10:52:35 am »
Thank you so much!

That worked brilliantly

I've posted my general first impressions on this distro over at the introduce yourself thread.  Suffice to say, I'll be sticking around!

Thanks again
 :)

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Can't install Steam
« Reply #7 on: December 09, 2015, 11:00:44 am »
You're most welcome :)

If you're happy with the solution, can you please remeber to mark the topic (SOLVED) .. you can do this by editing the FIRST posting in this topic, and changing:-

Subject:  Can't install Steam (SOLVED)

This may help future searchers find a working solution.

Thanks in advance :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec