Choose style:

Author Topic: Network disabled (Solved)  (Read 6294 times)

0 Members and 1 Guest are viewing this topic.

Offline Shamgar

  • Jr. Member
  • **
  • Posts: 44
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Network disabled
« Reply #30 on: December 31, 2015, 01:56:23 am »
Code: [Select]
shamgar@Pungolo ~ $ sudo service networking stop
[sudo] password for shamgar:
stop: Job failed while stopping
shamgar@Pungolo ~ $ sudo modprobe eeepc-wmi
modprobe: ERROR: could not insert 'eeepc_wmi': No such device
shamgar@Pungolo ~ $ sudo modprobe rt2800pci
shamgar@Pungolo ~ $ sudo service networking start
start: Job is already running: networking

by the way now, for some reason I can't explain, there are no more error messages during the boot, and in the boot itself the wireless option now stay one even if I reboot.

Offline darthlukan

  • Developer
  • Member
  • *****
  • Posts: 157
  • Karma: 27
  • Sith
    • View Profile
    • Brian C. Tomlinson dot com
  • Peppermint version(s): DEV
Re: Network disabled
« Reply #31 on: December 31, 2015, 03:36:44 am »
Chances are it was the hardware switch being glitchy. Now that you've got the module loaded at least once and the hardware switch is on, the setting should survive reboots (since the kernel will auto-load the module when it sees the hardware switch is "on" before the network service is started).

One thing you can do to make sure the module is loaded no matter what, is to perform the following:

Code: [Select]
$ sudo touch /etc/modprobe.d/10_custom.conf
$ sudo echo rt2800pci >> /etc/modules.d/10_custom.conf

The first command creates a custom config file for module loading if it doesn't already exist. The second command adds the module name to that file (if the file already exists, the ">>" will append rather than overwrite previous entries) so that it is automatically picked up by the kernel module loader on bootup. The reason for placing "10_" in the filename like that is because the module loader parses the number and will load that file before any others that might be in the same directory. For example, 10_custom.conf will load before 40_display.conf. By default, peppermint doesn't use numeric prefixes, so the loader loads in alphabetical order. Using the numeric prefix in this case will make that file load before the default peppermint files.
Team Peppermint | GPG: 3694569D | Github

Offline Shamgar

  • Jr. Member
  • **
  • Posts: 44
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Network disabled
« Reply #32 on: January 05, 2016, 04:50:16 am »
When I do the second command:

Code: [Select]
shamgar@Pungolo ~ $ sudo echo rt2800pci >> /etc/modules.d/10_custom.conf
bash: /etc/modules.d/10_custom.conf: File o directory non esistente

translated it says "file or directory don't exist"

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25659
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Network disabled
« Reply #33 on: January 05, 2016, 12:39:44 pm »
try:
Code: [Select]
echo "rt2800pci" | sudo tee -a /etc/modprobe.d/10_custom.conf
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Shamgar

  • Jr. Member
  • **
  • Posts: 44
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Network disabled
« Reply #34 on: January 11, 2016, 03:11:29 am »
I did it. Now?  :)

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25659
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Network disabled
« Reply #35 on: January 11, 2016, 05:09:55 pm »
I did it. Now?  :)

Is that a question ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Shamgar

  • Jr. Member
  • **
  • Posts: 44
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Network disabled
« Reply #36 on: January 15, 2016, 02:02:28 am »
Yes it was a question. I followed the instructions, but the problem remain...  :'(

Even if wireless card is turned on I still can't see any wi-fi connections




Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25659
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Network disabled
« Reply #37 on: January 15, 2016, 06:30:50 am »
So the problem isn't that the driver isn't loading, but that it doesn't connect ?

Next time it won't display any networks, open a terminal and copy the output from the following commands to a text file .. so you can post them later.
Code: [Select]
lsmod | grep 2800
and
Code: [Select]
rfkill list
and
Code: [Select]
iwlist scan
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Shamgar

  • Jr. Member
  • **
  • Posts: 44
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Network disabled
« Reply #38 on: January 16, 2016, 02:01:51 am »
Code: [Select]
shamgar@Pungolo ~ $ lsmod | grep 2800
rt2800pci              13398  0
rt2800mmio             16189  1 rt2800pci
rt2800lib              83150  2 rt2800pci,rt2800mmio
rt2x00pci              13111  1 rt2800pci
rt2x00mmio             13395  2 rt2800pci,rt2800mmio
rt2x00lib              48886  5 rt2x00pci,rt2800lib,rt2800pci,rt2800mmio,rt2x00mmio
mac80211              563196  3 rt2x00lib,rt2x00pci,rt2800lib
eeprom_93cx6           13168  1 rt2800pci
crc_ccitt              12627  1 rt2800lib
shamgar@Pungolo ~ $ rfkill list
0: eeepc-wlan: Wireless LAN
Soft blocked: yes
Hard blocked: no
1: eeepc-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
2: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
shamgar@Pungolo ~ $ iwlist scan
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

usb0      Interface doesn't support scanning.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25659
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Network disabled
« Reply #39 on: January 16, 2016, 06:01:47 am »
Next time it happens, can you check if running
Code: [Select]
rfkill unblock all
or
Code: [Select]
sudo rfkill unblock all
makes wireless start working again ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Shamgar

  • Jr. Member
  • **
  • Posts: 44
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Network disabled
« Reply #40 on: January 18, 2016, 06:09:53 am »
I Did it. I also did "rfkill list":

Code: [Select]
shamgar@Pungolo ~ $ rfkill list
0: eeepc-wlan: Wireless LAN
Soft blocked: no
Hard blocked: no
1: eeepc-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
2: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
5: phy2: Wireless LAN
Soft blocked: no
Hard blocked: no

So Wirless LAN Soft blocked turned to "no" after I did "sudo rfkill unblock all", but if I click in the status bar icon I read "wi-fi" disabled. I also tried to turn on wi-fi with the key shortcut (Fn+F2), and when I do again "rfkill list" Wirless Lan Soft blocked turned to "yes"

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25659
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Network disabled
« Reply #41 on: January 18, 2016, 01:29:48 pm »
I'd expect Fn+F2 to toggle the rfkill between softblocked and not softblocked depending on how many times you hit it.

But does both making sure it says it's NOT softblocked, and right-clicking the networkmanager icon and selecting "Enable Wi-Fi" allow wireless to start working ?

If so, which is the one that appears to be changing itself ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Shamgar

  • Jr. Member
  • **
  • Posts: 44
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Network disabled
« Reply #42 on: January 21, 2016, 02:02:21 am »
PCNetSpec and you all people that helped me, this is a great day for us all  :D

I did
Code: [Select]
sudo rfkill unblock all

then I did
Code: [Select]
rfkill list
to be sure everthing is unblocked

So in the end I right clicked on the network icon and I noticed the option "wi-fi enabled". I clicked and now, after two months, my old netbook is again connected via wi-fi to the rest of the world

Thank you very much for your patience, kindness and support  :)

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25659
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Network disabled (Solved)
« Reply #43 on: January 21, 2016, 01:57:55 pm »
Great stuff .. happy it's now working :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec