Choose style:

Author Topic: How to completely disable touchpad? [SOLVED]  (Read 2560 times)

0 Members and 1 Guest are viewing this topic.

Offline paulus

  • Member
  • ***
  • Posts: 194
  • Karma: 4
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10
How to completely disable touchpad? [SOLVED]
« on: November 24, 2015, 01:18:58 pm »
Hi,

I just installed Peppermint OS 6 on my Medion Akoya E1210, a 32-bits netbook.

The bottleneck is the touchpad: in the first place this is defective; secondly I never use it, and therefor want to disable it.

I found several threads here but all with just a temporary period of disabling; I am looking for a permanent solution.

I tried to disable the touchpad withing the BIOS, but no entry exists for this.

Of course there is an option in the Peppermint Control Center to disable the touchpad, but that doesn't work: after pressing, touching the touchpad, the OS becomes unresponsive, and to solve that I have to restart the OS! >:(

Who knows a way to completely disable the touchpad permanently, so not just for one run?

Many thanks! ;)
« Last Edit: November 24, 2015, 03:29:26 pm by paulus »

Offline scifidude79

  • Global Moderator
  • Hero
  • *****
  • Posts: 4029
  • Karma: 863
    • View Profile
  • Peppermint version(s): Peppermint 9
Re: How to completely disable touchpad?
« Reply #1 on: November 24, 2015, 01:23:24 pm »
Usually, there is an option in the BIOS.  It may not be called Touchpad, it may be called "Internal Pointing Device," or some such.

Offline paulus

  • Member
  • ***
  • Posts: 194
  • Karma: 4
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: How to completely disable touchpad?
« Reply #2 on: November 24, 2015, 01:25:49 pm »
Hi scifidude79,

I searched the whole BIOS, but no entry for the touchpad. I did a thorough search before starting this thread! ::)

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26290
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: How to completely disable touchpad?
« Reply #3 on: November 24, 2015, 02:15:14 pm »
Run:
Code: [Select]
xinput --list
the output will be similar to:
Code: [Select]
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=12   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ Laptop_Integrated_Webcam_1.3M             id=10   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=11   [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                          id=13   [slave  keyboard (3)]
in the above example the touchpad is device 12 .. so to disable it you'd run:
Code: [Select]
xinput set-prop 12 "Device Enabled" 0
and to re-enable it
Code: [Select]
xinput set-prop 12 "Device Enabled" 1
« Last Edit: November 24, 2015, 02:17:19 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline paulus

  • Member
  • ***
  • Posts: 194
  • Karma: 4
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: How to completely disable touchpad?
« Reply #4 on: November 24, 2015, 02:30:50 pm »
Hi PCNetSpec,

Great, but only for a single run! :(

Could you describe how to re-disable the touchpad every time after reboot?

Thank you!

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26290
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: How to completely disable touchpad?
« Reply #5 on: November 24, 2015, 02:41:33 pm »
Run:
Code: [Select]
gedit ~/.config/autostart/disable-touchpad.desktop
when a blank file opens, make it read:
Code: [Select]
[Desktop Entry]
Type=Application
Name=Disable Touchpad
Comment=Disable the Touchpad
Exec=bash -c 'xinput set-prop 12 "Device Enabled" 0'
NotShowIn=LXDE;
SAVE the file and exit gedit.

Log off/on (or reboot) to test
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline paulus

  • Member
  • ***
  • Posts: 194
  • Karma: 4
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: How to completely disable touchpad?
« Reply #6 on: November 24, 2015, 02:57:15 pm »
Unfortunately after reboot of re-logging it is not permanent.
What do I do wrong? :-\

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26290
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: How to completely disable touchpad?
« Reply #7 on: November 24, 2015, 03:02:37 pm »
What's the contents of:
Code: [Select]
gedit ~/.config/autostart/disable-touchpad.desktop
and the output from:
Code: [Select]
xinput --list
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline paulus

  • Member
  • ***
  • Posts: 194
  • Karma: 4
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: How to completely disable touchpad?
« Reply #8 on: November 24, 2015, 03:04:24 pm »
Hi PCNetSpec,

I found out myself what went wrong.

The last step I had to do is to set a V next to the entry Disable Touchpad in the list Autostart of LXSession configuration! It isn't done just by making the file: it has to be done manually.
Anyway: it now works, for which I am grateful! Thank you, PCNetSpec! :)
« Last Edit: November 24, 2015, 03:11:08 pm by paulus »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26290
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: How to completely disable touchpad?
« Reply #9 on: November 24, 2015, 03:16:28 pm »
You're most welcome :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec