Choose style:

Author Topic: installing wow in playonlinux  (Read 4181 times)

0 Members and 1 Guest are viewing this topic.

Offline bubadubadoo

  • Jr. Member
  • **
  • Posts: 38
  • Karma: 2
  • New Forum User
    • View Profile
  • Peppermint version(s): peppermint 8
installing wow in playonlinux
« on: November 22, 2015, 12:05:16 pm »
I've done this before and the game runs just fine, but I'm having trouble installing it on my new laptop. It's a 64-bit installation, my graphics card is nVidia geforce 950m and I'm using the proprietary nvidia-352-updates drivers. It installs the battle.net client, but as soon as it tries to actually run it and install wow it crashes, and when I run it through terminal the output I get is
Code: [Select]
Looking for python... 2.7.6 - selected
[main] Message: PlayOnLinux (4.2.2) is starting
[clean_tmp] Message: Cleaning temp directory
Script started /home/mine/.PlayOnLinux/shortcuts/Battle.net
[POL_System_CheckFS] Message: Checking filesystem for Battle.net Launcher.exe
[POL_Wine] Message: Running wine-1.7.45 Battle.net Launcher.exe (Working directory : /home/mine/.PlayOnLinux/wineprefix/wow/drive_c/Program Files (x86)/Battle.net)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
<html><head><title>Object moved</title></head><body>
<h2>Object moved to <a href="http://www.blizzard.com/404">here</a>.</h2>
</body></html>
<html><head><title>Object moved</title></head><body>
<h2>Object moved to <a href="http://www.blizzard.com/404">here</a>.</h2>
</body></html>
<html><head><title>Object moved</title></head><body>
<h2>Object moved to <a href="http://www.blizzard.com/404">here</a>.</h2>
</body></html>
[POL_Wine] Message: Wine return: 0
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
X Error of failed request:  GLXUnsupportedPrivateRequest
  Major opcode of failed request:  155 (GLX)
  Minor opcode of failed request:  16 (X_GLXVendorPrivate)
  Serial number of failed request:  2383
  Current serial number in output stream:  2384
I have no idea how to fix this issue, any help would be appreciated

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: installing wow in playonlinux
« Reply #1 on: November 22, 2015, 03:20:45 pm »
it's highly likely it's a problem with the nvidia proprietary drivers:
https://askubuntu.com/questions/541343/problems-with-libgl-fbconfigs-swrast-through-each-update

how did you install the proprietary driver ?

If you installed them via "Additional Drivers", which options is it offering you, and which one did you choose ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline bubadubadoo

  • Jr. Member
  • **
  • Posts: 38
  • Karma: 2
  • New Forum User
    • View Profile
  • Peppermint version(s): peppermint 8
Re: installing wow in playonlinux
« Reply #2 on: November 22, 2015, 03:23:45 pm »
I did install through "Additional drivers", and it gives me options for nvidia-352, nvidia-352-updates, and xserver-xorg-video-nouveau. I did find that thread before as well but every time I try messing with those things I break something.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: installing wow in playonlinux
« Reply #3 on: November 22, 2015, 05:05:30 pm »
Have you tried both nvidia-352 and nvidia-352-updates ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline bubadubadoo

  • Jr. Member
  • **
  • Posts: 38
  • Karma: 2
  • New Forum User
    • View Profile
  • Peppermint version(s): peppermint 8
Re: installing wow in playonlinux
« Reply #4 on: November 22, 2015, 05:09:00 pm »
I just tried nvidia-352, and it gives me the same error.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: installing wow in playonlinux
« Reply #5 on: November 22, 2015, 05:16:24 pm »
what's the output from:
Code: [Select]
sudo find /usr -iname "*libGL.so*" -exec ls -l {} \;

[EDIT]

Can you also post the output from:
Code: [Select]
dpkg -l | grep libgl1-mesa-dri
« Last Edit: November 22, 2015, 05:21:30 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline bubadubadoo

  • Jr. Member
  • **
  • Posts: 38
  • Karma: 2
  • New Forum User
    • View Profile
  • Peppermint version(s): peppermint 8
Re: installing wow in playonlinux
« Reply #6 on: November 22, 2015, 06:41:53 pm »
output of sudo find /usr -iname "*libGL.so*" -exec ls -l {} \;
Code: [Select]
-rw-r--r-- 1 root root 593372 Feb 12  2015 /usr/lib/i386-linux-gnu/mesa/libGL.so.1.2.0
lrwxrwxrwx 1 root root 14 Feb 12  2015 /usr/lib/i386-linux-gnu/mesa/libGL.so.1 -> libGL.so.1.2.0
-rw-r--r-- 1 root root 586264 Feb 12  2015 /usr/lib/x86_64-linux-gnu/mesa/libGL.so.1.2.0
lrwxrwxrwx 1 root root 14 Feb 12  2015 /usr/lib/x86_64-linux-gnu/mesa/libGL.so.1 -> libGL.so.1.2.0
lrwxrwxrwx 1 root root 10 Nov 16 14:51 /usr/lib/nvidia-352/libGL.so -> libGL.so.1
-rw-r--r-- 1 root root 1218248 Nov  7 23:51 /usr/lib/nvidia-352/libGL.so.352.63
lrwxrwxrwx 1 root root 15 Nov 16 14:51 /usr/lib/nvidia-352/libGL.so.1 -> libGL.so.352.63
lrwxrwxrwx 1 root root 10 Nov 16 14:51 /usr/lib32/nvidia-352/libGL.so -> libGL.so.1
-rw-r--r-- 1 root root 1047532 Nov  7 23:53 /usr/lib32/nvidia-352/libGL.so.352.63
lrwxrwxrwx 1 root root 15 Nov 16 14:51 /usr/lib32/nvidia-352/libGL.so.1 -> libGL.so.352.63
output of dpkg -l | grep libgl1-mesa-dri
Code: [Select]
rc  libgl1-mesa-dri:amd64                       10.1.3-0ubuntu0.4                       amd64        free implementation of the OpenGL API -- DRI modules
ii  libgl1-mesa-dri-lts-utopic:amd64            10.3.2-0ubuntu1~trusty2                 amd64        free implementation of the OpenGL API -- DRI modules
ii  libgl1-mesa-dri-lts-utopic:i386             10.3.2-0ubuntu1~trusty2                 i386         free implementation of the OpenGL API -- DRI modules
i had to install libgl1-mesa-dri-lts-utopic instead of libgl1-mesa-dri because otherwise steam wouldn't work, and trying to install libgl1-mesa-dri led to dependency issues and trying to fix those screwed up my graphics drivers or something and i had to reinstall because i didn't know how to fix it

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: installing wow in playonlinux
« Reply #7 on: November 22, 2015, 07:50:25 pm »
Can you post the contents of:
Code: [Select]
gedit /etc/ld.so.conf.d/zz_i386-biarch-compat.conf
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline bubadubadoo

  • Jr. Member
  • **
  • Posts: 38
  • Karma: 2
  • New Forum User
    • View Profile
  • Peppermint version(s): peppermint 8
Re: installing wow in playonlinux
« Reply #8 on: November 22, 2015, 07:51:34 pm »
Code: [Select]
# Legacy biarch compatibility support
/lib32
/usr/lib32

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: installing wow in playonlinux
« Reply #9 on: November 22, 2015, 07:57:34 pm »
OK, run:
Code: [Select]
sudo gedit /etc/ld.so.conf.d/zz_i386-biarch-compat.conf
and when the file opens for editing, swap the order of the 2 bottom lines .. so it now reads:-
Code: [Select]
# Legacy biarch compatibility support
/usr/lib32
/lib32
SAVE the file, and exit gedit.

Back in the terminal run:
Code: [Select]
sudo ldconfig
Now try using PlayOnLinux again and see if you still get that error.

Source:
http://forums.linuxmint.com/viewtopic.php?f=191&t=146226
and someone who says it worked for them:
http://www.linuxforums.org/forum/ubuntu-linux/202104-correct-driver-use.html
« Last Edit: November 22, 2015, 08:13:39 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline bubadubadoo

  • Jr. Member
  • **
  • Posts: 38
  • Karma: 2
  • New Forum User
    • View Profile
  • Peppermint version(s): peppermint 8
Re: installing wow in playonlinux
« Reply #10 on: November 22, 2015, 07:59:56 pm »
I'm still getting the same error.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: installing wow in playonlinux
« Reply #11 on: November 22, 2015, 08:11:28 pm »
Sorry I missed a step.

With that edit still in place, run:
Code: [Select]
sudo ldconfig
THEN try PlayOnLinux again.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline bubadubadoo

  • Jr. Member
  • **
  • Posts: 38
  • Karma: 2
  • New Forum User
    • View Profile
  • Peppermint version(s): peppermint 8
Re: installing wow in playonlinux
« Reply #12 on: November 22, 2015, 08:12:28 pm »
same error, and ldconfig is giving no output, i'm not sure if it's supposed to

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: installing wow in playonlinux
« Reply #13 on: November 22, 2015, 08:17:57 pm »
Does running:
Code: [Select]
export LD_LIBRARY_PATH="/usr/lib32/:/usr/lib/" 
then starting the battle.net installation from the command line still give that error ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline bubadubadoo

  • Jr. Member
  • **
  • Posts: 38
  • Karma: 2
  • New Forum User
    • View Profile
  • Peppermint version(s): peppermint 8
Re: installing wow in playonlinux
« Reply #14 on: November 22, 2015, 08:20:32 pm »
Still the same error.