Author Topic: Peppermint not powering down (SOLVED)  (Read 4381 times)

Offline GNULINUX

  • Member
  • ***
  • Posts: 986
  • Karma: 311
    • View Profile
  • Peppermint version(s): Peppermint Six (x64)
Peppermint not powering down (SOLVED)
« on: November 16, 2015, 09:28:12 am »
Hi,

Today I made my second dualboot (W7-P6) on an old PC and everything went well until I was trying to shutdown the system...
Peppermint won't power down the machine and stays forever at the following screen and I have to power down manually.
W7 is shutting down normal.



I tryed different drivers for the nVidia card (tested and legacy) with no difference. The X.Org X server driver gives me the Peppermint logo but the machine is not powering down either.

P6 output:

Code: [Select]
extramint@extramint-home ~ $ inxi -F
System:    Host: extramint-home Kernel: 3.16.0-53-generic x86_64 (64 bit) Desktop: N/A Distro: Peppermint Six
Machine:   Mobo: Intel model: DG33BU version: AAD79951-407
           Bios: Intel version: DPP3510J.86A.0293.2007.1002.1519 date: 10/02/2007
CPU:       Dual core Intel Core2 Duo CPU E6550 (-MCP-) cache: 4096 KB flags: (lm nx sse sse2 sse3 ssse3 vmx)
           Clock Speeds: 1: 1998.00 MHz 2: 1998.00 MHz
Graphics:  Card: NVIDIA GF119 [GeForce GT 520]
           X.Org: 1.16.0 drivers: nvidia (unloaded: fbdev,vesa,nouveau) Resolution: 1280x1024@60.0hz
           GLX Renderer: GeForce GT 520/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 346.96
Audio:     Card-1: NVIDIA GF119 HDMI Audio Controller driver: snd_hda_intel Sound: ALSA ver: k3.16.0-53-generic
           Card-2: Intel 82801I (ICH9 Family) HD Audio Controller driver: snd_hda_intel
Network:   Card-1: Intel 82566DC-2 Gigabit Network Connection driver: e1000e
           IF: eth0 state: down mac: #Edited Out
           Card-2: D-Link System AirPlus G DWL-G122 Wireless Adapter(rev.C1) [Ralink RT2571W] driver: rt73usb
           IF: wlan0 state: up mac: #Edited Out
Drives:    HDD Total Size: 160.0GB (3.6% used) 1: id: /dev/sda model: WDC_WD1600AAJS size: 160.0GB
Partition: ID: / size: 47G used: 5.5G (13%) fs: ext4 ID: swap-1 size: 3.21GB used: 0.00GB (0%) fs: swap
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 35.0C mobo: N/A gpu: 36C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 154 Uptime: 21 min Memory: 311.1/2999.4MB Client: Shell (bash) inxi: 1.9.17
extramint@extramint-home ~ $
Is there a solution for this problem?
Thanks in advance!
« Last Edit: November 17, 2015, 12:21:45 pm by GNULINUX »
Peppermint 6  (x64)   -   Windows 7 Ultimate SP1  (x64)
Running different OS flavors in VirtualBox, just for fun!

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Peppermint not powering down
« Reply #1 on: November 16, 2015, 10:20:50 am »
In your BIOS. is there a setting for APM (advanced Power Management) ? .. if so, does the PC shut down properly if you change that setting ?

Or maybe the Wake On Lan settings ?

Or maybe there's an ACPI setting in the BIOS ?
« Last Edit: November 16, 2015, 10:49:15 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline GNULINUX

  • Member
  • ***
  • Posts: 986
  • Karma: 311
    • View Profile
  • Peppermint version(s): Peppermint Six (x64)
Re: Peppermint not powering down
« Reply #2 on: November 16, 2015, 11:51:46 am »
Under "Power" in the BIOS:

Code: [Select]
After Power Failure <Stay off>
Wake on LAN from S5 <Stay off>
ACPI Suspend State <S3 State>
EIST <Enable>
C2 State <Disable>
Wake system from S5 <Disable>
The only other choise with "ACPI Suspend State" is "S1 State" but it didn't change anything regarding the problem.

Any other ideas?
Peppermint 6  (x64)   -   Windows 7 Ultimate SP1  (x64)
Running different OS flavors in VirtualBox, just for fun!

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Peppermint not powering down
« Reply #3 on: November 16, 2015, 12:48:40 pm »
That motherboard (Intel DG33BU) was well known for its buggy ACPI implementation.

Try this, open a terminal and run:
Code: [Select]
sudo gedit /etc/default/grubfind the line that reads:-

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

and change to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"

SAVE the file and exit gedit.

Back in the terminal, run:
Code: [Select]
sudo update-grubNow REBOOT.

After rebooting the first time, does it shutdown properly on the second attempt ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline GNULINUX

  • Member
  • ***
  • Posts: 986
  • Karma: 311
    • View Profile
  • Peppermint version(s): Peppermint Six (x64)
Re: Peppermint not powering down
« Reply #4 on: November 16, 2015, 01:36:02 pm »
No effect...  :(
I even tried with "ACPI Suspend State" on "S3 State" and "S1 State" in BIOS.

Extra info: Before Peppermint OS I had Mint 17 Xfce on it and that powered down fully.

Any other ideas?
Peppermint 6  (x64)   -   Windows 7 Ultimate SP1  (x64)
Running different OS flavors in VirtualBox, just for fun!

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Peppermint not powering down
« Reply #5 on: November 16, 2015, 01:55:25 pm »
OK, first let's undo that change

Run
Code: [Select]
sudo gedit /etc/default/grub
find the line that reads:-

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"

and change to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

SAVE the file and exit gedit.

Back in the terminal, run:
Code: [Select]
sudo update-grubthen REBOOT.

Now can you tell me which version of Mint 17 it was .. 17, 17.1 or 17.2 ?

and do you want to try upgrading to the 3.19 kernel and see if that helps ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline GNULINUX

  • Member
  • ***
  • Posts: 986
  • Karma: 311
    • View Profile
  • Peppermint version(s): Peppermint Six (x64)
Re: Peppermint not powering down
« Reply #6 on: November 16, 2015, 02:05:41 pm »
It was Mint 17 Xfce (x64).

Yes, I want to try... it's on an extra machine and my other Peppermint is flawless (thanks to you).
As long as the dualboot with W7 works it's ok!  :P
Peppermint 6  (x64)   -   Windows 7 Ultimate SP1  (x64)
Running different OS flavors in VirtualBox, just for fun!

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Peppermint not powering down
« Reply #7 on: November 16, 2015, 03:08:03 pm »
OK, Mint17 used the 3.13 kernel (as did Peppermint 5 as they were both built on Ubuntu 14.04).... whereas Peppermint 6, Ubuntu 14.04.2, and Mint 17.2 all use the 3.16 kernel.

If you want to try downgrading the kernel and xorg stack to 3.13 carry on below .. but it would be a VERY good idea to backup anything you cannot afford to loose first .. don't blame me if this all goes horribly wrong;



To downgrade to the 3.13 kernel and xorg stack (as used in Ubuntu 14.04/Mint 17/Peppermint 5)

First if you've switched to any proprietary graphics drivers it would be a good idea to switch back to the open sourced ones, and reboot

OK, open a terminal and run these commands in sequence:
(as they're quite long commands, it'd  be best to copy/paste them one at a time into your terminal, and run them .. make SURE you get the whole command as they scroll off the page to the right)
Code: [Select]
sudo apt-get remove --purge linux-generic-lts-utopic xserver-xorg-lts-utopic libgl1-mesa-glx-lts-utopic libegl1-mesa-drivers-lts-utopicthen:
Code: [Select]
sudo apt-get install --reinstall --install-recommends linux-generic xserver-xorg libgl1-mesa-glx libegl1-mesa-drivers xserver-xorg-input-allthen:
Code: [Select]
sudo apt-get install xserver-xorg-video-neomagic xserver-xorg-video-vesa xserver-xorg-input-evdev xserver-xorg-video-vmware xserver-xorg-video-mach64 xserver-xorg-video-radeon xserver-xorg-video-tdfx xserver-xorg-video-fbdev libgl1-mesa-glx xorg xserver-xorg-video-intel libgbm1 xserver-xorg-video-mga libegl1-mesa-drivers libxatracker2 libgles1-mesa xserver-xorg-video-sisusb xserver-xorg-core xserver-xorg-video-modesetting xserver-xorg-video-cirrus xserver-xorg-video-ati xserver-xorg-input-synaptics libgl1-mesa-dri libwayland-egl1-mesa xserver-xorg-input-all xserver-xorg-input-mouse libgles2-mesa xserver-xorg-video-savage xserver-xorg-video-trident xserver-xorg-video-siliconmotion libegl1-mesa xserver-xorg xserver-xorg-input-vmmouse xserver-xorg-video-r128 libglapi-mesa xserver-xorg-video-nouveau libopenvg1-mesa xserver-xorg-input-wacom linux-generic xserver-xorg-video-openchrome xserver-xorg-video-allOnce that command completes and leaves you back at a $ prompt, REBOOT

But during the boot, hit and hold the Shift key to access the GRUB menu.

Now you need to make SURE you boot the 3.13 kernel, not the 3.16 kernel


Once you've done that, come back here and post the output from:
Code: [Select]
uname -aso I can confirm you're booted into the 3.13 kernel before we continue (as we're not quite done yet, but I NEED to confirm you're booted into the 3.13 kernel before the next stage).

Also post the output from:
Code: [Select]
dpkg -l | grep lts-utopicand
Code: [Select]
dpkg -l | grep 3.16
« Last Edit: November 16, 2015, 03:15:17 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline GNULINUX

  • Member
  • ***
  • Posts: 986
  • Karma: 311
    • View Profile
  • Peppermint version(s): Peppermint Six (x64)
Re: Peppermint not powering down
« Reply #8 on: November 17, 2015, 01:46:11 am »
Yes, I understand the risk!  ;)

Back in Peppermint:

Code: [Select]
extramint@extramint-home ~ $ uname -a
Linux extramint-home 3.13.0-68-generic #111-Ubuntu SMP Fri Nov 6 18:17:06 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
extramint@extramint-home ~ $ dpkg -l | grep lts-utopic
ii  linux-headers-generic-lts-utopic            3.16.0.53.44                            amd64        Generic Linux kernel headers
ii  linux-image-generic-lts-utopic              3.16.0.53.44                            amd64        Generic Linux kernel image
extramint@extramint-home ~ $ dpkg -l | grep 3.16
ii  linux-headers-3.16.0-46                     3.16.0-46.62~14.04.1                    all          Header files related to Linux kernel version 3.16.0
ii  linux-headers-3.16.0-46-generic             3.16.0-46.62~14.04.1                    amd64        Linux kernel headers for version 3.16.0 on 64 bit x86 SMP
ii  linux-headers-3.16.0-53                     3.16.0-53.72~14.04.1                    all          Header files related to Linux kernel version 3.16.0
ii  linux-headers-3.16.0-53-generic             3.16.0-53.72~14.04.1                    amd64        Linux kernel headers for version 3.16.0 on 64 bit x86 SMP
ii  linux-headers-generic-lts-utopic            3.16.0.53.44                            amd64        Generic Linux kernel headers
rc  linux-image-3.16.0-37-generic               3.16.0-37.51~14.04.1                    amd64        Linux kernel image for version 3.16.0 on 64 bit x86 SMP
ii  linux-image-3.16.0-46-generic               3.16.0-46.62~14.04.1                    amd64        Linux kernel image for version 3.16.0 on 64 bit x86 SMP
ii  linux-image-3.16.0-53-generic               3.16.0-53.72~14.04.1                    amd64        Linux kernel image for version 3.16.0 on 64 bit x86 SMP
rc  linux-image-extra-3.16.0-37-generic         3.16.0-37.51~14.04.1                    amd64        Linux kernel extra modules for version 3.16.0 on 64 bit x86 SMP
ii  linux-image-extra-3.16.0-46-generic         3.16.0-46.62~14.04.1                    amd64        Linux kernel extra modules for version 3.16.0 on 64 bit x86 SMP
ii  linux-image-extra-3.16.0-53-generic         3.16.0-53.72~14.04.1                    amd64        Linux kernel extra modules for version 3.16.0 on 64 bit x86 SMP
ii  linux-image-generic-lts-utopic              3.16.0.53.44                            amd64        Generic Linux kernel image
extramint@extramint-home ~ $
The machine seems fully working, I leave it on...
I'm ready to proceed when you are.
Peppermint 6  (x64)   -   Windows 7 Ultimate SP1  (x64)
Running different OS flavors in VirtualBox, just for fun!

Offline Slim.Fatz

  • Global Moderator
  • Veteran
  • *****
  • Posts: 2343
  • Karma: 616
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 10 - 64bit
Re: Peppermint not powering down
« Reply #9 on: November 17, 2015, 03:07:51 am »
Hi GNULINUX,

Please be patient. PCNoSleep may actually be sleeping at the moment!  ;D

He will get back to you ASAP, I'm sure.

Regards,

-- Slim
Respect science, respect nature, respect each other.

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome

Offline GNULINUX

  • Member
  • ***
  • Posts: 986
  • Karma: 311
    • View Profile
  • Peppermint version(s): Peppermint Six (x64)
Re: Peppermint not powering down
« Reply #10 on: November 17, 2015, 03:58:13 am »
PCMustSleep  :D

No problem, I understand!
Peppermint 6  (x64)   -   Windows 7 Ultimate SP1  (x64)
Running different OS flavors in VirtualBox, just for fun!

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Peppermint not powering down
« Reply #11 on: November 17, 2015, 04:09:41 am »
OK PCHadSpleep returns :) .. now that "uname -a" reports you're in the 3.13 kernel .. does the PC shutdown properly (from the 3.13 kernel) ?

So please check with:
Code: [Select]
uname -athat you're still currently booted into the 3.13 kernel .. THEN test a shutdown.

Once we're convinced it works, we'll remove all the 3.16 stuff so it automagically boots 3.13 without any intervention from you.
« Last Edit: November 17, 2015, 04:18:52 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline GNULINUX

  • Member
  • ***
  • Posts: 986
  • Karma: 311
    • View Profile
  • Peppermint version(s): Peppermint Six (x64)
Re: Peppermint not powering down
« Reply #12 on: November 17, 2015, 07:36:17 am »
Hurray! Full shutdown and power off!  8)

I'm now back in Peppermint with the 3.13 kernel.
Peppermint 6  (x64)   -   Windows 7 Ultimate SP1  (x64)
Running different OS flavors in VirtualBox, just for fun!

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Peppermint not powering down
« Reply #13 on: November 17, 2015, 08:14:13 am »
OK, run:
Code: [Select]
uname -ato make 100% sure you're currently booted into the 3.13 kernel .. as long as that says you ARE currently in the 3.13 kernel, run:
Code: [Select]
sudo apt-get remove --purge linux-headers-generic-lts-utopic linux-image-generic-lts-utopic linux-headers-3.16.0-46 linux-headers-3.16.0-46-generic linux-headers-3.16.0-53 linux-headers-3.16.0-53-generic linux-image-3.16.0-37-generic linux-image-3.16.0-46-generic linux-image-3.16.0-53-generic linux-image-extra-3.16.0-37-generic linux-image-extra-3.16.0-46-generic linux-image-extra-3.16.0-53-generic(be sure to get all that long command)

Then REBOOT without doing anything to manually select a kernel .. I want to see if it now AUTOMATICALLY boots into the 3.13 kernel .. does it ?

then post the output from:
Code: [Select]
uname -aand
Code: [Select]
dpkg -l | grep lts-utopicand
Code: [Select]
dpkg -l | grep 3.16again
« Last Edit: November 17, 2015, 08:17:16 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline GNULINUX

  • Member
  • ***
  • Posts: 986
  • Karma: 311
    • View Profile
  • Peppermint version(s): Peppermint Six (x64)
Re: Peppermint not powering down
« Reply #14 on: November 17, 2015, 08:43:10 am »
It boots automatically in the 3.13 kernel and powers down fully.

Code: [Select]
extramint@extramint-home ~ $ uname -a
Linux extramint-home 3.13.0-68-generic #111-Ubuntu SMP Fri Nov 6 18:17:06 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
extramint@extramint-home ~ $ dpkg -l | grep lts-utopic
extramint@extramint-home ~ $ dpkg -l | grep 3.16
extramint@extramint-home ~ $
I think this is a success!

Can I install the nVidia driver again and can I normally update the system?
Peppermint 6  (x64)   -   Windows 7 Ultimate SP1  (x64)
Running different OS flavors in VirtualBox, just for fun!