Choose style:

Author Topic: Installed peppermint 6 64 bit but nothing happens [solved]  (Read 6389 times)

0 Members and 1 Guest are viewing this topic.

Offline ut_icedragon

  • nOOb
  • *
  • Posts: 24
  • Karma: 1
  • New Forum User
    • View Profile
Re: Installed peppermint 6 64 bit but nothing happens
« Reply #30 on: November 10, 2015, 07:45:10 pm »
Okay. Did. Done. Do I boot to LiveUSB, repartition and install?

Sent from my SM-G920V using Tapatalk


Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25661
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Installed peppermint 6 64 bit but nothing happens
« Reply #31 on: November 10, 2015, 08:02:43 pm »
Just boot the LiveUSB, click the "Install Peppermint" desktop icon .. and when asked, tell it to use the whole disk overwriting anything already there.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline ut_icedragon

  • nOOb
  • *
  • Posts: 24
  • Karma: 1
  • New Forum User
    • View Profile
Re: Installed peppermint 6 64 bit but nothing happens
« Reply #32 on: November 10, 2015, 09:06:58 pm »
ITS ALIVE!!!!


Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25661
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Installed peppermint 6 64 bit but nothing happens
« Reply #33 on: November 10, 2015, 09:10:12 pm »
Great stuff .. and well done for sticking at it :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline ut_icedragon

  • nOOb
  • *
  • Posts: 24
  • Karma: 1
  • New Forum User
    • View Profile
Re: Installed peppermint 6 64 bit but nothing happens
« Reply #34 on: November 10, 2015, 09:23:55 pm »
Great stuff .. and well done for sticking at it :)

A couple of things I noticed.

Consistently each time I reinstalled P6, on 64, on the initial boot up, the GRUB menu never came up after the BIOS splash. Only way around it was to press F12 for 'Boot Manager', select HDD, and then it would take me to the GRUB menu. Would boot fine to GRUB each time after.

On 32 bit, GRUB screen again does not come up on first boot. Did same thing. Now on subsequent boots, GRUB still does not appear but after a few seconds of blank screen, P6 will start and boots completely.


Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25661
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Installed peppermint 6 64 bit but nothing happens
« Reply #35 on: November 10, 2015, 09:30:55 pm »
If there's only one OS installed the GRUB menu doesn't automatically display .. to access the GRUB menu you have to hit the Shift key immediately after the BIOS POST screen.

With a single OS, it's generally pointless for GRUB to display .. so it hides itself ;)

If I had to guess wwhat was wrong with the 64bit version, I'd *guess* it was a corrupt ISO download or burn .. but that is a guess

the loop error you were getting is usually caused by GRUB trying to insert a 64bit driver into a 32bit kernel (or vice versa) but as there should onle be 64bit stuff on the 64bit ISO, I can only assume the kernel or driver was corrupt.

[EDIT]

I suppose another cause could be bad sectors on the HDD .. SMART suggests you have 7 sectors reallocated, that's not a problem in its own right but can indicate a failing HDD

There's currently no sectors pending reallocation, so at this point I wouldn't worry about it unless you start getting I/O errors or the SMART reallocated sector count starts to rise.
« Last Edit: November 10, 2015, 09:42:27 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline ut_icedragon

  • nOOb
  • *
  • Posts: 24
  • Karma: 1
  • New Forum User
    • View Profile
Re: Installed peppermint 6 64 bit but nothing happens
« Reply #36 on: November 10, 2015, 09:55:19 pm »
Thanks for the follow up info. I'll keep an eye on the HD too just in case.

Last thing, if I may ask on your guidance one more time, I'd like to get back to dual booting for Peppermint and W7. How should I properly partition the HD for installation of W7 and any tips on how to make sure when I go to install it off the DVD I have, it goes to the right partition?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25661
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Installed peppermint 6 64 bit but nothing happens
« Reply #37 on: November 10, 2015, 10:31:54 pm »
OK as you've only just installed Peppermint (so it wouldn't be a big deal to do it again), I'd say the easiest way would be to install Windows FIRST (so it doesn't overwrite the GRUB bootloader .. though that could be fixed)

How I'd do it

a) wipe the drive (no partitions)

b) install windows, and when it asks how large it should make the partition (and offering the full capacity), lower the number it's offering .. so Windows installs leaving some unpartitioned space at the end of the drive

c) install Peppermint .. and when asked, choose to use "the remaining space" .. Peppermint shouuld then get installed to the unpartitioned space (automatically creating partitions), and GRUB installed, which will pick up the Windows installation.

WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline ut_icedragon

  • nOOb
  • *
  • Posts: 24
  • Karma: 1
  • New Forum User
    • View Profile
Re: Installed peppermint 6 64 bit but nothing happens
« Reply #38 on: November 10, 2015, 10:48:14 pm »
awsome. Thank you so much for all your help on this. Want me to mark the thread as solved?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25661
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Installed peppermint 6 64 bit but nothing happens
« Reply #39 on: November 10, 2015, 11:07:05 pm »
Up to you .. I'd leave it open until you've got the installations done, then close it

post installation issues can go in new topics ;)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline ut_icedragon

  • nOOb
  • *
  • Posts: 24
  • Karma: 1
  • New Forum User
    • View Profile
Re: Installed peppermint 6 64 bit but nothing happens
« Reply #40 on: November 23, 2015, 12:56:39 pm »
Hey, it been a few weeks but I finally got around to doing the wipe and reinstall of Windows 7. I had to use the recovery DVDs I made when I first got the thing (go proactive me), and it went smooth, but nowhere in the process did it give me the option to partition or size the windows installation. I know I can use gparted though P6 USB to create a partition but can you remind me how correctly to do that, and any steps I need to take in process?

Thanks.

EDIT, I found this guide for setting up a dual boot? Will this get me on the right path? I like the talk about setting up a storage partition that can be accessed from either drive. Thoughts?

http://lifehacker.com/5403100/dual-boot-windows-7-and-ubuntu-in-perfect-harmony?sidebar_promotions_icons=testingoff&utm_expid=66866090-67.e9PWeE2DSnKObFD7vNEoqg.1&utm_referrer=https%3A%2F%2Fwww.google.com%2F
« Last Edit: November 23, 2015, 06:21:23 pm by ut_icedragon »

Offline ut_icedragon

  • nOOb
  • *
  • Posts: 24
  • Karma: 1
  • New Forum User
    • View Profile
Re: Installed peppermint 6 64 bit but nothing happens
« Reply #41 on: November 23, 2015, 11:27:25 pm »
So I ended up resizing the windows partition in windows and just ran the P6 32 bit installer from the live USB and let it install in the extra space. Worked great.

Here's the problem, the GRUB menu looks very unfriendly, and there's 2 entries for Windows, named the same thing, but one is the recovery partition, and the other is the full W7. I remember from past experience that booting into the recovery screwed up my GRUB so I would like to edit the GRUB menu so that only two options remain:

1. The default selection is P6, and is named "Peppermint 6"
2: The only other entry is the main W7 option, named "Windows 7"

Years ago the person who introduced me to linux and peppermint was able to set this up (though this was done in person), and I'm wondering if this can be done again?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25661
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Installed peppermint 6 64 bit but nothing happens
« Reply #42 on: November 24, 2015, 05:30:44 am »
It can be hidden, but it's a bit tricky, and -

a) If you get it wrong you could end up with an unbootable system .. only fixable via a LiveCD/LiveUSB
and
b) What happens if you find yourself in the position that you want to access the recovery partition at any point

So here's what I'd suggest.....

Use grub-customiser to place the recovery partition menuentry in a submenu labelled something like "Windows Recovery (DO NOT USE)" .. at least that would separate it from the other top level menu entries, label it clearly, and would mean it takes an extra click to select the recovery partition making accidental selection much harder.

Sound like an idea ?

If so, install grub-customizer with these 3 commands:
Code: [Select]
sudo add-apt-repository ppa:danielrichter2007/grub-customizer
then:
Code: [Select]
sudo apt-get update
then:
Code: [Select]
sudo apt-get install grub-customizer
Now fire up Grub Customizer from the menu

menu > System Tools > Grub Customiser

In Grub Customiser, on the "List Configuration" tab ..

right-click on the entry you know to be the recovery partition entry, and select "Create submenu"

a text entry box should appear directly above it .. in that box type Windows Recovery (DO NOT USE) .. and hit enter.

Now click the "Save" button at the top .. and give it a short while to complete.

Now reboot to test.



If you truly want it hidden, and understand the associated risks .. see here:
https://askubuntu.com/questions/318120/how-do-i-hide-grub-entries

WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline ut_icedragon

  • nOOb
  • *
  • Posts: 24
  • Karma: 1
  • New Forum User
    • View Profile
Re: Installed peppermint 6 64 bit but nothing happens
« Reply #43 on: November 24, 2015, 10:20:59 pm »
Magnificent! Worked great.

Thank You so much.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25661
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Installed peppermint 6 64 bit but nothing happens [solved]
« Reply #44 on: November 25, 2015, 05:23:52 am »
You're most welcome :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec