Choose style:

Author Topic: Wireless & Ethernet not Working After P.6 install. RFKILL switch (SOLVED)  (Read 3777 times)

0 Members and 1 Guest are viewing this topic.

Offline Jonyrokkitt

  • nOOb
  • *
  • Posts: 13
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Wireless & Ethernet not Working After P.6 install. RFKILL switch suspected
« Reply #15 on: November 07, 2015, 12:33:19 pm »
I am going to try the offline route now. Have the files and instructions, will report back shortly

Offline Jonyrokkitt

  • nOOb
  • *
  • Posts: 13
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Wireless & Ethernet not Working After P.6 install. RFKILL switch suspected
« Reply #16 on: November 07, 2015, 12:46:37 pm »
 :-[ - Sorry about the poor formating.

But thats besides the point, because you sorted it like pro.

I rebooted the device, headed over to the network settings, right clicked to enable networking, then right clicked again to enable wifi. Like a butterfly crossed with lighting a password dialog popped up and I logged in.

Awesome, Awesome, Awesome.

Thank you, sir.

Offline Jonyrokkitt

  • nOOb
  • *
  • Posts: 13
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Wireless & Ethernet not Working After P.6 install. RFKILL switch suspected
« Reply #17 on: November 07, 2015, 12:58:07 pm »
Do I mark this as solved - or do you? I cant find a solved button...

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26290
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Wireless & Ethernet not Working After P.6 install. RFKILL switch suspected
« Reply #18 on: November 07, 2015, 01:00:21 pm »
You're most welcome :)

If you're happy with the solution, can you please mark the topic as (SOLVED) .. you can do this by editing the FIRST posting in this topic and appending (SOLVED) to the subject line .. like so:-

Subject: Wireless & Ethernet not Working After P.6 install. RFKILL switch suspected (SOLVED)

Thanks in advance :)
« Last Edit: November 07, 2015, 01:08:14 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Jonyrokkitt

  • nOOb
  • *
  • Posts: 13
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Wireless & Ethernet not Working After P.6 install. RFKILL switch (SOLVED)
« Reply #19 on: November 07, 2015, 01:31:02 pm »
 8) 8) 8) 8) 8) 8) :P :P :P :P :P :P :P :D :D :D :D :D :D

All done. Thanks again!

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1013
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Wireless & Ethernet not Working After P.6 install. RFKILL switch (SOLVED)
« Reply #20 on: November 07, 2015, 01:41:28 pm »
No problem, you'll get the hang of if really quickly  ;).  I forgot something very important too - welcome to the Peppermint Forum  :)!!
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline Jonyrokkitt

  • nOOb
  • *
  • Posts: 13
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Wireless & Ethernet not Working After P.6 install. RFKILL switch (SOLVED)
« Reply #21 on: November 07, 2015, 03:02:26 pm »
Hi Guts,

Quick question:

I upgraded, and replaced the cutter with the updated version. That caused a failure of the wireless. However, I noticed that by running

Code: [Select]
sudo dpkg -i b43-fwcutter_018-2_386i.deb

I got the wireless back up and running. Do you have any suggestions for a permanent fix? Should I downgrade to previous versions?

What dependencies am I hostage to, in terms of packages, the release, and ultimately their ability to respond to this? I have no problems setting a script to run this command everytime I start up, but I am not sure it's a solution.

Offline Jonyrokkitt

  • nOOb
  • *
  • Posts: 13
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Wireless & Ethernet not Working After P.6 install. RFKILL switch (SOLVED)
« Reply #22 on: November 07, 2015, 03:10:47 pm »
I am just being impatient it seems. As long as the package is not upgraded, I just have to be patient, it's an old machine and it takes it's time.
Press wireless rfkill switch, wait ten seconds, colour changes.
That works.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26290
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Wireless & Ethernet not Working After P.6 install. RFKILL switch (SOLVED)
« Reply #23 on: November 07, 2015, 03:12:41 pm »
Run:
Code: [Select]
sudo apt-get update
then
Code: [Select]
sudo apt-get install firmware-b43-fwcutter b43-fwcutter
then do a full system update:
Code: [Select]
sudo apt-get update
then:
Code: [Select]
sudo apt-get upgrade
then
Code: [Select]
sudo apt-get dist-upgrade
then REBOOT.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec