Choose style:

Author Topic: (SOLVED) Desktop: How hide icons (content of user folder)  (Read 1894 times)

0 Members and 1 Guest are viewing this topic.

Offline carpecanem

  • Jr. Member
  • **
  • Posts: 25
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
(SOLVED) Desktop: How hide icons (content of user folder)
« on: October 30, 2015, 05:55:34 pm »
Hi there,

After a reboot, the content of my user folder (the icons of the files and folders) is displayed on the desktop. I didn't have this behaviour before.

Unfortunately I don't remember how I had disabled it in the first place (did I at all?). I found a couple of solutions in the WWW, but none of them can be applied, because the necessary tools or configuration keys do not exist on my installation.

I hope that there is that one config key in that one file, which will solve this problem. Does someone know a solution?

Regards, Mike
« Last Edit: October 31, 2015, 09:14:09 pm by carpecanem »

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1013
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Desktop: How hide icons (content of user folder)
« Reply #1 on: October 30, 2015, 06:30:12 pm »
Hi carpecanem, Have you got dconf-editor installed?  If you have, is this what you're looking for, http://forum.peppermintos.com/index.php/topic,1975.msg19217.html#msg19217?
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline scifidude79

  • Global Moderator
  • Hero
  • *****
  • Posts: 4029
  • Karma: 863
    • View Profile
  • Peppermint version(s): Peppermint 9
Re: Desktop: How hide icons (content of user folder)
« Reply #2 on: October 30, 2015, 06:51:07 pm »
Open the file manager to the /Desktop folder and see if there are shortcut files in there.  If there are, delete them to get rid of the icons.

Offline carpecanem

  • Jr. Member
  • **
  • Posts: 25
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Desktop: How hide icons (content of user folder)
« Reply #3 on: October 31, 2015, 12:38:11 am »
Hi carpecanem, Have you got dconf-editor installed?  If you have, is this what you're looking for, http://forum.peppermintos.com/index.php/topic,1975.msg19217.html#msg19217?

I'm sorry, but that's not the problem. The tutorial deals with the "system icons". I had an empty desktop, but now it displays the content of my user folder.
 

Offline carpecanem

  • Jr. Member
  • **
  • Posts: 25
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Desktop: How hide icons (content of user folder)
« Reply #4 on: October 31, 2015, 12:43:07 am »
Open the file manager to the /Desktop folder and see if there are shortcut files in there.  If there are, delete them to get rid of the icons.

That's not the problem either. Actually, the file manager complained that the link to the specified folder doesn' exist, which I checked manually, and indeed a folder named "Desktop" did not exist. I (re-?)created it, but no change, I still have the content of my user folder on the desktop.

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1013
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Desktop: How hide icons (content of user folder)
« Reply #5 on: October 31, 2015, 03:44:24 am »
Hi carpecanem, what's the output from:
Code: [Select]
ls -a ~/Desktop
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline zebedeeboss

  • Global Moderator
  • Hero
  • *****
  • Posts: 3045
  • Karma: 563
  • Life first... Peppermint a close 2nd :)
    • View Profile
  • Peppermint version(s): P10 / P9 Respin
Re: Desktop: How hide icons (content of user folder)
« Reply #6 on: October 31, 2015, 05:51:49 am »
http://ubuntuforums.org/showthread.php?t=1706643

This may help or it may not :D   a quick google search uncovered this thread.   The principles may apply and need altering slightly to meet your problem here - plus it is quite an old thread...
Be Kind Whenever Possible...   It is Always Possible - Dalai Lama

Linux User #565092
P10 x64 Desktop - AMD Threadripper 2950X - 64Gb RAM - NVIDIA RTX2080Ti 11Gb - 2 x 27" 4k 3840x2160 - 1 x 34" 5120x2160
P9/10 @ P9 x64 Laptop - i7-7700HQ @ 2.80GHz - 8Gb RAM - Nvidia GTX1050 4Gb - 15.6" HD 1920x1080

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25661
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Desktop: How hide icons (content of user folder)
« Reply #7 on: October 31, 2015, 08:36:18 am »
What's the output from:
Code: [Select]
cat ~/.config/user-dirs.dirs
it should be
Quote
# This file is written by xdg-user-dirs-update
# If you want to change or add directories, just edit the line you're
# interested in. All local changes will be retained on the next run
# Format is XDG_xxx_DIR="$HOME/yyy", where yyy is a shell-escaped
# homedir-relative path, or XDG_xxx_DIR="/yyy", where /yyy is an
# absolute path. No other format is supported.
#
XDG_DESKTOP_DIR="$HOME/Desktop"
XDG_DOWNLOAD_DIR="$HOME/Downloads"
XDG_TEMPLATES_DIR="$HOME/Templates"
XDG_PUBLICSHARE_DIR="$HOME/Public"
XDG_DOCUMENTS_DIR="$HOME/Documents"
XDG_MUSIC_DIR="$HOME/Music"
XDG_PICTURES_DIR="$HOME/Pictures"
XDG_VIDEOS_DIR="$HOME/Videos"

If that's not what it reads, run:
Code: [Select]
gedit ~/.config/user-dirs.dirs
and make it read that way.

SAVE the file, then log off/on .. or run:
Code: [Select]
nemo --quit
then fire up:-
Code: [Select]
menu > File Manager
to restart the desktop.
« Last Edit: October 31, 2015, 08:48:45 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline carpecanem

  • Jr. Member
  • **
  • Posts: 25
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Desktop: How hide icons (content of user folder)
« Reply #8 on: October 31, 2015, 09:00:15 pm »
Hi carpecanem, what's the output from:
Code: [Select]
ls -a ~/Desktop

The output is as expected: ". .."

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1013
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Desktop: How hide icons (content of user folder)
« Reply #9 on: October 31, 2015, 09:08:14 pm »
Hi carpecanem{/b], follow the instructions that PCNetSpec has given you.  That should sort things out for you  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline carpecanem

  • Jr. Member
  • **
  • Posts: 25
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Desktop: How hide icons (content of user folder)
« Reply #10 on: October 31, 2015, 09:09:39 pm »
http://ubuntuforums.org/showthread.php?t=1706643

This may help or it may not :D   a quick google search uncovered this thread.   The principles may apply and need altering slightly to meet your problem here - plus it is quite an old thread...

I think I read that already, but I missed the relevant detail:

~/.config/user-dirs.dirs:
XDG_DESKTOP_DIR="$HOME/Desktop"

Apparrently this key had somehow been set to "$HOME/" during the reboot in question. No idea why/how, I do not feel guilty in any way, as always. One day when the computers will enslave mankind we will wonder why we didn't see these first signs  :D

I changed it now and everything is fine again.

Offline carpecanem

  • Jr. Member
  • **
  • Posts: 25
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Desktop: How hide icons (content of user folder)
« Reply #11 on: October 31, 2015, 09:13:30 pm »
What's the output from:
Code: [Select]
cat ~/.config/user-dirs.dirs
it should be
Quote
# This file is written by xdg-user-dirs-update
# If you want to change or add directories, just edit the line you're
# interested in. All local changes will be retained on the next run
# Format is XDG_xxx_DIR="$HOME/yyy", where yyy is a shell-escaped
# homedir-relative path, or XDG_xxx_DIR="/yyy", where /yyy is an
# absolute path. No other format is supported.
#
XDG_DESKTOP_DIR="$HOME/Desktop"
XDG_DOWNLOAD_DIR="$HOME/Downloads"
XDG_TEMPLATES_DIR="$HOME/Templates"
XDG_PUBLICSHARE_DIR="$HOME/Public"
XDG_DOCUMENTS_DIR="$HOME/Documents"
XDG_MUSIC_DIR="$HOME/Music"
XDG_PICTURES_DIR="$HOME/Pictures"
XDG_VIDEOS_DIR="$HOME/Videos"

That was the problem. I have no idea why this setting was changed. I swear I didn't do anything  ::)

Offline carpecanem

  • Jr. Member
  • **
  • Posts: 25
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Desktop: How hide icons (content of user folder)
« Reply #12 on: October 31, 2015, 09:16:34 pm »
Hi carpecanem, follow the instructions that PCNetSpec has given you.  That should sort things out for you  ;).

It did. Thanks to everybody!