Choose style:

Author Topic: Using Spoiler tags to hide large blocks of text or terminal output in posts  (Read 4694 times)

0 Members and 1 Guest are viewing this topic.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25456
  • Karma: 2799
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Add spoiler tags at the beginning and end of your text
Code: [Select]
[spoiler]text body to be hidden in the spoiler[/spoiler]
The example above would look like this:-
Spoiler (click here to view / hide)
text body to be hidden in the spoiler
[close]

O to add a custom title to the spoiler
Code: [Select]
[spoiler=Custom Title]text body to be hidden in the spoiler[/spoiler]
Custom Title
text body to be hidden in the spoiler
[close]

OR, When editing the text for your post, highlight the text you wish to hide in the spoiler, and whilst the text is highlighted click the Sp button .. the
Code: [Select]
[Spoiler][/Spoiler]
tags will appear surrounding the highlighted text.
« Last Edit: May 06, 2014, 10:18:11 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Slim.Fatz

  • Trusted User
  • Veteran
  • *****
  • Posts: 1752
  • Karma: 466
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 10 - 64bit
Hi, PCNetSpec:

I have had strange results using the "Sp" button, but only when I first click the button with the idea of then pasting or entering text between the resulting tags. The problem is that just simply clicking the button produces the "end" tag first and the "start" tag last. It looks like this:


Code: [Select]
[/spoiler][spoiler]
But note: it only seems to do this when the cursor is on a new empty line. When it is at the end or in the middle or even the beginning of a line that already contains text, then the resulting tags are in the correct order. :-\

Let me know if this is occurring on your machine or if my browsers are haunted.  :P

Regards,
-- Slim
"Life first -- Peppermint a close 2nd!" -- Zeb

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25456
  • Karma: 2799
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
If you click the Sp button with no text highlighted you'll get
Code: [Select]
[spoiler][/spoiler]
wherever the cursor was positioned when you hit the Sp button .. Never seen the come up the wrong ware around  :-\
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Slim.Fatz

  • Trusted User
  • Veteran
  • *****
  • Posts: 1752
  • Karma: 466
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 10 - 64bit
This is strange indeed!  :-\

I just did some testing and get this result:

1. Posting with QupZilla gives me the problem as described.

2. Posting with Firefox and clicking the "Sp" button on an empty line only prints the "start" tag. Entering text after this tag and again clicking on "Sp" again produces the "start" tag. But entering or pasting the text first and then highlighting it and finally clicking "Sp" works perfectly.

Now I need to test it with Chromium (which I don't use very often. I'll let you know the result.


Edit/Update:
I'm now using Chromium and the result is just like when using QupZilla!  :-\


How can this happen? It's not a great problem for me, but for new users of this button it could be rather disturbing (as it was for me, when I first noticed it).


Regards,
-- Slim

« Last Edit: August 10, 2014, 11:03:40 am by Slim.Fatz »
"Life first -- Peppermint a close 2nd!" -- Zeb

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25456
  • Karma: 2799
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Works perfectly for me in Firefox  :-\
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec