Choose style:

Author Topic: Mute button (Solved)  (Read 1758 times)

0 Members and 1 Guest are viewing this topic.

Offline stew1411

  • Jr. Member
  • **
  • Posts: 70
  • Karma: 3
    • View Profile
  • Peppermint version(s): 8
Mute button (Solved)
« on: September 26, 2015, 05:54:53 am »
Hello all. I have a slight problem, but its not a deal breaker. On my laptop I have dedicated volume control buttons. They work fine. The mute button mutes the sound, but pressing it again does not unmute. I have to unmute with my mouse in the tray icon. Any way to fix?

I'm using P5 on a Lenovo ThinkPad X201. I've ordered a SSD and will install P6 when it arrives. Would the fix apply to P6 as well?

Sent from my LG-D850 using Tapatalk

« Last Edit: September 28, 2015, 05:21:15 pm by stew1411 »

Offline Dave_D

  • Newly Subscribed
  • *
  • Posts: 14
  • Karma: 3
  • Often wrong, never in doubt. Now with more Cowbell
    • View Profile
  • Peppermint version(s): 6
Re: Mute button
« Reply #1 on: September 26, 2015, 11:47:26 am »
Maybe it's related, maybe not, but I can't get the volume control slider box to go away after a volume change, let along mute or unmute. Only a reboot helps or kill the process.

On a generic box PC

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Mute button
« Reply #2 on: September 26, 2015, 01:07:06 pm »
@ stew1411

Try this:
http://forum.peppermintos.com/index.php/topic,2445.msg24057.html#msg24057



@Dave_D

Can you start your own topic please
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline stew1411

  • Jr. Member
  • **
  • Posts: 70
  • Karma: 3
    • View Profile
  • Peppermint version(s): 8
Re: Mute button
« Reply #3 on: September 26, 2015, 05:17:48 pm »
Typing that into terminal pull up the following:

Code: [Select]
andrew@andrew-Notebook ~ $ sudo gedit /etc/asound.conf
Swipe your finger across the fingerprint reader

** (gedit:3245): WARNING **: Could not load Gedit repository: Typelib file for namespace 'GtkSource', version '3.0' not found

(gedit:3245): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
andrew@andrew-Notebook ~ $

Navigating to the /etc/ folder and showing hidden files, I'm not finding the file.

Offline s4w3d0ff

  • Jr. Member
  • **
  • Posts: 58
  • Karma: 6
  • Spray and Pray
    • View Profile
    • Github
  • Peppermint version(s): Peppermint 7even 64bit UEFI
Re: Mute button
« Reply #4 on: September 26, 2015, 07:14:23 pm »
Code: [Select]
sudo apt-get install gedit
?
Linuxize IT!
BTC: 15D8VaZco22GTLVrFMAehXyif6EGf8GMYV

Offline stew1411

  • Jr. Member
  • **
  • Posts: 70
  • Karma: 3
    • View Profile
  • Peppermint version(s): 8
Re: Mute button
« Reply #5 on: September 26, 2015, 11:19:38 pm »
It's installed. I've used it to edit other files. That one just won't work.

Sent from my LG-D850 using Tapatalk


Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Mute button
« Reply #6 on: September 27, 2015, 05:00:57 am »
Code: [Select]
sudo apt-get install gir1.2-gtksource-3.0
will get rid of the first warning, but they're just that "warnings" (and are quite normal in Peppermint and in fact Ubuntu because they don't use the gnome session either) .. they are not important and should NOT stop gedit from working.

If gedit is failing to open with that command I can only assume it's something to do with your fingerprint reader and/or software.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline stew1411

  • Jr. Member
  • **
  • Posts: 70
  • Karma: 3
    • View Profile
  • Peppermint version(s): 8
Re: Mute button
« Reply #7 on: September 27, 2015, 08:43:23 am »
OK no more warning. asound.conf opens, but its just a blank file. That's what it did before.

Sent from my LG-D850 using Tapatalk


Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Mute button
« Reply #8 on: September 27, 2015, 09:57:07 am »
It's *supposed* to open a blank file .. read this again:
http://forum.peppermintos.com/index.php/topic,2445.msg24057.html#msg24057
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline stew1411

  • Jr. Member
  • **
  • Posts: 70
  • Karma: 3
    • View Profile
  • Peppermint version(s): 8
Re: Mute button
« Reply #9 on: September 27, 2015, 09:52:42 pm »
Oops. Didn't see that part. Thanks, worked like a charm.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Mute button
« Reply #10 on: September 28, 2015, 05:15:27 am »
You're most welcome :)

Can you please remember to mark the topic solved .. it'll help future searches find a known working solution .. thanks in advance :)

You can mark this topic solved by editing the FIRST posting in this topic and changing:

Subject: Mute button (SOLVED)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec