Choose style:

Author Topic: Computer wouldn't turn on...just beeps [SOLVED]  (Read 1210 times)

0 Members and 1 Guest are viewing this topic.

Offline sskarma

  • Member
  • ***
  • Posts: 376
  • Karma: 32
    • View Profile
  • Peppermint version(s): Peppermint 6 32-bit
Computer wouldn't turn on...just beeps [SOLVED]
« on: September 21, 2015, 08:11:36 am »
Hi guys, so I was giving my computer it's semi-annual inside cleanup where I open it up and clean up everything. so like usually, I took out the RAM, cleaned it up and cleaned the motherboard. and after cleaning up, I put everything back in and started the computer but it wouldn't turn on. it gives a long beep followed by two short beeps. according to Asus documentation, this beep code means that it cannot detect my RAM stick.

I tried pulling out and  reinserting the RAM for about 20 times now, but none of this would help. the processor fan is running fine and so does the SMPS fan. Is my RAM okay or did I mess it up? :(
« Last Edit: September 21, 2015, 10:45:09 am by sk_sarma »

Offline sskarma

  • Member
  • ***
  • Posts: 376
  • Karma: 32
    • View Profile
  • Peppermint version(s): Peppermint 6 32-bit
Re: Computer wouldn't turn on...just beeps
« Reply #1 on: September 21, 2015, 10:43:54 am »
I solved the problem on my own. I just had to push the RAM further into the slot so as to lock it on both sides with the hinge. and now my computer's back to life.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26466
  • Karma: 2885
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Computer wouldn't turn on...just beeps [SOLVED]
« Reply #2 on: September 21, 2015, 12:40:22 pm »
Cool, glad you solved it :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline sskarma

  • Member
  • ***
  • Posts: 376
  • Karma: 32
    • View Profile
  • Peppermint version(s): Peppermint 6 32-bit
Re: Computer wouldn't turn on...just beeps [SOLVED]
« Reply #3 on: September 21, 2015, 01:35:58 pm »
Thank you PCNETSPEC. my computer has lose Video adapter. After inserting the RAM correctly, the computer stopped beeping but it wouldn't turn on. That means it can't detect the video adapter. It has become a little loose I guess. so I banged the cabinet pretty hard on the motherboard side couple of times and then the single beep sound came (what a relief). Then it turned on and I was listening to some music on peppermint, suddenly rebooted itself. now it's fine. :D