Choose style:

Author Topic: "S to skip mount, M to manual..." on P6 start, help  (Read 2836 times)

0 Members and 1 Guest are viewing this topic.

Offline gychang

  • Member
  • ***
  • Posts: 102
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
"S to skip mount, M to manual..." on P6 start, help
« on: September 16, 2015, 07:01:09 pm »
When I boot into P6, I always get warning on first screen, usually I enter S and seems to proceed.  I  am trying to mount NTFS partition (Data) but does not automount and can not access from Nemo.
here is my /etc/fstab:
--
Code: [Select]
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdc6 during installation
UUID=7603b1e3-26e7-4706-984f-614119736c81 /               ext4    noatime,errors=remount-ro 0       1
# /boot/efi was on /dev/sdc2 during installation
UUID=8A7D-5288  /boot/efi       vfat    defaults        0       1
# swap was on /dev/sdc5 during installation
UUID=9ac3e962-d444-4c5b-a29e-b33c8778a815 none            swap    sw              0       0
/dev/disk/by-uuid/0C3F9CB82E076DC7 /mnt/0C3F9CB82E076DC7 auto nosuid,nodev,nofail,x-gvfs-show 0 0
--

thanks in advance
« Last Edit: September 22, 2015, 07:32:00 pm by gychang »

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1013
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: "S to skip mount, M to manual..." on P6 start, help
« Reply #1 on: September 16, 2015, 07:11:15 pm »
Hi gychang, can you please provide some more information?  Please run the following commands in a terminal window and post the outputs back to the forum:
Code: [Select]
sudo fdisk -l 
followed by:
Code: [Select]
sudo blkid
Please remember to encapsulate the outputs with the # Insert Code function.  This preserves the original output.  This function is found above the,  :-[ Embarrassed emoticon in the forum editor - many thanks  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline gychang

  • Member
  • ***
  • Posts: 102
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: "S to skip mount, M to manual..." on P6 start, help
« Reply #2 on: September 17, 2015, 08:28:55 am »
Hi gychang, can you please provide some more information?  Please run the following commands in a terminal window and post the outputs back to the forum:
Code: [Select]
sudo fdisk -l 
followed by:
Code: [Select]
sudo blkid
Please remember to encapsulate the outputs with the # Insert Code function.  This preserves the original output.  This function is found above the,  :-[ Embarrassed emoticon in the forum editor - many thanks  ;).

I ended up reinstalling the P6, now working fine.  thanks,

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25936
  • Karma: 2836
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: "S to skip mount, M to manual..." on P6 start, help
« Reply #3 on: September 17, 2015, 03:01:16 pm »
Well that was a bit drastic, all for a single malformed line in fstab .. but whatever works for you ;)
« Last Edit: September 17, 2015, 03:06:57 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline gychang

  • Member
  • ***
  • Posts: 102
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: "S to skip mount, M to manual..." on P6 start, help
« Reply #4 on: September 18, 2015, 07:47:10 am »
Hi gychang, can you please provide some more information?  Please run the following commands in a terminal window and post the outputs back to the forum:
Code: [Select]
sudo fdisk -l 
followed by:
Code: [Select]
sudo blkid
Please remember to encapsulate the outputs with the # Insert Code function.  This preserves the original output.  This function is found above the,  :-[ Embarrassed emoticon in the forum editor - many thanks  ;).

reinstalled P6, worked for one day and now the same problem.

fdisk -l

Code: [Select]
apa@main ~ $ sudo fdisk -l
[sudo] password for apa:

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.


Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0xe9c64868

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1  1953525167   976762583+  ee  GPT
Partition 1 does not start on physical sector boundary.

WARNING: GPT (GUID Partition Table) detected on '/dev/sdb'! The util fdisk doesn't support GPT. Use GNU Parted.


Disk /dev/sdb: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders, total 234441648 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1   234441647   117220823+  ee  GPT


sudo blkid

Code: [Select]
apa@main ~ $ sudo blkid
/dev/sda1: LABEL="Data" UUID="58DE2D0079E8B3D3" TYPE="ntfs"
/dev/sdb1: LABEL="Recovery" UUID="723E7C403E7BFB83" TYPE="ntfs"
/dev/sdb2: UUID="8A7D-5288" TYPE="vfat"
/dev/sdb4: UUID="D204B7B004B79647" TYPE="ntfs"
/dev/sdb5: UUID="E47C2A917C2A5F14" TYPE="ntfs"
/dev/sdb6: UUID="9ac3e962-d444-4c5b-a29e-b33c8778a815" TYPE="swap"
/dev/sdb7: UUID="c5d87df0-f1bb-467b-bbd7-0e7a5bbcc780" TYPE="ext4"

/dev/sda1 is not automounting...

how to fix this?



Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25936
  • Karma: 2836
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: "S to skip mount, M to manual..." on P6 start, help
« Reply #5 on: September 18, 2015, 08:00:35 am »
Backup fstab:
Code: [Select]
sudo cp -v /etc/fstab /etc/fstab.bak
now create a mountpoint:
Code: [Select]
sudo mkdir -p /media/Data
make sure you have ntfs-3g installed:
Code: [Select]
sudo apt-get install ntfs-3g
now open fstab for editing:
Code: [Select]
sudo gedit /etc/fstab
and add the 2 NEW lines at the bottom:
Code: [Select]
## Mount Data partition (/dev/sda1) manually added by gychang
UUID=58DE2D0079E8B3D3  /media/Data  ntfs-3g  defaults,windows_names,locale=en_US.utf8  0 0
SAVE the file and exit gedit

run:
Code: [Select]
sudo mount -a
and if there were no errors .. reboot to test



NOTE - whilst in fstab, remove any line you previously added to automount dsa1
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline gychang

  • Member
  • ***
  • Posts: 102
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: "S to skip mount, M to manual..." on P6 start, help
« Reply #6 on: September 19, 2015, 12:31:32 am »
Backup fstab:
Code: [Select]
sudo cp -v /etc/fstab /etc/fstab.bak
now create a mountpoint:
Code: [Select]
sudo mkdir -p /media/Data
make sure you have ntfs-3g installed:
Code: [Select]
sudo apt-get install ntfs-3g
now open fstab for editing:
Code: [Select]
sudo gedit /etc/fstab
and add the 2 NEW lines at the bottom:
Code: [Select]
## Mount Data partition (/dev/sda1) manually added by gychang
UUID=58DE2D0079E8B3D3  /media/Data  ntfs-3g  defaults,windows_names,locale=en_US.utf8  0 0
SAVE the file and exit gedit

run:
Code: [Select]
sudo mount -a
and if there were no errors .. reboot to test



NOTE - whilst in fstab, remove any line you previously added to automount dsa1

I am still getting errors when I enter sudo mount -a

Code: [Select]
apa@main ~ $ sudo mount -a
[sudo] password for apa:
The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sda1': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.
The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sda1': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1013
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: "S to skip mount, M to manual..." on P6 start, help
« Reply #7 on: September 19, 2015, 12:59:23 am »
Hi gychang, What's the content of your fstab file?  Run the following command and post the output back to the forum:
Code: [Select]
gedit /etc/fstab
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25936
  • Karma: 2836
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: "S to skip mount, M to manual..." on P6 start, help
« Reply #8 on: September 19, 2015, 07:01:02 am »
reboot into Windows and run:
Code: [Select]
chkdsk /f
to fix the Windows filesystem errors
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline gychang

  • Member
  • ***
  • Posts: 102
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: "S to skip mount, M to manual..." on P6 start, help
« Reply #9 on: September 19, 2015, 09:20:44 am »
reboot into Windows and run:
Code: [Select]
chkdsk /f
to fix the Windows filesystem errors

am dual booting, on my windows 10, I did chkdsk D: /f /r /x and now it does load sda (NTFS) disk, and all works, BUT I still get the "S to skip mount..." and have to enter S and proceed to booting into P6.  Can it that my sda and sdb is reversed on my PC (have OS-win 10, P6 on mSATA - sdb, and my Data HD-NTFS is on sda) or can it be grub-customizer?

thanks for all the help so far...


Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25936
  • Karma: 2836
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: "S to skip mount, M to manual..." on P6 start, help
« Reply #10 on: September 19, 2015, 10:01:49 am »
Give us the contents of:
Code: [Select]
gedit /etc/fstab
and the output from:
Code: [Select]
sudo fdisk -l
and
Code: [Select]
sudo blkid
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline gychang

  • Member
  • ***
  • Posts: 102
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: "S to skip mount, M to manual..." on P6 start, help
« Reply #11 on: September 19, 2015, 12:01:50 pm »
Give us the contents of:
Code: [Select]
gedit /etc/fstab
and the output from:
Code: [Select]
sudo fdisk -l
and
Code: [Select]
sudo blkid

fstab:
Code: [Select]
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdb6 during installation
UUID=c5d87df0-f1bb-467b-bbd7-0e7a5bbcc780 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sdb2 during installation
UUID=8A7D-5288  /boot/efi       vfat    defaults        0       1
# swap was on /dev/sdb5 during installation
UUID=9ac3e962-d444-4c5b-a29e-b33c8778a815 none            swap    sw              0       0
/dev/disk/by-uuid/58DE2D0079E8B3D3 /mnt/58DE2D0079E8B3D3 auto nosuid,nodev,nofail,x-gvfs-show 0 0
## Mount Data partition (/dev/sda1) manually added by gychang
UUID=58DE2D0079E8B3D3  /media/Data  ntfs-3g  defaults,windows_names,locale=en_US.utf8  0 0

blkid
Code: [Select]
apa@main ~ $ sudo blkid
[sudo] password for apa:
/dev/sda1: LABEL="Data" UUID="58DE2D0079E8B3D3" TYPE="ntfs"
/dev/sdb1: LABEL="Recovery" UUID="723E7C403E7BFB83" TYPE="ntfs"
/dev/sdb2: UUID="8A7D-5288" TYPE="vfat"
/dev/sdb4: UUID="D204B7B004B79647" TYPE="ntfs"
/dev/sdb5: UUID="E47C2A917C2A5F14" TYPE="ntfs"
/dev/sdb6: UUID="9ac3e962-d444-4c5b-a29e-b33c8778a815" TYPE="swap"
/dev/sdb7: UUID="c5d87df0-f1bb-467b-bbd7-0e7a5bbcc780" TYPE="ext4"

fdisk -l
Code: [Select]
apa@main ~ $ sudo fdisk -l

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.


Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0xe9c64868

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1  1953525167   976762583+  ee  GPT
Partition 1 does not start on physical sector boundary.

WARNING: GPT (GUID Partition Table) detected on '/dev/sdb'! The util fdisk doesn't support GPT. Use GNU Parted.


Disk /dev/sdb: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders, total 234441648 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1   234441647   117220823+  ee  GPT


thanks,

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25936
  • Karma: 2836
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: "S to skip mount, M to manual..." on P6 start, help
« Reply #12 on: September 19, 2015, 04:28:17 pm »
run:
Code: [Select]
sudo gedit /etc/fstab
and make it read:
Code: [Select]
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdb6 during installation
UUID=c5d87df0-f1bb-467b-bbd7-0e7a5bbcc780 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sdb2 during installation
UUID=8A7D-5288  /boot/efi       vfat    defaults        0       1
# swap was on /dev/sdb5 during installation
UUID=9ac3e962-d444-4c5b-a29e-b33c8778a815 none            swap    sw              0       0
## Mount Data partition (/dev/sda1) manually added by gychang
UUID=58DE2D0079E8B3D3  /media/Data  ntfs-3g  defaults,windows_names,locale=en_US.utf8  0 0
SAVE the file .. reboot to test.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline gychang

  • Member
  • ***
  • Posts: 102
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: "S to skip mount, M to manual..." on P6 start, help
« Reply #13 on: September 19, 2015, 06:01:07 pm »
works!, thanks.

what was wrong?, fstab am sure has to do with NTFS HD not properly being mounted.



run:
Code: [Select]
sudo gedit /etc/fstab
and make it read:
Code: [Select]
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdb6 during installation
UUID=c5d87df0-f1bb-467b-bbd7-0e7a5bbcc780 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sdb2 during installation
UUID=8A7D-5288  /boot/efi       vfat    defaults        0       1
# swap was on /dev/sdb5 during installation
UUID=9ac3e962-d444-4c5b-a29e-b33c8778a815 none            swap    sw              0       0
## Mount Data partition (/dev/sda1) manually added by gychang
UUID=58DE2D0079E8B3D3  /media/Data  ntfs-3g  defaults,windows_names,locale=en_US.utf8  0 0
SAVE the file .. reboot to test.

Offline gychang

  • Member
  • ***
  • Posts: 102
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: "S to skip mount, M to manual..." on P6 start, help (SOLVED)
« Reply #14 on: September 19, 2015, 06:01:23 pm »
When I boot into P6, I always get warning on first screen, usually I enter S and seems to proceed.  I  am trying to mount NTFS partition (Data) but does not automount and can not access from Nemo.
here is my /etc/fstab:
--
Code: [Select]
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdc6 during installation
UUID=7603b1e3-26e7-4706-984f-614119736c81 /               ext4    noatime,errors=remount-ro 0       1
# /boot/efi was on /dev/sdc2 during installation
UUID=8A7D-5288  /boot/efi       vfat    defaults        0       1
# swap was on /dev/sdc5 during installation
UUID=9ac3e962-d444-4c5b-a29e-b33c8778a815 none            swap    sw              0       0
/dev/disk/by-uuid/0C3F9CB82E076DC7 /mnt/0C3F9CB82E076DC7 auto nosuid,nodev,nofail,x-gvfs-show 0 0
--

thanks in advance