Choose style:

Author Topic: Switch on 'NumLk' on boot [SOLVED]  (Read 1021 times)

0 Members and 1 Guest are viewing this topic.

Offline Toshmarple

  • Jr. Member
  • **
  • Posts: 61
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): P 6<9-32 Ntbk and P6<9-64 Laptop
Switch on 'NumLk' on boot [SOLVED]
« on: September 16, 2015, 02:08:40 am »
I know it's a very small thing but I would love to have 'NumLk' switch on automatically on booting.  My password includes numerical characters and I've lost count of the number of times I've tried to logon without switching on 'NumLk' first, probably comes from using W7 & XP for so many years  (they both switch it on automatically at boot).

Thanks, Toshmarple
« Last Edit: September 16, 2015, 07:05:02 am by Toshmarple »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25725
  • Karma: 2822
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Switch on 'NumLk' on boot
« Reply #1 on: September 16, 2015, 04:39:26 am »
Try:
Code: [Select]
sudo apt-get install numlockx
then reboot to test.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Toshmarple

  • Jr. Member
  • **
  • Posts: 61
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): P 6<9-32 Ntbk and P6<9-64 Laptop
Re: Switch on 'NumLk' on boot
« Reply #2 on: September 16, 2015, 04:59:35 am »
Sorry to say it's not working and I have checked to ensure it has installed (which it has).  Also re-booted twice but no luck, sorry.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25725
  • Karma: 2822
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Switch on 'NumLk' on boot
« Reply #3 on: September 16, 2015, 05:07:54 am »
Run
Code: [Select]
sudo gedit /etc/default/numlockx

And change the line:-

NUMLOCK=auto

to

NUMLOCK=on

SAVE the file, reboot to test.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Toshmarple

  • Jr. Member
  • **
  • Posts: 61
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): P 6<9-32 Ntbk and P6<9-64 Laptop
Re: Switch on 'NumLk' on boot [SOLVED]
« Reply #4 on: September 16, 2015, 07:11:16 am »
Yep, that did it!  Thanks a million and also for the very quick response.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25725
  • Karma: 2822
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Switch on 'NumLk' on boot [SOLVED]
« Reply #5 on: September 16, 2015, 07:43:36 am »
You're most welcome :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec