Choose style:

Author Topic: on screen keyboard on login screen (SOLVED)  (Read 2463 times)

0 Members and 1 Guest are viewing this topic.

Offline WolfBikersClub95

  • nOOb
  • *
  • Posts: 3
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 6
on screen keyboard on login screen (SOLVED)
« on: September 13, 2015, 11:04:10 pm »
So i first installed peppermint on my laptop and instantly fell in love with it. so i decided to give it a try on my old Fujitsu walcom penabled tablet however i quickly realised that there was no on-screen keyboard installed by default. so completed the install with a usb keyboard plugged in and installed onboard once i logged in for the first time. sorted, yes? wrong. after doing my first reboot without the keyboard plugged in i could not get onboard to open on the log on screen, there was no option in the accessibility menu for the login screen.

so my question to the faithful peppermint community is, How can i get onboard to open from the login screen so that i can log in without a keyboard plugged in.
« Last Edit: September 15, 2015, 04:29:27 pm by WolfBikersClub95 »

Offline Slim.Fatz

  • Trusted User
  • Veteran
  • *****
  • Posts: 1879
  • Karma: 494
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 10 - 64bit
Re: on screen keyboard on login screen
« Reply #1 on: September 14, 2015, 03:39:50 am »
Hi WolfBikersClub95,

This might be impossible since Peppermint Six was not developed for tablet usage -- although, if it is possible to solve your problem, I'm sure that someone around here (e.g. our local guru PCNetSpec) will provide the solution.  ;)

Good luck and sorry that I could not help you,

-- Slim
"Life first -- Peppermint a close 2nd!" -- Zeb

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26468
  • Karma: 2872
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: on screen keyboard on login screen
« Reply #2 on: September 14, 2015, 07:12:07 am »
OK, you have 2 options:-

1) Just autologin  <-- by far the easiest option .. if you want instructions just ask .. DO NOT mess in "Users & Groups", that is NOT where you set autologin

2) Install onboard:
Code: [Select]
sudo apt-get install onboard
then start onboard from the (menu > Universal Access > Onboard) menu item.

THIS BIT IS IMPORTANT - Open a terminal and run:
Code: [Select]
sudo gedit /etc/xdg/autostart/onboard-autostart.desktop
find the line that reads:-
Code: [Select]
Exec=onboard --not-show-in=GNOME
and change it to
Code: [Select]
Exec=killall onboard ; onboard --not-show-in=GNOME
SAVE the file and exit gedit

OPTIONAL (if you don't want the keyboard to already be shown on the desktop once logged in) - Now click the Onboard icon in the system tray, and select Preferences .. and put a tick in "Start Onboard hidden" and click the "Close" button.

Now in the menu go to
menu > Preferences > Default Applications for LXSession > Core applications (tab)
scroll down till you find the "A11y" field, and in that box enter:
onboard
now close the LXSession Configuration window (X button top right)


Now open a terminal and run:
Code: [Select]
sudo gedit /etc/lightdm/lightdm-gtk-greeter.conf
and add these 2 lines at the bottom
Code: [Select]
keyboard=onboard
show-indicators=~language;~a11y;~session;~power;
SAVE the file.

Now log off to test

At the login screen you can click the little "man in a circle" accessibility icon and then select "Onscreen Keyboard"



Note - DO NOT skip the part in green about autostarting A11y: onboard in Default Applications for LXSession, or your Peppermint menu will misbehave when you get to the desktop.
« Last Edit: September 14, 2015, 07:57:24 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline WolfBikersClub95

  • nOOb
  • *
  • Posts: 3
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 6
Re: on screen keyboard on login screen
« Reply #3 on: September 15, 2015, 04:16:37 pm »
Thank your for reply and the very detailed steps. ill give it a try now and get back.

Offline WolfBikersClub95

  • nOOb
  • *
  • Posts: 3
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 6
Re: on screen keyboard on login screen
« Reply #4 on: September 15, 2015, 04:27:12 pm »
Works perfectly. Thank you.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26468
  • Karma: 2872
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: on screen keyboard on login screen (SOLVED)
« Reply #5 on: September 15, 2015, 05:07:46 pm »
Terrific, you're welcome, and thanks for marking the topic solved :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec