Author Topic: Steam in Peppermint Six - errors on 32 bit library dependencies (SOLVED)  (Read 4439 times)

Offline Dobri

  • Newly Subscribed
  • *
  • Posts: 17
  • Karma: 4
  • Bah
    • View Profile
  • Peppermint version(s): TEN (64)
Re: Steam in Peppermint Six - errors on 32 bit library dependencies (SOLVED)
« Reply #15 on: November 18, 2015, 06:16:03 am »
Hi steam problem its same hire :

Code: [Select]
dobri@dobri-MS-Linux ~ $ sudo apt-get install libgl1-mesa-dri-lts-utopic:i386 libgl1-mesa-glx-lts-utopic:i386 libglapi-mesa-lts-utopic:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgl1-mesa-glx-lts-utopic:i386 : Depends: libudev1:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
dobri@dobri-MS-Linux ~ $ uname -a
Linux dobri-MS-Linux 3.16.0-53-generic #72~14.04.1-Ubuntu SMP Fri Nov 6 18:17:23 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
« Last Edit: November 18, 2015, 10:36:23 am by AndyInMokum »
WARNING: Military software detected, top secret clearance required

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Steam in Peppermint Six - errors on 32 bit library dependencies (SOLVED)
« Reply #16 on: November 18, 2015, 09:36:43 am »
Try:
Code: [Select]
sudo apt-get install libgl1-mesa-dri-lts-utopic:i386 libgl1-mesa-glx-lts-utopic:i386 libglapi-mesa-lts-utopic:i386 libudev1:i386aand welcome to the forum :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Dobri

  • Newly Subscribed
  • *
  • Posts: 17
  • Karma: 4
  • Bah
    • View Profile
  • Peppermint version(s): TEN (64)
Re: Steam in Peppermint Six - errors on 32 bit library dependencies (SOLVED)
« Reply #17 on: November 20, 2015, 04:05:30 am »
Tnx its the same
Code: [Select]
dobri@dobri-MS-Linux ~ $ sudo apt-get install libgl1-mesa-dri-lts-utopic:i386 libgl1-mesa-glx-lts-utopic:i386 libglapi-mesa-lts-utopic:i386 libudev1:i386
[sudo] password for dobri:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libudev1:i386 : Depends: libcgmanager0:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
dobri@dobri-MS-Linux ~ $
« Last Edit: November 20, 2015, 05:11:19 am by AndyInMokum »
WARNING: Military software detected, top secret clearance required

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4889
  • Karma: 1058
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 10 (64-bit)
Re: Steam in Peppermint Six - errors on 32 bit library dependencies (SOLVED)
« Reply #18 on: November 20, 2015, 05:16:19 am »
Hi Dobri, for future reference could you please encapsulate terminal outputs with the # Insert Code function.  This is located in the forum editor, just above the Embarrassed  :-[ emoticon in the forum editor.  This preserves the original format of the output.  It makes it much easier for future users to read and relate to.  It also keeps things neat and tidy.  This time I’ve done this for you.  Don't worry, you'll get the hang of it really quickly.  Thanks in advance ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline scifidude79

  • Hero
  • *****
  • Posts: 4029
  • Karma: 870
    • View Profile
  • Peppermint version(s): Peppermint 9
Re: Steam in Peppermint Six - errors on 32 bit library dependencies (SOLVED)
« Reply #19 on: November 20, 2015, 06:55:08 am »
Hi Dobri.  As I asked the person who started this topic, how did you install Steam?  Did you download it from their website and install it or install it from the repository?  If you installed it from the repository, you should be getting none of these errors because Apt installs everything you need.

Offline Dobri

  • Newly Subscribed
  • *
  • Posts: 17
  • Karma: 4
  • Bah
    • View Profile
  • Peppermint version(s): TEN (64)
Re: Steam in Peppermint Six - errors on 32 bit library dependencies (SOLVED)
« Reply #20 on: November 20, 2015, 07:08:48 am »
I installed from the steam website deb package
WARNING: Military software detected, top secret clearance required

Offline scifidude79

  • Hero
  • *****
  • Posts: 4029
  • Karma: 870
    • View Profile
  • Peppermint version(s): Peppermint 9
Re: Steam in Peppermint Six - errors on 32 bit library dependencies (SOLVED)
« Reply #21 on: November 20, 2015, 07:44:42 am »
In that case, I'd advise you to do what the person who started this thread did and use the Software Manager or Synaptic Package Manager to remove that version and reinstall it using the one in the repository.

Though, I will warn you about one thing.  I noticed in your thread about what you're running Peppermint on that you have AMD graphics.  Unless they've fixed it, which I doubt, there's a bug in Steam for Linux with AMD graphics.  For some unknown reason, if you have the AMD FGLRX driver installed, Steam may not start.  If that happens, what you'll need to do is uninstall the AMD driver, then run Steam so that it updates and starts.  Then reinstall the AMD driver.  It's a pain, but Steam will work flawlessly after that.  I know, I have AMD graphics on my laptop.

Offline Dobri

  • Newly Subscribed
  • *
  • Posts: 17
  • Karma: 4
  • Bah
    • View Profile
  • Peppermint version(s): TEN (64)
Re: Steam in Peppermint Six - errors on 32 bit library dependencies (SOLVED)
« Reply #22 on: November 20, 2015, 08:12:35 am »
Tnx for help, my staem is working jast its compleining for problem with dependencies.My game work ok, jast its pein evry start.And yes its AMD FGLRX driver installed.
WARNING: Military software detected, top secret clearance required