Choose style:

Author Topic: Wake on LAN and atheros 8121 [SOLVED]  (Read 3259 times)

0 Members and 1 Guest are viewing this topic.

Offline CluelessOne

  • nOOb
  • *
  • Posts: 7
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Wake on LAN and atheros 8121 [SOLVED]
« on: August 29, 2015, 09:31:53 am »
I have installed Peppermint 6 on Asus EEE PC 1000H. For the most part it is all right, but I am cannot enable Wake-on LAN feature for the ethernet controller. I definitely know that the adapter have a wake-on LAN feature, because I can do it in Windows 7. I can wake the computer from sleep, hibernation & shutdown when I install Windows 7 on it.

This is the lspci output
Code: [Select]
00:00.0 Host bridge: Intel Corporation Mobile 945GSE Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GSE Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 2 (rev 02)
00:1c.3 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 4 (rev 02)
00:1d.0 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB controller: Intel Corporation NM10/ICH7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7-M Family) SATA Controller [AHCI mode] (rev 02)
01:00.0 Network controller: Ralink corp. RT2790 Wireless 802.11n 1T/2R PCIe
03:00.0 Ethernet controller: Qualcomm Atheros AR8121/AR8113/AR8114 Gigabit or Fast Ethernet (rev b0)

This is the ifconfig output

Quote
eth0      Link encap:Ethernet  HWaddr 00:23:54:32:8b:ff 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:1
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

Note: I am using wifi right now so no activity on ethernet, but ethernet adapter works. I use it at work.

This is the ethtool output
Code: [Select]
Settings for eth0:
Supported ports: [ TP ]
Supported link modes:   10baseT/Half 10baseT/Full
                        100baseT/Half 100baseT/Full
Supported pause frame use: No
Supports auto-negotiation: Yes
Advertised link modes:  1000baseT/Full
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Speed: Unknown!
Duplex: Unknown! (255)
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
MDI-X: Unknown
Cannot get wake-on-lan settings: Operation not permitted
Current message level: 0x00000000 (0)
       
Link detected: no

Please help. Thanks.
« Last Edit: August 29, 2015, 12:16:30 pm by CluelessOne »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25661
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Wake on LAN and atheros 8121
« Reply #1 on: August 29, 2015, 10:15:10 am »
You're running ethtool without elevated privileges, so it cannot report back the WOL settings .. so instead of:
Code: [Select]
ethtool eth0
try
Code: [Select]
sudo ethtool eth0
which should be able to access the WOL settings and report them back

See here:
https://help.ubuntu.com/community/WakeOnLan
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline CluelessOne

  • nOOb
  • *
  • Posts: 7
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Wake on LAN and atheros 8121
« Reply #2 on: August 29, 2015, 12:13:04 pm »
Oh, how silly of me.

Ok, so I ran ethtool with sudo, and got wake on lan capability pg. So thanks. How do I mark this as solved?
PS: Is there anything like windows device manager applet in Linux? Would be nice instead of running down command after command in terminal.

Offline CluelessOne

  • nOOb
  • *
  • Posts: 7
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Wake on LAN and atheros 8121 [SOLVED]
« Reply #3 on: August 29, 2015, 12:39:24 pm »
Sorry to add another question, where should I put the line
Code: [Select]
up ethtool -s eth0 wol g
In the file /etc/network/interface ? It only says
Code: [Select]
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25661
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Wake on LAN and atheros 8121 [SOLVED]
« Reply #4 on: August 29, 2015, 01:41:43 pm »
Does that command make WOL work ?

if so, does it need to be run each cold boot ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline CluelessOne

  • nOOb
  • *
  • Posts: 7
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Wake on LAN and atheros 8121 [SOLVED]
« Reply #5 on: August 29, 2015, 09:10:21 pm »
Yes, the wake on lan feature works. I have to use wake-on with magic packet ("g"), because using PHY ("p") is too "chatty".
The command has to be enabled each time it boots.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25661
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Wake on LAN and atheros 8121 [SOLVED]
« Reply #6 on: August 29, 2015, 10:05:51 pm »
well try adding it to /etc/network/interface

if that doesn't work, you could always try adding that command to /etc/rc.local just above the "exit 0" line
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec