Author Topic: My-Weather indicator not working  (Read 5914 times)

Offline penrose1950

  • Member
  • ***
  • Posts: 165
  • Karma: 5
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 9 64 bit
My-Weather indicator not working
« on: August 20, 2015, 01:01:57 pm »
hello my weather indicator was working but it is not now.   http://mintguide.org/effects/335-my-weather-indicator-beautiful-clock-and-weather-widget-on-linux-mint.html

 dpkg -l | grep python-dateutil
ii  python-dateutil                             1.5+dfsg-1ubuntu1                       all          powerful extensions to the standard datetime module


dpkg -l | grep python-lxml
ii  python-lxml                                 3.3.3-1ubuntu0.1                        amd64        pythonic binding for the libxml2 and libxslt libraries


dpkg -l | grep python3-tz      gave no output

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: My-Weather indicator not working
« Reply #1 on: August 24, 2015, 05:51:42 am »
Not working how exactly ? .. not starting, or starting but giving the wrong results ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline penrose1950

  • Member
  • ***
  • Posts: 165
  • Karma: 5
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 9 64 bit
Re: My-Weather indicator not working
« Reply #2 on: August 24, 2015, 10:58:02 am »
i click on my weather and nothing comes up on the screen?
thank you.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: My-Weather indicator not working
« Reply #3 on: August 24, 2015, 03:53:05 pm »
OK, first run:
Code: [Select]
sudo killall my-weather-indicatornow what's the output from:
Code: [Select]
/opt/extras.ubuntu.com/my-weather-indicator/bin/my-weather-indicator?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline penrose1950

  • Member
  • ***
  • Posts: 165
  • Karma: 5
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 9 64 bit
Re: My-Weather indicator not working
« Reply #4 on: August 25, 2015, 12:45:28 am »
/opt/extras.ubuntu.com/my-weather-indicator/bin/my-weather-indicator
bash: /opt/extras.ubuntu.com/my-weather-indicator/bin/my-weather-indicator: No such file or directory

Offline Slim.Fatz

  • Global Moderator
  • Veteran
  • *****
  • Posts: 2315
  • Karma: 614
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 10 - 64bit
Re: My-Weather indicator not working
« Reply #5 on: August 25, 2015, 03:20:32 am »
Hi penrose1950,

I don't know much about my-weather-indicator, but if PCNetSpec gave you the correct path to use then it appears that it is not (or no longer) installed. Maybe try posting the output to this:

Code: [Select]
dpkg -l | grep my-weather-indicator
You might have to reinstall it. Good luck.

Regards,

-- Slim
Respect science, respect nature, respect each other.

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: My-Weather indicator not working
« Reply #6 on: August 25, 2015, 06:25:43 am »
Can you also run:
Code: [Select]
sudo updatedbthen post the output from:
Code: [Select]
locate my-weather-indicator
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline penrose1950

  • Member
  • ***
  • Posts: 165
  • Karma: 5
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 9 64 bit
Re: My-Weather indicator not working
« Reply #7 on: August 26, 2015, 07:52:51 am »
Spoiler (click here to view / hide)
[close]

Offline penrose1950

  • Member
  • ***
  • Posts: 165
  • Karma: 5
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 9 64 bit
Re: My-Weather indicator not working
« Reply #8 on: August 26, 2015, 08:01:38 am »
Spoiler (click here to view / hide)
[close]

Offline penrose1950

  • Member
  • ***
  • Posts: 165
  • Karma: 5
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 9 64 bit
Re: My-Weather indicator not working
« Reply #9 on: August 26, 2015, 08:02:19 am »
it would not let me put in all the output as The message exceeds the maximum allowed length (30000 characters).

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: My-Weather indicator not working
« Reply #10 on: August 26, 2015, 08:36:32 am »
OK according to that the file DOES exist  :-\

So let's uninstall .. delete the directory .. and reinstall:
Code: [Select]
sudo apt-get remove --purge my-weather-indicatorthen
Code: [Select]
sudo rm -rv /opt/extras.ubuntu.comthen
Code: [Select]
sudo apt-get install my-weather-indicator
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline penrose1950

  • Member
  • ***
  • Posts: 165
  • Karma: 5
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 9 64 bit
Re: My-Weather indicator not working
« Reply #11 on: August 26, 2015, 08:52:00 am »
rm: cannot remove ‘/opt/extras.ubuntu.com’: No such file or directory

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: My-Weather indicator not working
« Reply #12 on: August 26, 2015, 12:26:23 pm »
What's the output from:
Code: [Select]
ls -a /opt
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline penrose1950

  • Member
  • ***
  • Posts: 165
  • Karma: 5
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 9 64 bit
Re: My-Weather indicator not working
« Reply #13 on: August 27, 2015, 12:49:13 am »
ls -a /opt
.  ..  extras.ubuntu.com

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: My-Weather indicator not working
« Reply #14 on: August 27, 2015, 02:14:42 am »
How weird is that .. one command says the directory doesn't exist and the other says it does  :-\

Maybe a filesystem error (?) .. try running:
Code: [Select]
sudo touch /forcefsckthen reboot .. during the bootup you should see a filesystem check being run.

Once rebooted run:
Code: [Select]
sudo rm -rv /opt/extras.ubuntu.comdid that run without error.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec