Choose style:

Author Topic: keyboard shortcut for switching between Keyboard Layouts not working (SOLVED)  (Read 5179 times)

0 Members and 1 Guest are viewing this topic.

Offline damig

  • Member
  • ***
  • Posts: 126
  • Karma: 9
  • New Forum User
    • View Profile
  • Peppermint version(s): 5 (32), 7 (64)
I have Installed a second keyboard layout and can't switch between them using keyboard shortcut. I've noticed when I tick `keys to change layout and LShift+LAlt`(in `Preferences>Keyboard Layout>Tools>hide/unhide profiles>global>options), it unticks either `keys to change layout` or the`LShift+LAlt` after `apply`. It worked for a moment, but now it doesn't. Can anyone help?
« Last Edit: April 28, 2014, 10:07:31 am by damig »

Offline mac

  • Global Moderator
  • Veteran
  • *****
  • Posts: 1088
  • Karma: 336
    • View Profile
  • Peppermint version(s): Peppermint 7-8-9
Re: Switching 2 Keyboard Layouts shorcut option unticks itself
« Reply #1 on: April 25, 2014, 11:19:48 am »
To the left of "Key(s) to change layout" click on the dark triangle to see your options (see image in Spoiler)
Spoiler (click here to view / hide)
[close]
Is that what you're after?  ???
Peppermint: Standing Out from the Cloud
Reg. Linux User #432835

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26313
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Switching 2 Keyboard Layouts shorcut option unticks itself
« Reply #2 on: April 25, 2014, 12:42:25 pm »
Which layouts ?

Let's say you wanted to use LeftAlt+LeftShift to toggle between the GB and Russian keyboard layouts

you could run:
Code: [Select]
setxkbmap -option grp:lalt_lshift_toggle "gb,ru"
and test it works.

If it works, add the line

@setxkbmap -option grp:lalt_lshift_toggle "gb,ru"

to

/etc/xdg/lxsession/Peppermint/autostart



See here:
https://help.ubuntu.com/community/Lubuntu/Keyboard#Keyboard_Mapping

but remember the location of the Peppermint autostart file is as above .. not the location on that page.
« Last Edit: April 25, 2014, 08:03:30 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline damig

  • Member
  • ***
  • Posts: 126
  • Karma: 9
  • New Forum User
    • View Profile
  • Peppermint version(s): 5 (32), 7 (64)
Re: Switching 2 Keyboard Layouts shorcut option unticks itself
« Reply #3 on: April 25, 2014, 06:14:06 pm »
thx guys, it looks like a homework. I'll keep in touch...

Offline damig

  • Member
  • ***
  • Posts: 126
  • Karma: 9
  • New Forum User
    • View Profile
  • Peppermint version(s): 5 (32), 7 (64)
Re: Switching 2 Keyboard Layouts shorcut option unticks itself
« Reply #4 on: April 25, 2014, 06:29:12 pm »
To the left of "Key(s) to change layout" click on the dark triangle to see your options (see image in Spoiler)
Spoiler (click here to view / hide)
[close]
Is that what you're after?  ???
mac, yes. I tick the 'key(s) to change layout` as well as the option for the key shortcut (dropdown menu is activated with the black arrow in front of the tick field). In my case, I tick the Left Shift+Left Alt (Windows habit) as well. So now I tell system to change keyboard layouts when I press the LShift+LAlt. But when I click `apply` either `key(s to change layout` or the `Left Shift+Left Alt` tick field is unticked.
I have en and mk as keyboard layouts and I didn't installed it as I said, but the Peppermint OS Live CD Installation did that automatically with me just inputing location.

Offline mac

  • Global Moderator
  • Veteran
  • *****
  • Posts: 1088
  • Karma: 336
    • View Profile
  • Peppermint version(s): Peppermint 7-8-9
Re: Switching 2 Keyboard Layouts shorcut option unticks itself
« Reply #5 on: April 25, 2014, 07:30:31 pm »
Did you try PCNetSpec's instructions above?
Peppermint: Standing Out from the Cloud
Reg. Linux User #432835

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26313
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Switching 2 Keyboard Layouts shorcut option unticks itself
« Reply #6 on: April 25, 2014, 08:06:52 pm »
I'm not even sure where you guys are trying to change the settings.

Either follow my instructions above, or just add the Keyboard Layout Handler panel applet, and set it to do the same.

Even if you use my original instructions, you'll probably still want to add the Keyboard Layout Handler panel applet, so you have an indicator of which layout you're currently using.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline damig

  • Member
  • ***
  • Posts: 126
  • Karma: 9
  • New Forum User
    • View Profile
  • Peppermint version(s): 5 (32), 7 (64)
Re: Switching 2 Keyboard Layouts shorcut option unticks itself
« Reply #7 on: April 26, 2014, 06:11:43 am »
Did you try PCNetSpec's instructions above?
trying to keep up with you guys but have mercy, what is silly for you, it's a burden for me...
re: the
Code: [Select]
setxkbmap -option grp:lalt_lshift_toggle "gb,mk"
... it works, now I have to continue
« Last Edit: April 26, 2014, 06:16:21 am by damig »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26313
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Switching 2 Keyboard Layouts shorcut option unticks itself
« Reply #8 on: April 26, 2014, 06:24:08 am »
OK, if that works, open a terminal and run:
Code: [Select]
sudo gedit /etc/xdg/lxsession/Peppermint/autostart
when a text document with a few lines already in it opens, add a single NEW line at the bottom that reads:-
Code: [Select]
@setxkbmap -option grp:lalt_lshift_toggle "gb,mk"
SAVE the file, and exit gedit.

Now reboot to test it still works after the reboot without you having to run anything in a terminal.

[EDIT]

Once that's working, let us know if you'd like to add the Keyboard Layout Handler panel applet .. that will give you a little flag by your clock telling you which layout is currently active.
« Last Edit: April 26, 2014, 06:33:02 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline damig

  • Member
  • ***
  • Posts: 126
  • Karma: 9
  • New Forum User
    • View Profile
  • Peppermint version(s): 5 (32), 7 (64)
Re: Switching 2 Keyboard Layouts shorcut option unticks itself
« Reply #9 on: April 26, 2014, 06:39:33 am »
I'm not even sure where you guys are trying to change the settings.

Either follow my instructions above, or just add the Keyboard Layout Handler panel applet, and set it to do the same.

Even if you use my original instructions, you'll probably still want to add the Keyboard Layout Handler panel applet, so you have an indicator of which layout you're currently using.
already done that PCNetSpec,
here what was going on guys:
at the beginning, the first thing I did regarding typing and surfing is to add Macedonian keyboard layout in the OS. I found it under preferences>keyboard layout and altho not user friendly, it showed the default en and mk installed. Ok, I snooped around to assign shortcut keys to change the keybord layout and I found the place ticked them both and confidently went back to surfing. But when I would use the shortcut, no change. Then I looked for, found and installed the handler which shows the current keybord layout. It worked! I was switching the flags with the shortcut, and typing latin and cyrillic. But it was for a brief moment. Everything went back to not responding when using the shortcut. My investigation resulted with realising that the system somehow untics the assignment of the shortcut when `apply` is pressed.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26313
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Switching 2 Keyboard Layouts shorcut option unticks itself
« Reply #10 on: April 26, 2014, 06:48:39 am »
See my last posting.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline damig

  • Member
  • ***
  • Posts: 126
  • Karma: 9
  • New Forum User
    • View Profile
  • Peppermint version(s): 5 (32), 7 (64)
Re: Switching 2 Keyboard Layouts shorcut option unticks itself
« Reply #11 on: April 26, 2014, 07:18:22 am »
асдфјасдasd;fjasl;dgjl
it worked! thx guys