Choose style:

Author Topic: Ice custom icon does not work  (Read 5447 times)

0 Members and 1 Guest are viewing this topic.

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4893
  • Karma: 1053
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 10 (64-bit)
Re: Ice custom icon does not work
« Reply #15 on: August 01, 2015, 06:28:24 am »
5kgnbafasnb.png is the name www.mupload.nl attributed to it, I guess randomly. Of course I uploaded the image with its original name, and then www.mupload.nl gave me that output/link.
Where is the this image file located and what is it called?
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26466
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Ice custom icon does not work
« Reply #16 on: August 01, 2015, 06:28:42 am »
OK, try this .. run these commands in sequence
Code: [Select]
cd ~/.local/share/ice
then
Code: [Select]
wget http://www.mupload.nl/img/5kgnbafasnb.png
now open googleinbox.desktop for editing:
Code: [Select]
gedit /home/paul/.local/share/applications/googleinbox.desktop
and make it read:
Code: [Select]
[Desktop Entry]
Version=1.0
Name=Google Inbox
Exec=chromium-browser --app=https://inbox.google.com/
Terminal=false
X-MultipleArgs=false
Type=Application
Icon=/home/paul/.local/share/ice/5kgnbafasnb.png
Categories=GTK;Network;
MimeType=text/html;text/xml;application/xhtml_xml;
StartupWMClass=Chromium
StartupNotify=true
SAVE the file, and eexit gedit.

Check the icon in the menu. (menu > Internet > Google Inbox)



You MAY need to restart the panel before the new icon shows up:
Code: [Select]
lxpanelctl restart
« Last Edit: August 01, 2015, 06:34:53 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline paulus

  • Member
  • ***
  • Posts: 194
  • Karma: 4
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: Ice custom icon does not work
« Reply #17 on: August 01, 2015, 06:51:34 am »
A step forward: in the menu "Internet" it shows the right Google Inbox icon! But after opening it, it shows the blue icon of the Chromium web browser.

Do you know the cause, and how to prevent this in the future?

Sometime this also happens with other SSB's, e.g. the SSB Peppermint Forum, from which I am typing right now: at the moment it shows a kind of empty "document icon", but in other instances it shows the right icon: the known red-white Peppermint icon.

So that's a problem that occurs occasionally.

Another thing: according to a Peppermint instruction video, , it is possible to store the custom icon in a self chosen folder: is that still possible? This would make SSB's so much easier and more user friendly.

Again: thanks!
« Last Edit: August 01, 2015, 06:56:58 am by paulus »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26466
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Ice custom icon does not work
« Reply #18 on: August 01, 2015, 06:58:24 am »
Yes you can store it anywhere you like as long ans you point the SSB to it correctly.

the chromium icon displays in the titlebar if the site has no favicon .. chromium doesn't get the icon in the window titlebar from the locally stored icon.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline paulus

  • Member
  • ***
  • Posts: 194
  • Karma: 4
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: Ice custom icon does not work
« Reply #19 on: August 01, 2015, 07:03:10 am »
Yes you can store it anywhere you like as long ans you point the SSB to it correctly.

the chromium icon displays in the titlebar if the site has no favicon .. chromium doesn't get the icon in the window titlebar from the locally stored icon.

So how could I point the SSB correctly to the icon? In other words: what did I wrong, and how could I correct it?

And: How is it possible that even the originally installed SSB Peppermint Forum is not stable regarding to its proper icon?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26466
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Ice custom icon does not work
« Reply #20 on: August 01, 2015, 07:21:22 am »
no idea .. it's all working for me  :-\

are you sure you don't have any hardware problems ? .. or possibly a corrupt file system ?

and what do you mean by "not stable" ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline paulus

  • Member
  • ***
  • Posts: 194
  • Karma: 4
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: Ice custom icon does not work
« Reply #21 on: August 01, 2015, 07:41:26 am »
no idea .. it's all working for me  :-\

are you sure you don't have any hardware problems ? .. or possibly a corrupt file system ?

and what do you mean by "not stable" ?

As far as I know I don't have any hardware problems, nor a corrupt file system.

By "not stable" I mean that now and then the icon of SSB "Peppermint OS" is not showing the original red-white icon of Peppermint, but sometimes shows another icon, as I described before.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26466
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Ice custom icon does not work
« Reply #22 on: August 01, 2015, 08:16:49 am »
Do you mean "not stable" in the chromium SSB window titlebar or in the menu ?

as I said .. the chromium titlebar icon doesnt come from a local icon .. it comes from the websites favicon, so if that's not showing consistently it's an upstream chromium issue (or maybe a chromium cache issue).
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline paulus

  • Member
  • ***
  • Posts: 194
  • Karma: 4
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: Ice custom icon does not work
« Reply #23 on: August 01, 2015, 09:18:13 am »
Do you mean "not stable" in the chromium SSB window titlebar or in the menu ?

as I said .. the chromium titlebar icon doesnt come from a local icon .. it comes from the websites favicon, so if that's not showing consistently it's an upstream chromium issue (or maybe a chromium cache issue).

I meant by "not stable" the SSB window titlebar, and understand that this is dependent on external websites, so that cannot be restored.

For the rest: I let it go. As said before: it is not the end of the world, and you did a great job by really getting into the matter and tried whatever was possible: this is much appreciated by me: GREAT THANKS! 8)

paulus

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4893
  • Karma: 1053
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 10 (64-bit)
Re: Ice custom icon does not work
« Reply #24 on: December 11, 2015, 02:39:14 pm »
5kgnbafasnb.png is the name www.mupload.nl attributed to it, I guess randomly. Of course I uploaded the image with its original name, and then www.mupload.nl gave me that output/link.
Open up
Code: [Select]
gedit ~/.local/share/applications/googleinbox.desktop
change the contents from:
Code: [Select]
[Desktop Entry]
Version=1.0
Name=Google Inbox
Exec=chromium-browser --app=https://inbox.google.com/
Terminal=false
X-MultipleArgs=false
Type=Application
Icon=/home/paul/.local/share/ice/googleinbox.png
Categories=GTK;Network;
MimeType=text/html;text/xml;application/xhtml_xml;
StartupWMClass=Chromium
StartupNotify=true
to
Code: [Select]
[Desktop Entry]
Version=1.0
Name=Google Inbox
Exec=chromium-browser --app=https://inbox.google.com/
Terminal=false
X-MultipleArgs=false
Type=Application
Icon=/usr/share/pixmaps/5kgnbafasnb.png
Categories=GTK;Network;
MimeType=text/html;text/xml;application/xhtml_xml;
StartupWMClass=Chromium
StartupNotify=true
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.