Author Topic: CD.DVD mount problem on Fujitsu V2040  (Read 2386 times)

Offline NickF

  • Member
  • ***
  • Posts: 59
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
CD.DVD mount problem on Fujitsu V2040
« on: July 28, 2015, 03:20:45 am »
Hi
Just installed Peppermint 6 on this laptop - all fine except a problem with device mounting.
1. The CD/DVD drive fails to mount when media inserted - despite that being set in filemanager preferences.
(at first I though VLC was failing - but it is OK)
If I use a live system from a USB I do NOT have this problem.
2. My standard modification to prevent accidental access to the Win XP, by modifying the FSTAB file as follows:
# Line to prevent mounting WinXP partition without root password:
UUID="UUID of windows volume WinXP"  /media/WinXP  ntfs-3g  noauto,nouser  0 0
seems to fail to stop auto-mount (although it works on older Pmint and similar laptops)
I've probably missed something obvious! But help much appreciated.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: CD.DVD mount problem on Fujitsu V2040
« Reply #1 on: July 28, 2015, 09:03:31 am »
CD mounting - If after inserting the disk,you open the file manager and click on the disk in the left hand column, does the disk then get mounted ?

Blocking Windows partition mounting - can you post the entire contents of:
Code: [Select]
gedit /etc/fstaband the output from:
Code: [Select]
sudo blkid
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline NickF

  • Member
  • ***
  • Posts: 59
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: CD.DVD mount problem on Fujitsu V2040
« Reply #2 on: July 28, 2015, 10:25:28 am »
Hi
If I insert a CD having already opened FileManager, it shows up but does not auto-mount.
Code: [Select]
$ sudo blkid:
/dev/sda1: LABEL="WinXP" UUID="D448C0DA48C0BD0C" TYPE="ntfs"
/dev/sda5: LABEL="Data" UUID="30A135795CD0F2B4" TYPE="ntfs"
/dev/sda6: UUID="8ac46774-657f-47b1-9eae-25d496a5643d" TYPE="ext4"
/dev/sda7: UUID="27b94154-f7ea-4a05-8a8d-2875093f1922" TYPE="swap"

$ gedit /etc/fstab:
/etc/fstab: static file system information.
#
Quote
#Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda6 during installation
UUID=8ac46774-657f-47b1-9eae-25d496a5643d /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda7 during installation
UUID=27b94154-f7ea-4a05-8a8d-2875093f1922 none            swap    sw              0       0
UUID="30A135795CD0F2B4"  /media/Data  ntfs-3g  defaults,windows_names  0 0
UUID="D448C0DA48C0BD0C"  /media/WinXP  ntfs-3g  noauto,nouser  0 0

I added the last 2 lines to FSTAB after using BLKID.
Thanks for helping!
« Last Edit: July 28, 2015, 01:10:53 pm by AndyInMokum »

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4889
  • Karma: 1058
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 10 (64-bit)
Re: CD.DVD mount problem on Fujitsu V2040
« Reply #3 on: July 28, 2015, 01:21:46 pm »
Hi NickF, in future could you please encapsulate terminal outputs with the, # Insert Code function.  It preserves the original format.  This function is located above the,  :-[ Embarrassed emoticon in the forum editor.  Could you also encapsulate gedit text outputs with the, Insert Quote function, also to preserve the original format.  This function is located directly to the right of the, Insert Code function in the forum editor.  I've done this for you this time - many thanks  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline NickF

  • Member
  • ***
  • Posts: 59
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: CD.DVD mount problem on Fujitsu V2040
« Reply #4 on: July 28, 2015, 02:30:21 pm »
Sorry Andy - I'm learning!

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4889
  • Karma: 1058
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 10 (64-bit)
Re: CD.DVD mount problem on Fujitsu V2040
« Reply #5 on: July 28, 2015, 02:41:35 pm »
Sorry Andy - I'm learning!
No problem, I was doing the same when I first joined the forum.  It just takes a little getting used to :).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: CD.DVD mount problem on Fujitsu V2040
« Reply #6 on: July 28, 2015, 05:04:42 pm »
The automounting issue was mentioned in the release notes:
http://peppermintos.com/release-notes/

Quote from: Peppermint Six Release Notes
Plugging in removable media does not cause the new Nemo file manager to prompt to mount the drive, you need to enter the file manager and click on the drive in the left hand column, it will then be mounted.



I'm not 100% sure what you're trying to do in fstab .. but:
Code: [Select]
man ntfs-3gsuggests that the "noauto" and "nouser" options arn't valid for ntfs-3g

If you comment out that line altogether in fstab, IIRC the partition won't be automounted unless you click on it in Nemo for the same reeason as the CDROM isn't being automounted until selectd in Nemo), and then requires your password
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline NickF

  • Member
  • ***
  • Posts: 59
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: CD.DVD mount problem on Fujitsu V2040
« Reply #7 on: July 29, 2015, 03:52:28 am »
Many thanks
Sorry I missed the bit about the CD/DVD - simply caught-out by the change. Easy once you know!
Is that likely to update - or is that a permanent situation?

FSTAB:
I was trying to avoid a less-informed user from damaging Win files from Pmint.
In previous versions the nouser, noauto options did work (some Ubuntu documentation suggests them) - and enforced the requirement for a password on mounting.
The better work-around now seems to be to add 'RO' - so it opens, but can't be altered. In fact it then asks for a password to unmount, but after that damage is possible - but it requires some effort!

I have also added hide_hid_files to both win partition mounts.

Unless you have any further wisdom, that probably about closes this thread.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: CD.DVD mount problem on Fujitsu V2040
« Reply #8 on: July 29, 2015, 05:09:58 am »
Many thanks
Sorry I missed the bit about the CD/DVD - simply caught-out by the change. Easy once you know!
Is that likely to update - or is that a permanent situation?

It's *probably* permanent in Peppermint 6 but may be fixed in Peppermint 7



Thinking about it, "nouser" and "noauto" may just be standard "mount" options .. see:
Code: [Select]
man mount"nouser" should be the default anyway so probably not necessary, but "noauto" may work as an option.

Leave the topic open for now, and I'll have an experiment tonight when I can lay my hands on my sons dual boot PC
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec