Author Topic: Peppermint 6 on Macbook-Air  (Read 2235 times)

Offline tbalon

  • Newly Subscribed
  • *
  • Posts: 3
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 5 and 6
Peppermint 6 on Macbook-Air
« on: August 13, 2015, 08:26:14 am »
I'm a big fan of Peppermint and have used in on many laptops including an older Acer and my main
development laptop Thinkpad X60s. I received a used Macbook-Air recently and wanted to install
Peppermint 6 on it along with the OSX install.

I've was able to boot the USB stick with Peppermint 6 but things the hot-keys don't seem to work well.

1. The hot-keys for screen brightness don't function, screen is always at max brightness
2. The hot-key for sound mute doesn't work, it mutes but doesn't un-mute

I also couldn't find a way to disable the touch-pad while typing.

I tried the Live Mint 17 USB and all the hot-keys and touch-pad settings worked well but I'd rather
use Peppermint since it's memory footprint is lighter and I'm used to the environment.

Have these issues been addressed , anyone using Peppermint 6 on a Macbook find a way to fix these ?


Thanks







Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Peppermint 6 on Macbook-Air
« Reply #1 on: August 13, 2015, 09:13:16 am »
Solution to disable touchpad whilst typing.

Open a terminal and run:
Code: [Select]
syndaemon -i 1 -dthat will kill the touchpad for one second from when you hit a key.

you can adjust the 1 second delay as you see fit .. I use 0.5 (half) second, but you could go as low as 0.01

Don't run the command multiple times as it's being started as a daemon .. terminate it with:
Code: [Select]
sudo killall syndaemonbetween adjustment attempts.

Once you've found a number you're happy with we can run it at login by creating an autostart file .. just let us know what delay you settle on
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Dan

  • Newly Subscribed
  • *
  • Posts: 17
  • Karma: 4
  • New Forum User
    • View Profile
  • Peppermint version(s): 5 & 6
Re: Peppermint 6 on Macbook-Air
« Reply #2 on: August 13, 2015, 09:21:07 am »
I just remove the checkmarks from the Touchpad options in the Peppermint Control Center (Keyboard and Pointer tab). That disables the touchpad on my Toshiba laptop, and it stays disabled unless I put the check marks back again.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Peppermint 6 on Macbook-Air
« Reply #3 on: August 13, 2015, 09:51:58 am »
Sure, you could disable it permanently .. but that's not what you asked  :-\

Quote from: Dan
I also couldn't find a way to disable the touch-pad while typing.
« Last Edit: August 13, 2015, 09:54:06 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Dan

  • Newly Subscribed
  • *
  • Posts: 17
  • Karma: 4
  • New Forum User
    • View Profile
  • Peppermint version(s): 5 & 6
Re: Peppermint 6 on Macbook-Air
« Reply #4 on: August 13, 2015, 10:04:57 am »
Ah...I see. I'm sorry; I was applying my own thought process rather than the actual wording of the request.

Offline tbalon

  • Newly Subscribed
  • *
  • Posts: 3
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 5 and 6
Re: Peppermint 6 on Macbook-Air
« Reply #5 on: August 13, 2015, 12:04:01 pm »
Great .. this seems like a workable solution. 

The big one now is screen brightness, when I use the hot-key to raise or lower the levels the animation
shows on the screen but the brightness remains at the same level  (full brightness) which of course is
really not good for battery life.

Tom

Solution to disable touchpad whilst typing.

Open a terminal and run:
Code: [Select]
syndaemon -i 1 -dthat will kill the touchpad for one second from when you hit a key.

you can adjust the 1 second delay as you see fit .. I use 0.5 (half) second, but you could go as low as 0.01

Don't run the command multiple times as it's being started as a daemon .. terminate it with:
Code: [Select]
sudo killall syndaemonbetween adjustment attempts.

Once you've found a number you're happy with we can run it at login by creating an autostart file .. just let us know what delay you settle on

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline tbalon

  • Newly Subscribed
  • *
  • Posts: 3
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 5 and 6
Re: Peppermint 6 on Macbook-Air
« Reply #7 on: August 13, 2015, 02:30:58 pm »
It's a 13" MacBook Air Mid 2012
MacBookAir 5.2

Hope that helps .. I will try the post you sent .. THANKS

Which model of mackbook air ?

https://help.ubuntu.com/community/MacBookAir5-2/Trusty#Function_Keys

https://help.ubuntu.com/community/MacBookAir6-2/Trusty#Function_Keys