Author Topic: Permanently set xkb options for caps lock control and mac numlock etc (Solved)  (Read 2582 times)

Offline guyboertje

  • Newly Subscribed
  • *
  • Posts: 1
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 6 after 3
I upgraded from 3 to 6.  In 3 I had it all sorted.  I have an Apple Aluminium keyboard so my Linux dev box has the same keyboard as my Macbook Pro.

I like to have the Caps Lock as a Control key and mac numeric keypad giving numbers instead.

In P6 I struggled to find the answer.  I tried "setxkbmap -option caps:ctrl_modifier -option numpad:mac" which worked but did not persist across reboots.

Using setxkbmap in an autostart item did not work.

Eventually I found the local desktop.conf in ~/.config/lxsession/Peppermint/desktop.conf

Which now looks like this.  See the [Keymap] section - the options key - here you can set any options.  I read read the Vala source which just call setxkbmap with what you give it.


Spoiler (click here to view / hide)
[close]
« Last Edit: July 02, 2015, 03:10:26 pm by AndyInMokum »

Offline scifidude79

  • Hero
  • *****
  • Posts: 4029
  • Karma: 870
    • View Profile
  • Peppermint version(s): Peppermint 9
Running this will open the file for the key bindings:

Code: [Select]
gedit ~/.config/peppermint-control-center/xbindkeys.conf
I have no idea if that helps because I don't have a Mac and I'm not entirely sure what you're trying to do.

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4889
  • Karma: 1058
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 10 (64-bit)
Hi guyboertje, I see that the output you returned is very long.  In future, could you please encapsulate long outputs with the Sp Spoiler function.  This is located in the forum editor, just above the crying  :'( emoticon.  It makes it much easier for people to read and keeps things neat and tidy.  This time I've done this for you.  Thanks in advance ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Thanks for posting your solution, and for marking the topic solved :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline utu

  • Newly Subscribed
  • *
  • Posts: 19
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 64-bit Peppermint 7 LiveUSB
I appreciate these suggestions to disable the caps_lock toggle,
but none of them worked for me using a Dell Inspiron 1545 laptop and Peppermint 7.

What did work was adding, or adding-to, the file ~/.config/lxsession/Peppermint/autostart
a command somewht like one suggested early in guyboertje's initial post:
Code: [Select]
setxkbmap -option ctrl:nocaps

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Cheers for that utu .. known working solutions are always welcome :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec