Choose style:

Author Topic: No sound from Acer Aspire One  (Read 2877 times)

0 Members and 1 Guest are viewing this topic.

Offline Rev_Biscuit

  • nOOb
  • *
  • Posts: 15
  • Karma: 0
  • New Forum User
    • View Profile
No sound from Acer Aspire One
« on: June 22, 2015, 03:09:55 pm »
Hi guys, since I've updated to P6 I've lost sound coming from my netbook. Getting sound fine from the headphone jack but not from the onboard speakers. Any ideas?
Everything seems to be on/up in the volume panel and configuration is set to Analogue Stereo Duplex.

Offline scifidude79

  • Global Moderator
  • Hero
  • *****
  • Posts: 4029
  • Karma: 865
    • View Profile
  • Peppermint version(s): Peppermint 9
Re: No sound from Acer Aspire One
« Reply #1 on: June 22, 2015, 03:18:41 pm »
I take it, in the Output Devices tab, you have the Port set to "Analog Output" and not "Headphone"?

Offline Rev_Biscuit

  • nOOb
  • *
  • Posts: 15
  • Karma: 0
  • New Forum User
    • View Profile
Re: No sound from Acer Aspire One
« Reply #2 on: June 22, 2015, 03:24:30 pm »
I only have option of 'Speakers' and ' Headphones (unplugged) '

Offline scifidude79

  • Global Moderator
  • Hero
  • *****
  • Posts: 4029
  • Karma: 865
    • View Profile
  • Peppermint version(s): Peppermint 9
Re: No sound from Acer Aspire One
« Reply #3 on: June 22, 2015, 03:26:54 pm »
Whatever your system calls it, that's obviously not the issue.  I was just checking.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26466
  • Karma: 2885
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: No sound from Acer Aspire One
« Reply #4 on: June 22, 2015, 03:45:14 pm »
Did you keep your home partition from a previous install ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Rev_Biscuit

  • nOOb
  • *
  • Posts: 15
  • Karma: 0
  • New Forum User
    • View Profile
Re: No sound from Acer Aspire One
« Reply #5 on: June 22, 2015, 03:52:24 pm »
Did you keep your home partition from a previous install ?


haha.....erm.....oh dear!...no. Is that bad? Didn't know I had to. Just made a back up of all the documents I needed and then did a clean install.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26466
  • Karma: 2885
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: No sound from Acer Aspire One
« Reply #6 on: June 22, 2015, 03:54:25 pm »
Of course you don't "have to", I was just asking iif you had.

Let's see if resetting PulseAudio fixes things

How to reset pulseaudio:-

Open a terminal and run these commands in sequence:
Code: [Select]
touch ~/.config/pulse/client.conf
then
Code: [Select]
echo autospawn = no > ~/.config/pulse/client.conf
then
Code: [Select]
sudo killall pulseaudio
then
Code: [Select]
mv -vf ~/.config/pulse ~/.config/pulse-old

Pulseaudio should respawn and be back to defaults . you may now need to raise the volume a bit with the volume control by the clock.

If it doesn't respawn, log off/on again.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Rev_Biscuit

  • nOOb
  • *
  • Posts: 15
  • Karma: 0
  • New Forum User
    • View Profile
Re: No sound from Acer Aspire One
« Reply #7 on: June 22, 2015, 04:13:17 pm »
No, nothing.
However, when I ran 'sudo killall pulseaudio', i was asked for password then I got a message. I think it said 'fatal error - cannot find pulse audio' but cannot be sure what it was was. I've tried to recreate it but it's not doing it this time. Still no audio though. The sound bar moves around in the volume control playback though.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26466
  • Karma: 2885
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: No sound from Acer Aspire One
« Reply #8 on: June 22, 2015, 04:42:14 pm »
That error message was just because wekilled pulseaudio for a while .. nothing to worry about

OK, can you make sure in the pulseaudio volume control you have these settings

Output device tab

Port: Speakers
and the 3 little icons above and to the right ALL selected EXCEPT the speaker one.



Configuration tab

Profile: Analogue Stereo Duplex



Now do you get audio from your speakers if you run this is a terminal:
Code: [Select]
aplay /usr/share/sounds/alsa/Front_Center.wav

if not, what's the output from:
Code: [Select]
aplay -l

and can you give us the exact model of AA1
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Rev_Biscuit

  • nOOb
  • *
  • Posts: 15
  • Karma: 0
  • New Forum User
    • View Profile
Re: No sound from Acer Aspire One
« Reply #9 on: June 22, 2015, 05:01:25 pm »
No sound from terminal

Code: [Select]
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

Acer Aspire A0A 150 - Ab

Offline Rev_Biscuit

  • nOOb
  • *
  • Posts: 15
  • Karma: 0
  • New Forum User
    • View Profile
Re: No sound from Acer Aspire One
« Reply #10 on: June 22, 2015, 05:24:37 pm »
thanks for help so far :)
Going to bed though, so don't think I'm ignoring you! I'll post back tomorrow.
Night night!

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26466
  • Karma: 2885
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: No sound from Acer Aspire One
« Reply #11 on: June 22, 2015, 05:41:46 pm »
OK, (whenever you're ready) can you run:
Code: [Select]
cd ~; wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh ; bash alsa-info.sh --upload
the output will contain a URK in red, similar to:-

Quote
Your ALSA information is located at http://www.alsa-project.org/db/?f=fcf0c602bf04924dc1be9f3b0e2a155a03b11181

Please inform the person helping you.

Can you post that URL back here
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Rev_Biscuit

  • nOOb
  • *
  • Posts: 15
  • Karma: 0
  • New Forum User
    • View Profile
Re: No sound from Acer Aspire One
« Reply #12 on: June 24, 2015, 03:06:44 pm »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26466
  • Karma: 2885
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: No sound from Acer Aspire One
« Reply #13 on: June 24, 2015, 04:35:59 pm »
OK, what did you update to Peppermint 6 from ?  ..  Peppermint 5 ?

Does audio work on the Peppermint 6 LiveUSB ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Rev_Biscuit

  • nOOb
  • *
  • Posts: 15
  • Karma: 0
  • New Forum User
    • View Profile
Re: No sound from Acer Aspire One
« Reply #14 on: June 24, 2015, 04:58:43 pm »
I went from 4 to 6.   I posted a few weeks back in regard to not being able to install any software and you kindly helped me out.

I've just tried live usb of peppermint and linux lite and neither of them had any sound.

There is, of course, the possibility that the speakers are broken!