Choose style:

Author Topic: Bluetooth - Autostart [SOLVED]  (Read 1847 times)

0 Members and 1 Guest are viewing this topic.

Offline lswarte

  • Trusted User
  • Member
  • *****
  • Posts: 177
  • Karma: 201
  • Once a noob, always a noob.
    • View Profile
    • Facebook
  • Peppermint version(s): Peppermint 9
Bluetooth - Autostart [SOLVED]
« on: June 20, 2015, 04:13:45 am »
I got a Bose SoundLink Colour speaker connected to a laptop with PM5. It plays fine by now, this post on the forum helped me a lot.

But ... I am surprised by the number of clicks I have to do before it plays music ... At least three clicks in three different windows before it works. Is there an easier or quicker way? How do I have to get it playing now?

  • Start the Bluetooth manager (Blueman)
  • Right click the Bluetooth icon in the system tray and choose the speaker in the recent connections
  • Start Pulseaudio and choose the speaker as output channel
  • Start whatever I want to play music from

That is a lot of work that needs to be done before the speaker does what it is supposed to do. If I compare it to the number of steps needed to get it playing from a phone it is ... not really user friendly. It would be a relief if only Blueman would autostart for example.

Now I have searched here and here to get it easier to play. Among other things I found this in the /etc/xdg/autostart/blueman.desktop file:

Code: [Select]
NotShowIn=LXDE

My interpretation is that blueman does not show up in LXDE. Is that correct? But why not? And would it help me if I would change the file?

Perhaps there is a solution, but I do not feel secure enough to step into it and edit some files without really knowing what I am doing.

Is there any body who can help me?

Thank you in advance.

Laurens Swarte
the Netherlands.
« Last Edit: June 23, 2015, 03:51:34 am by lswarte »

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4889
  • Karma: 1058
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 10 (64-bit)
Re: Bluetooth - Autostart
« Reply #1 on: June 20, 2015, 04:52:50 am »
Hi lswarte, how's it going?  To get Blueman to autostart you need to copy it into your autostart folder.  Open a terminal window with the following keystrokes. Ctrl+Alt+t.  Enter the following command.
Code: [Select]
cp -v /usr/share/applications/blueman-manager.desktop ~/.config/autostart/blueman-manager.desktop
Hit enter.  That'll move it to autostart.  I like to put a time start delay on autostart items.  It prevents things becoming bottlenecked.  Run this command:
Code: [Select]
gedit ~/.config/autostart/blueman-manager.desktop
Edit the line:
Code: [Select]
Exec=blueman-manager
to look like this:
Code: [Select]
Exec=bash -c "sleep 10 ; blueman-manager"
Save the file and exit gedit.  This will put a 10 sec delay on initiating Blueman at boot.   Now logout and back in.  Your Blueman Device Manager will open automatically after 10 secs.  Adjust the timing, according to your needs.  I hope this help to save a bit of time for you  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline lswarte

  • Trusted User
  • Member
  • *****
  • Posts: 177
  • Karma: 201
  • Once a noob, always a noob.
    • View Profile
    • Facebook
  • Peppermint version(s): Peppermint 9
Re: Bluetooth - Autostart
« Reply #2 on: June 21, 2015, 09:22:19 am »
That worked just fine. Thank you, Andy.

It immediately creates another question, I hope I can ask you right here and now, but if you want me to make a new topic I will.

Please take a look at the screenhot:

:

The "Audioprofiel" is set to "Uit" (Out) by default. Hence, the speaker doesn't play any music until I change it from "Uit" to A2DP.

Do you know a way to change that setting?

Thank you,

Laurens Swarte
the Netherlands.

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4889
  • Karma: 1058
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 10 (64-bit)
Re: Bluetooth - Autostart
« Reply #3 on: June 21, 2015, 10:06:05 am »
Hi Laurens, It's my pleasure  ;).  I'm sorry I can't help you with your next question  :-\.  To save confusion, it might be a good idea to start a fresh topic for it in the, Software & Applications section  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.