Choose style:

Author Topic: DNS in MATE and Xubuntu Do Not Reflect Modem's Configured DNS [SOLVED]  (Read 1866 times)

0 Members and 1 Guest are viewing this topic.

Offline perknh

  • Trusted User
  • Hero
  • *****
  • Posts: 3828
  • Karma: 301
  • Soy un huevo, nada más.
    • View Profile
  • Peppermint version(s): Peppermint 10
Hello fellow Peppermint Aficionados,

I went yesterday and today to a friend's home in a order to try to installing Peppermint 6 on her computer that was running Ubuntu Mate --but no luck.  This 11 year-old computer will have nothing to do with Chrome, Chromium, or even Maxthon (which stopped development with Linux months ago.)  No new surprises here.  I was just being hopeful.  ;)

So I went to look at this modem's DNS, and I then see the DNS number had changed from the number I had originally entered to the number 10.0.0.1 --which looks more like a generic router number to me.  Now, after this I saw that the Windows 7 computer's Microsoft Security Essentials anti-virus was turning from yellow to green to yellow continuously even though I had updated it.

So I put two and two together figuring  that something was wrong there, and I would be smart to reinstall Linux and Windows again from scratch.  But, here's the odd thing:  I installed Xubuntu 14.04.2 this time on the desktop, and reinstalled Windows 7 on the labtop, and reentered and saved Norton's ConnectSafe DNS in the modem.  And, after all of this, I looked at Xubuntu's connection information and the Primary DNS was reading 10.0.0.1 all over again!

The actual DNS numbers for Norton ConnectSafe DNS are 199.85.126.10 and 199.85.127.10.  Why does Xubuntu show 10.0.0.1 when there is an Ethernet connection whose real primary DNS is actually 199.85.126.10?

There is a Netgear router for the Wi-Fi in the house, but I don't see why it wouldn't be picking up the modem's DNS.  I tested Norton's DNS and Norton's DNS is working fine for this Desktop computer, but it does not show Norton's actual DNS primary number.

Like I said, I know Norton DNS is actually working.  We tested it --even though it's primary number is not showing with Xubuntu.

Any guesses as to how this could be happening?

I'm stumped with this one.   :-\

Thank you,

perknh
« Last Edit: June 06, 2015, 07:44:06 am by perknh »
We're all Peppermint users and that's what matters  ;).  -- AndyInMokum

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25497
  • Karma: 2807
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: DNS in MATE and Xubuntu Do Not Reflect Modem's True DNS
« Reply #1 on: June 05, 2015, 09:36:10 pm »
modem ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline perknh

  • Trusted User
  • Hero
  • *****
  • Posts: 3828
  • Karma: 301
  • Soy un huevo, nada más.
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: DNS in MATE and Xubuntu Do Not Reflect Modem's Configured DNS
« Reply #2 on: June 05, 2015, 09:45:38 pm »
Yes, there's a Westell modem and, I believe, a Netgear router.  It's not one unit like everybody has these days.  The modem was built in 2006 -- and used to be mine!  I got into, and configured, the DNS in the modem.  I first got into the modem by the numbers 192.168.1.1.  From there I configured the Firewall and the DNS.

P.S.

I see your point!  The modem doesn't have a true DNS.  I've modified the title of this thread.  Thank you.
« Last Edit: June 05, 2015, 09:50:34 pm by perknh »
We're all Peppermint users and that's what matters  ;).  -- AndyInMokum

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25497
  • Karma: 2807
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: DNS in MATE and Xubuntu Do Not Reflect Modem's Configured DNS
« Reply #3 on: June 06, 2015, 05:45:55 am »
OK, I presume you're getting the DNS info (from the OS) by right-clicking the networkmanager tray icon and selecting "Connection Information" ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline perknh

  • Trusted User
  • Hero
  • *****
  • Posts: 3828
  • Karma: 301
  • Soy un huevo, nada más.
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: DNS in MATE and Xubuntu Do Not Reflect Modem's Configured DNS
« Reply #4 on: June 06, 2015, 06:55:04 am »
Yes, exactly.  Where the two a arrows are, next to the language settings, and the clock.  That's it!  ;)
We're all Peppermint users and that's what matters  ;).  -- AndyInMokum

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25497
  • Karma: 2807
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: DNS in MATE and Xubuntu Do Not Reflect Modem's Configured DNS
« Reply #5 on: June 06, 2015, 07:16:02 am »
OK, the IP address ranges

10.0.0.0  -  10.255.255.255
172.16.0.0  -  172.31.255.255
192.168.0.0  -  192.168.255.255

Are all reserved for private networks (LAN's)

With this in mind, I *guess* if network manager can't figure out the DNS it'll default to 10.0.0.1 to be 100% sure it's not going out onto the net.
but if the modem is doing the name resolution via the DNS you entered (in its settings), network manager doesn't really need to know the DNS address (for the internet) .. it broadcasts the request as a domain name, the modem then does the conversion to IP via the DNS it's configured to use.
This WON'T help with internal name resolution (on the LAN) but unless you're networking PC's on te LAN by hostname rather than IP it's unimportant.

If it's working, don't worry about it .. 10.0.0.1 is a safe address (which is the point in networkmanager defaulting to it) :)
« Last Edit: June 06, 2015, 07:21:48 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline perknh

  • Trusted User
  • Hero
  • *****
  • Posts: 3828
  • Karma: 301
  • Soy un huevo, nada más.
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: DNS in MATE and Xubuntu Do Not Reflect Modem's Configured DNS
« Reply #6 on: June 06, 2015, 07:43:17 am »
If it's working, don't worry about it .. 10.0.0.1 is a safe address (which is the point in networkmanager defaulting to it) :)

Yes, that's it!

Spoiler (click here to view / hide)
Interface:  Ethernet
Hardware Address:  F4: EC: (etc....)
Driver:
Speed:   Unknown
Security:  None
IPv4:
IP Address:  10.0.0.6
Broadcast Address:  10.0.0.225
Subnet Mask:  255.255.255.0
Default Route:  10.0.0.1
Primary DNS:  10.0.0.1

IPv6:

Ignored
[close]

Imagine my surprise when I see a number different than the one in the modem.  I had a fit --and apparently over nothing!  :)

By the way, your instructions of how to go back to a previous, now unsupported, version of Flash for Firefox saved the day for us again.

Thank you, PCNetSpec!

perknh

P.S.

A side note:

It took about 10 hours to fully update a new version of a Windows 7 installation for my friend's laptop.  >:(  I've really come to dislike Windows very much after discovering Linux.
« Last Edit: June 06, 2015, 07:57:52 am by perknh »
We're all Peppermint users and that's what matters  ;).  -- AndyInMokum

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25497
  • Karma: 2807
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Looks like the PC is getting it's IP (10.0.0.6) via DHCP from the router (routers IP being 10.0.0.1), so it's setting the router as the DHCP server.

This is actually the correct setup .. name resolution will work on the net via the DNS configured in the router .. name resolution on the internel LAN will be handle by the router.



10 hours to update Win7 .. in my experience that was pretty quick  :o
« Last Edit: June 06, 2015, 09:28:51 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec