Choose style:

Author Topic: Minimal Dark desktop for Peppermint Six.  (Read 9727 times)

0 Members and 1 Guest are viewing this topic.

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 23939
  • Karma: 2656
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Minimal Dark desktop for Peppermint Six.
« Reply #15 on: June 07, 2015, 12:59:08 pm »
What exactly are you trying to get screenfetch to do, and when ?
(display EVERY time you open the terminal ? .. or only when you run the "screenfetch" command in an already open terminal .. or what ?)

and what's the output from:
Code: [Select]
ls -l /usr/bin/screenfetch
and the contents of
Code: [Select]
gedit /usr/lib/peppermint/adjustments/sakura.desktop
« Last Edit: June 07, 2015, 01:00:42 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline mattosensei

  • Member
  • ***
  • Posts: 222
  • Karma: 28
  • Linux with 'L' plates
    • View Profile
  • Peppermint version(s): 6
Re: Minimal Dark desktop for Peppermint Six.
« Reply #16 on: June 07, 2015, 01:07:50 pm »
What exactly are you trying to get screenfetch to do, and when ?
(display EVERY time you open the terminal ? .. or only when you run the "screenfetch" command in an already open terminal .. or what ?)

and what's the output from:
Code: [Select]
ls -l /usr/bin/screenfetch
and the contents of
Code: [Select]
gedit /usr/lib/peppermint/adjustments/sakura.desktop

Wanted it so every time I CTRL+ALT+T I would get the picture/readout on the top part of terminal.

Outputs:

Code: [Select]
ms@linux-desktop ~ $ ls -l /usr/bin/screenfetch
ls: cannot access /usr/bin/screenfetch: No such file or directory
ms@linux-desktop ~ $
I had followed the instructions here: http://tuxtweaks.com/2013/12/install-screenfetch-linux/

Code: [Select]
[Desktop Entry]
Name=Terminal
Comment=Use the command line
TryExec=sakura
Exec=sakura
Icon=lxterminal
Type=Application
Categories=GTK;Utility;TerminalEmulator;
StartupNotify=true
X-Ubuntu-Gettext-Domain=sakura

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4809
  • Karma: 1011
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Minimal Dark desktop for Peppermint Six.
« Reply #17 on: June 07, 2015, 01:20:18 pm »
Hi mattosensei, I'm presuming you followed the screenFetch installation in this link: http://tuxtweaks.com/2013/12/install-screenfetch-linux/.  I'm also presuming you copied it to:
Code: [Select]
/usr/local/bin
or
Code: [Select]
/usr/bin
Open a terminal window and enter the following command:
Code: [Select]
touch ~/.bashrc && gedit ~/.bashrc
in the empty document, copy and paste these lines into it:
Code: [Select]
##Automatically open screenFetch in terminal window
if [ -x /usr/local/bin/screenfetch ]; then screenfetch; fi
Or
Code: [Select]
##Automatically open screenFetch in terminal window
if [ -x /usr/bin/screenfetch ]; then screenfetch; fi
Depending on which bin location you originally saved to.  Save and exit the file.  Test by opening a terminal with the keystrokes: Ctrl + Alt + t.  That should do it  ;).
« Last Edit: June 07, 2015, 04:43:50 pm by AndyInMokum, Reason: upgrading code »
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline mattosensei

  • Member
  • ***
  • Posts: 222
  • Karma: 28
  • Linux with 'L' plates
    • View Profile
  • Peppermint version(s): 6
Re: Minimal Dark desktop for Peppermint Six.
« Reply #18 on: June 07, 2015, 01:23:51 pm »
Hi mattosensei, I'm presuming you followed the screenFetch installation in this link: http://tuxtweaks.com/2013/12/install-screenfetch-linux/.  I'm also presuming you copied it to:
Code: [Select]
/usr/local/bin
or
Code: [Select]
/usr/bin
Open a terminal window and enter the following command:
Code: [Select]
touch ~/.bashrc && gedit ~/.bashrc
in the empty document, copy and paste these lines into it:
Code: [Select]
##Automatically open screenFetch in terminal window
if [ -x /usr/local/bin/screenfetch ]; then screenfetch; fi
Or
Code: [Select]
##Automatically open screenFetch in terminal window
if [ -x /usr/bin/screenfetch ]; then screenfetch; fi
Depending on which bin location you originally saved to.  Save and exit the file.  Test by opening a terminal with the keystrokes: Ctrl + Alt + t.  That should do it  ;).

Thanks - that worked. All good now  :P
« Last Edit: June 07, 2015, 04:47:43 pm by AndyInMokum, Reason: upgrading code »

Offline mattosensei

  • Member
  • ***
  • Posts: 222
  • Karma: 28
  • Linux with 'L' plates
    • View Profile
  • Peppermint version(s): 6
Re: Minimal Dark desktop for Peppermint Six.
« Reply #19 on: June 07, 2015, 01:26:18 pm »


 :D

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4809
  • Karma: 1011
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Minimal Dark desktop for Peppermint Six.
« Reply #20 on: June 07, 2015, 01:32:04 pm »
Very nice indeed  ;).  If you want Sakura to open like this when using the other methods of invoking it.  Let me know and I'll show you how.  What do you think of the Sakura terminal?  I really like it.
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline mattosensei

  • Member
  • ***
  • Posts: 222
  • Karma: 28
  • Linux with 'L' plates
    • View Profile
  • Peppermint version(s): 6
Re: Minimal Dark desktop for Peppermint Six.
« Reply #21 on: June 07, 2015, 01:35:55 pm »
Very nice indeed  ;).  If you want Sakura to open like this when using the other methods of invoking it.  Let me know and I'll show you how.  What do you think of the Sakura terminal?  I really like it.

Thanks Andy.

I went to Menu>Accessories>Terminal and that also opened with the picture! :D I'm less worried about the 4x tabs, was more keen on getting that nice picture and readout every time! I'm all about the window dressing!  :P

PS Your instrucs might make a nice tutorial in the tutorial section of the forum. It's a nice little project.

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 23939
  • Karma: 2656
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Minimal Dark desktop for Peppermint Six.
« Reply #22 on: June 07, 2015, 02:05:25 pm »
@Andy

Here's a better line for ~/.bashrc
Code: [Select]
if [ -x /usr/bin/screenfetch ]; then screenfetch; fi
which check to see if /usr/bin/screenfetch exists and is executabe .. then attempts to run it only if those criteria are met.
it saves the terminal throwing an error if /usr/bin/screenfetch ever gets removed by the user or isn't executable.

just a thought ;)
« Last Edit: June 07, 2015, 02:11:30 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4809
  • Karma: 1011
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Minimal Dark desktop for Peppermint Six.
« Reply #23 on: June 07, 2015, 04:13:05 pm »
@Andy

Here's a better line for ~/.bashrc
Code: [Select]
if [ -x /usr/bin/screenfetch ]; then screenfetch; fi
which check to see if /usr/bin/screenfetch exists and is executabe .. then attempts to run it only if those criteria are met.
it saves the terminal throwing an error if /usr/bin/screenfetch ever gets removed by the user or isn't executable.

just a thought ;)

Yeah, I like it  8)!!
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline cavy

  • Trusted User
  • Member
  • *****
  • Posts: 420
  • Karma: 55
  • Caveman
    • View Profile
    • PeppermentOS Pixies
  • Peppermint version(s): Peppermint Eight
Re: Minimal Dark desktop for Peppermint Six.
« Reply #24 on: June 08, 2015, 04:38:40 pm »
Hi Andy, how is is going fella.

I would offer an compliment, if I could see any of your pictures, they all have that small deleted/bad image icon.
“We know what we are, but not what we may be.”

Desktop Dell 7040 i7-6700 500Gb-SSD 32Gb ram
Laptop    Dell 7470 i5-6300 500Gb-SSD  16Gb ram
Various antiques to sample other OS's etc

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4809
  • Karma: 1011
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Minimal Dark desktop for Peppermint Six.
« Reply #25 on: June 08, 2015, 06:27:56 pm »
Hi cavy, yeah it's going great mate.  How about yourself?  I just checked the images.  The links are working on both of my machines.  They're only links to the image hosting site, imgur.com.  This is a bit of a mystery.  I have no idea why you can't see them  :-\.
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 23939
  • Karma: 2656
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Minimal Dark desktop for Peppermint Six.
« Reply #26 on: June 08, 2015, 07:28:54 pm »
No problem seeing the images here either, even after clearing the browser cache .. so there must be something blocking IMGUR (or images) on cavy's PC.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline WaltH

  • Jr. Member
  • **
  • Posts: 73
  • Karma: 3
  • Know Enough To Be Dangerous
    • View Profile
  • Peppermint version(s): Peppermint OS 7 64-bit
Re: Minimal Dark desktop for Peppermint Six.
« Reply #27 on: September 18, 2015, 10:37:12 am »
I know this thread is a little old, but I just came across it and tried all of the instructions. They worked, except that some of the information text cuts across the ASCII image.



Is there any way to fix this? Thanks.



Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4809
  • Karma: 1011
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Minimal Dark desktop for Peppermint Six.
« Reply #28 on: September 18, 2015, 11:47:22 am »
Hi WaltH, yeah it's really easy.  You need to change the geometry of the Sakura terminal.  You do this by changing the number of columns and rows.  I can't remember what the default geometry is.  As a demonstration, run this in a terminal window:
Code: [Select]
bash -c "sakura -c 89 -r 28"
Sakura is being launched in bash with 89 columns and 28 rows.  If this works for you.  You can replace the keyboard shortcut at: menu > Preferences > Peppermint Control Center.  Double click on the xterminal shortcut and delete it.  Click on any of the other tabs and then return back to: Keyboard Shortcuts.  You can now see the Add New option.  Select this and enter:
Code: [Select]
bash -c "sakura -c 89 -r 28"
Click Ok and then select: Ctrl and: Alt from the options and enter: t into the field.  Click on Ok.  To apply the same to opening Sakura from the menu run this command in a terminal:
Code: [Select]
sudo gedit /usr/lib/peppermint/adjustments/sakura.desktop
Make the file look like the following:
Code: [Select]
[Desktop Entry]
Name=Terminal
Comment=Use the command line
TryExec=sakura
Exec=bash -c "sakura -c 89 -r 28"
Icon=lxterminal
Type=Application
Categories=GTK;Utility;TerminalEmulator;
StartupNotify=true
X-Ubuntu-Gettext-Domain=sakura
Save the file and quit gedit.  Now run this command:
Code: [Select]
cp -v /usr/lib/peppermint/adjustments/sakura.desktop ~/.local/share/applications
Now to finish, run the following command in a terminal window:
Code: [Select]
gedit ~/.config/lxpanel/Peppermint/panels/panel
find the section that reads:
Code: [Select]
}
        item {
            name=Terminal
            image=lxterminal
            action=sakura
and make it read:
Code: [Select]
}
        item {
            name=Terminal
            image=lxterminal
            action=bash -c "sakura -c 89 -r 28"
Save the file and quit gedit.  You should now be set.  Obviously, set the dimensions to suit your screen. 

Note:  After the final command, run this command:
Code: [Select]
ls -a ~/.config/lxpanel/Peppermint/panels
The output should read:
Code: [Select]
.  ..  panel
If it reads:
Code: [Select]
.  ..  panel panel~
run this command:
Code: [Select]
rm -v ~/.config/lxpanel/Peppermint/panels/panel~
I know it looks long, it is comprehensive  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline WaltH

  • Jr. Member
  • **
  • Posts: 73
  • Karma: 3
  • Know Enough To Be Dangerous
    • View Profile
  • Peppermint version(s): Peppermint OS 7 64-bit
Re: Minimal Dark desktop for Peppermint Six.
« Reply #29 on: September 18, 2015, 12:24:54 pm »
Thanks! That did it. I had to go with 95 instead of 89 for the first value because of the lengthy name returned for my CPU, but I'm now set there.