Author Topic: how to disable laptop mouse buttons [ SOLVED ]  (Read 2440 times)

Offline dh2012

  • Newly Subscribed
  • *
  • Posts: 10
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): peppermint 9
how to disable laptop mouse buttons [ SOLVED ]
« on: May 24, 2015, 09:09:18 am »
hello
i have a lenovo thinkpad e530 laptop , and i prefer to use a external mouse , i have managed to disable the touchpad but the buttons seem to remain live ,these are at the top of the touchpad so it is easy to accidently knock one  this is very annoying as  it can totally mess up what i am doing ,  anyone know how to stop these buttons working ?,
        thankyou
« Last Edit: May 30, 2015, 10:47:00 am by dh2012 »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: how to disable laptop mouse buttons
« Reply #1 on: May 25, 2015, 06:35:54 am »
What's the output from:
Code: [Select]
xinput --list?

If you see something like
Quote
mark@AA1-Blue ~ $ xinput --list
⎡ Virtual core pointer                       id=2   [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                 id=4   [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                 id=12   [slave  pointer  (2)]
⎣ Virtual core keyboard                      id=3   [master keyboard (2)]
    ↳ Virtual core XTEST keyboard                id=5   [slave  keyboard (3)]
    ↳ Power Button                               id=6   [slave  keyboard (3)]
    ↳ Video Bus                                  id=7   [slave  keyboard (3)]
    ↳ Power Button                               id=8   [slave  keyboard (3)]
    ↳ Sleep Button                               id=9   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard               id=11   [slave  keyboard (3)]
    ↳ USB 2.0 Camera
Try running:
Code: [Select]
xinput --disable "SynPS/2 Synaptics TouchPad"(be sure to include the quotation marks if the device name contains spaces)

you can re-enable it with:
Code: [Select]
xinput --enable "SynPS/2 Synaptics TouchPad"or logging off/on or rebooting.

if that works (kills the touchpad and buttons, but doesn't affect the mouse) let us know the exact command that disabled it and we'll tell you how to either create an icon for disabling/re-enabling, or automate the disbling at bootup.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline dh2012

  • Newly Subscribed
  • *
  • Posts: 10
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): peppermint 9
Re: how to disable laptop mouse buttons
« Reply #2 on: May 27, 2015, 12:43:23 pm »
thankyou for your reply . copy /pasted the commands to get them right , but does not seem to have made any difference buttons still work ,, this is what i got

david@david-ThinkPad-Edge-E530 ~ $ xinput --list
⎡ Virtual core pointer                       id=2   [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                 id=4   [slave  pointer  (2)]
⎜   ↳ Lenovo USB Laser Mouse                     id=9   [slave  pointer  (2)]
⎜   ↳ TPPS/2 IBM TrackPoint                      id=12   [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                 id=11   [slave  pointer  (2)]
⎣ Virtual core keyboard                      id=3   [master keyboard (2)]
    ↳ Virtual core XTEST keyboard                id=5   [slave  keyboard (3)]
    ↳ Power Button                               id=6   [slave  keyboard (3)]
    ↳ Video Bus                                  id=7   [slave  keyboard (3)]
    ↳ Power Button                               id=8   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard               id=10   [slave  keyboard (3)]
    ↳ ThinkPad Extra Buttons                     id=13   [slave  keyboard (3)]
david@david-ThinkPad-Edge-E530 ~ $  xinput --disable "SynPS/2 Synaptics TouchPad"
david@david-ThinkPad-Edge-E530 ~ $







Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: how to disable laptop mouse buttons
« Reply #3 on: May 27, 2015, 02:32:26 pm »
So what happens of you run both
Code: [Select]
xinput --disable "SynPS/2 Synaptics TouchPad"and
Code: [Select]
xinput --disable "TPPS/2 IBM TrackPoint"?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline dh2012

  • Newly Subscribed
  • *
  • Posts: 10
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): peppermint 9
Re: how to disable laptop mouse buttons
« Reply #4 on: May 29, 2015, 11:24:22 am »
ran them both and after the second one    xinput --enable "SynPS/2 Synaptics TouchPad"    the buttons were dead  :)  but they work again after a restart , is there any way of killing them permanently  ? as i cannot imagine ever wanting to use them 

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: how to disable laptop mouse buttons
« Reply #5 on: May 29, 2015, 05:46:07 pm »
yes but first you'll need to tell me EXACTLY which command(s) you needed to run to kill the buttons because your last message made no sense.

a) "--enable" wouldn't kill the buttons
b) "SynPS/2 Synaptics TouchPad" wasn't the second command
c) did you need to run BOTH commands, which two, and in what order ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline dh2012

  • Newly Subscribed
  • *
  • Posts: 10
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): peppermint 9
Re: how to disable laptop mouse buttons
« Reply #6 on: May 30, 2015, 01:30:29 am »
sorry messed that last message up
buttons work on start up,,  first ran    xinput --disable "SynPS/2 Synaptics TouchPad"
buttons still work
second ran    xinput --disable "TPPS/2 IBM TrackPoint"
buttons dead but work again on restart

david@david-ThinkPad-Edge-E530 ~ $ xinput --disable "SynPS/2 Synaptics TouchPad"david@david-ThinkPad-Edge-E530 ~ $ xinput --disable "TPPS/2 IBM TrackPoint"
david@david-ThinkPad-Edge-E530 ~ $

restart buttons work again  so ive tried just
  xinput --disable "TPPS/2 IBM TrackPoint"
and buttons dead , so looks like first command not needed ?

david@david-ThinkPad-Edge-E530 ~ $ xinput --disable "TPPS/2 IBM TrackPoint"
david@david-ThinkPad-Edge-E530 ~ $





Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: how to disable laptop mouse buttons
« Reply #7 on: May 30, 2015, 02:22:56 am »
Spot on :)

OK, let's create an autostart file that runs that command at login .. open a terminal and run:
Code: [Select]
gedit ~/.config/autostart/trackpoint-disable.desktopwhen a BLANK file opens, make it read:
Code: [Select]
[Desktop Entry]
Type=Application
Name=TrackPoint Disable
Comment=Disasbe the TPPS/2 IBM TrackPoint
Exec=xinput --disable "TPPS/2 IBM TrackPoint"
Icon=input-mouse
Terminal=false
SAVE the file.

Now log off/on (or reboot) to test.



To UNDO

If at any point you want to re-enable the touchpad temporarily .. opeen a gterminal (Ctrl+Alt+T) and run:
Code: [Select]
xinput --enable "TPPS/2 IBM TrackPoint"or to re-enable it permanently, just delete that autostart file:
Code: [Select]
rm -v ~/.config/autostart/trackpoint-disable.desktop
« Last Edit: May 30, 2015, 03:19:25 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline dh2012

  • Newly Subscribed
  • *
  • Posts: 10
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): peppermint 9
Re: how to disable laptop mouse buttons
« Reply #8 on: May 30, 2015, 10:45:41 am »
thats worked a treat , thankyou very much for your help  :)

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: how to disable laptop mouse buttons [ SOLVED ]
« Reply #9 on: May 30, 2015, 11:22:01 am »
You're welcome .. thanks for marking the topic solved :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec