Choose style:

Author Topic: Pitchforks II, Snappy.  (Read 886 times)

0 Members and 1 Guest are viewing this topic.

Offline sanguinemoon

  • Jr. Member
  • **
  • Posts: 83
  • Karma: 12
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Pitchforks II, Snappy.
« on: May 14, 2015, 11:38:57 pm »
 I'm concerned about Ubuntu moving away from .deb . I have some third-party software that's vital to me, such as  Writer's Cafe (http://www.writerscafe.co.uk/) that won't come in Snappy. The outlines for my novel, novellas and short stories are in Writer's Cafe format so I can't simply find alternative software. I can't be the only user that needs specialized programs that are not in the repositories. Maybe the "Generic Installer" will work in this case, but what about updates, etc?

Some responses noted this is only Ubuntu Next, but Cooke makes it clear that Ubuntu 15.10 will be based on the new package format. Decisions like this from Canonical that ignore the needs of end users in name of embracing "the future" could well be the deal killer against using any Ubuntu-based distro once this flows downstream.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 24484
  • Karma: 2698
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Pitchforks II, Snappy.
« Reply #1 on: May 15, 2015, 07:35:27 am »
http://www.webupd8.org/2015/04/ubuntu-desktop-to-eventually-switch-to.html

Michael Hall from Canonical suggests the plan is to have both a .deb and snappy builds of 16.04 so you should be OK for a while yet ;)

Beyond that it's only a packaging issue so I'd expect most non-repo software authors to eventually do a snappy package

You'll still be able to compile from source, or use a generic binary installer
(Writer's Café can be downloaded as a "generic installer" .. which is basically an archive and installation script, that should still work .. but eventually I'd expect they'll also do a snappy/click package)

Seriously I wouldn't worry about it .. Canonical/Ubuntu aren't going to shoot themselves in the foot by making it impossible to install third party software .. they'd die overnight ;)
« Last Edit: May 15, 2015, 07:37:52 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec