Choose style:

Author Topic: [SOLVED] USB Audio DAC not working  (Read 3454 times)

0 Members and 1 Guest are viewing this topic.

Offline d1g1tal

  • nOOb
  • *
  • Posts: 3
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 4
[SOLVED] USB Audio DAC not working
« on: April 14, 2014, 06:36:31 pm »
My USB DAC was detected out of the box fine, but was not the default, so I had to manually change the output device which was a bit annoying, but worked. Unfortunately there is no option for this in Chrome or Opera, so no sound through my browser if I use my DAC :-(

This lead me in to looking into ALSA and messing around with a few settings. I briefly got sounds in my browser, but the next time I rebooted (several days later) there was no sound and additionally the USB DAC is no longer even listed as an audio device for me to manually change to in Audacious, which I use for most of my listening.

By this point I couldn't remember 100% what I had changed. Now I could probably get back to where I was pretty easily with a full re-install, but I'd like to understand for ALSA works and I don't think I'm *too* far away from getting it to work how I want.

Here's some of my config and other details:

From dmesg:
Code: [Select]
[    3.189078] usb 4-2: new full-speed USB device number 3 using uhci_hcd
[    3.399177] usb 4-2: New USB device found, idVendor=08bb, idProduct=2704
[    3.399193] usb 4-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    3.399202] usb 4-2: Product: USB Audio DAC   
[    3.399209] usb 4-2: Manufacturer: Burr-Brown from TI             

[    4.178471] cannot find the slot for index 0 (range 0-1), error: -16
[    4.178562] cannot create card instance 0
[    4.178646] snd-usb-audio: probe of 4-2:1.0 failed with error -5
[    4.179849] usbcore: registered new interface driver snd-usb-audio

Code: [Select]
me@peppermint4 ~ $ cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfcffc000 irq 43
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfe97c000 irq 17
me@peppermint4 ~ $ cat /proc/asound/modules
 0 snd_hda_intel
 1 snd_hda_intel
me@peppermint4 ~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
me@peppermint4 ~ $

This was the contents of my .asoundrc file until I deleted it to see if that helped, which it didn't.

Code: [Select]
pcm.!default front:DAC # USB Audio DAC
# pcm.!default front:Intel # HDA Intel STAC92xx Analog

...and finally my alsa-base.conf file
Code: [Select]
# Load snd-usb-audio as first soundcard
options snd-usb-audio index=0

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2

Any help greatly appreciated!
« Last Edit: May 10, 2014, 09:46:55 am by d1g1tal »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 15180
  • Karma: 1816
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 7 Respin (64bit)
Re: USB Audio DAC not working
« Reply #1 on: April 14, 2014, 07:19:22 pm »
The first thing I'd try would be installing PulseAudio:
Code: [Select]
sudo apt-get install pulseaudio pulseaudio-utils pavucontrol
and seeing if configuring audio through the newly added menu item

menu > Sound & Video > PulseAudio Volume Control

gets things working ;)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
Linux in the UK

Offline d1g1tal

  • nOOb
  • *
  • Posts: 3
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 4
Re: USB Audio DAC not working
« Reply #2 on: April 15, 2014, 07:20:52 pm »
The first thing I'd try would be installing PulseAudio:
Code: [Select]
sudo apt-get install pulseaudio pulseaudio-utils pavucontrol
and seeing if configuring audio through the newly added menu item

menu > Sound & Video > PulseAudio Volume Control

gets things working ;)
Had to take out the "options snd-usb-audio index=0" line as well, but I seem to have got things working and the GUI of pavucontrol is a much nicer way of sorting things than a variety of alsa config files.

I'll check that all is well once I've rebooted and tried a few more apps, then mark this as solved.

Thanks  :)

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 15180
  • Karma: 1816
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 7 Respin (64bit)
Re: USB Audio DAC not working
« Reply #3 on: April 15, 2014, 08:35:13 pm »
Great news, and you're more than welcome. :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
Linux in the UK