Choose style:

Author Topic: nm-applet acting up for the past several days.  (Read 1330 times)

0 Members and 1 Guest are viewing this topic.

Offline willow

  • Newly Subscribed
  • *
  • Posts: 1
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 5
nm-applet acting up for the past several days.
« on: March 11, 2015, 06:44:31 pm »
Since maybe a few days ago I noticed that nm-applet is acting up. "Disconnect" link is greyed out, and on right-click, "Enable Wireless," "Enable Wi-Fi" and "Edit Connections" are greyed out. So I cannot disconnect from a network that connected automatically, or switch to another network.

I looked up the networkmanager bug tracker and I have not seen anything being reported. So it is quite possible that the problem is caused by interference from another software that was upgraded recently.

Interestingly, though, when I
Code: [Select]
ps -aux | grep "nm-applet"
and
Code: [Select]
kill -SIGTERM (task number here)
then
Code: [Select]
nm-applet

the applet starts again with all the greyed out links now active and usable.

This is weird. I have not seen this happen until recently.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: nm-applet acting up for the past several days.
« Reply #1 on: March 13, 2015, 10:26:01 am »
Try this .. open a terminal and run:
Code: [Select]
mkdir ~/.config/autostart/unstarted
then
Code: [Select]
mv -v ~/.config/autostart/nm-applet.desktop ~/.config/autostart/unstarted/nm-applet.desktop
now log off/on (or reboot) .. and seee if nm-applet still starts, and if so if it helped with your problem.

If not you can always put it back with:
Code: [Select]
mv -v ~/.config/autostart/unstarted/nm-applet.desktop ~/.config/autostart//nm-applet.desktop
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec