Author Topic: Any version of Ubuntu 14.4.2+ That Uses YouTube with Firefox [SOLVED]  (Read 4962 times)

0 Members and 1 Guest are viewing this topic.

Offline perknh

  • Trusted User
  • Hero
  • *****
  • Posts: 3972
  • Karma: 362
  • Soy un huevo, nada más.
    • View Profile
  • Peppermint version(s): Peppermint 10
Peppermint and Ubuntu users,

I have a friend with an old, old, old HP desktop computer.  It's a computer on which Chrome or Chromium browser won't function at all.  Peppermint 5 had, long ago, proven itself to be a no-go with this computer. (Thank you mac, PCNetSpec, and everyone who tried to help me 11 months ago with that issue.)  So, I eventually put Xubuntu on this old legacy computer.  Now a couple of days ago, I wanted to show one of my dearest of friends, who both owns and uses this computer, a video on YouTube.  And this is where my, and this old computer's, troubles begin.

YouTube in Firefox (the most current version whatever that may be) will not work with Xubuntu 14.04.2, 14.10, or 15.04.  It will not work within Ubuntu MATE 14.04.2 either.  Yes, for a split instant the YouTube video flashes onto the screen, and then, where the video would be, that space becomes empty and white, blending in with the white background of YouTube itself -- with no trace of a video to be seen.

I don't have access to that computer right this moment, but I'm wondering if any of the Firefox users using Peppermint, or any people here, who use any flavor of Ubuntu, have experienced any issue similar as this concerning Firefox and YouTube; and if so, what can I do about it when I get a chance to get back to that old legacy computer?

Thank you,

perknh
« Last Edit: March 11, 2015, 01:45:23 pm by perknh »
[T]here are a lot of people happily running Peppermint ICE which hasn't been receiving ANY updates for a while now .. and I personally would STILL consider that MUCH more secure than any version of Windows with up-to-date AV/Anti-malware ;)

--  PCNetSpec, Cornwall, Eng.  Dec 03, 2013 5:18 pm

Offline rjm65

  • Veteran
  • ****
  • Posts: 1013
  • Karma: 310
  • I have Peppermint Fresh Breath. :P
    • View Profile
  • Peppermint version(s): Win-98 /Win-7/ Peppermint 9
Re: Any version of Ubuntu 14.4.2+ That Uses Firefox with YouTube
« Reply #1 on: March 10, 2015, 02:07:30 pm »
yes i experienced this and pcnetspec solved it a long while back, it is flash, you don't have i think its sse2 or some type of flag on your processor that the new flash uses, going back to the old flash works on those processors...  :P
Robert
Peppermint 9 User

Gateway Solo 9300 Pro
IBM T40

Offline perknh

  • Trusted User
  • Hero
  • *****
  • Posts: 3972
  • Karma: 362
  • Soy un huevo, nada más.
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: Any version of Ubuntu 14.4.2+ That Uses YouTube with Firefox
« Reply #2 on: March 10, 2015, 05:01:13 pm »
Thank you, rjm65.

Would you know which thread offers a solution to this problem?

When we installed Xubuntu 14.04, we did not have this problem.

Thank you,

perknh

P.S.

I never dawned on me until now to try Qupzilla or Opera, do you think one of these browsers might offer a simple solution for this problem.  I should mention that I did uninstall and then re-install Flash once through Ubuntu's software manager.  And I also installed Ubuntu-restricted-extras on one of my several installations too;  but none of these efforts helped me with this problem.
« Last Edit: March 10, 2015, 08:06:32 pm by perknh »
[T]here are a lot of people happily running Peppermint ICE which hasn't been receiving ANY updates for a while now .. and I personally would STILL consider that MUCH more secure than any version of Windows with up-to-date AV/Anti-malware ;)

--  PCNetSpec, Cornwall, Eng.  Dec 03, 2013 5:18 pm

Offline rjm65

  • Veteran
  • ****
  • Posts: 1013
  • Karma: 310
  • I have Peppermint Fresh Breath. :P
    • View Profile
  • Peppermint version(s): Win-98 /Win-7/ Peppermint 9
Re: Any version of Ubuntu 14.4.2+ That Uses Firefox with YouTube
« Reply #3 on: March 10, 2015, 06:31:47 pm »
I have the text file from the thread on my linux tricks usb stick, here is what fixed it for me.... 
be sure to do the first command and see if your processor has sse2 if it don't then try what he said to try to fix it...  okie dokie???-------------
cat /proc/cpuinfo | grep sse
flags      : fpu vme de pse tsc msr pae mce cx8 mtrr pge mca cmov pse36 mmx fxsr sse up

uname -a
Linux gateway9300pro-Solo-9300-Pro 3.2.0-60-generic #91-Ubuntu SMP Wed Feb 19 03:55:18 UTC 2014 i686 i686 i386 GNU/Linux

dpkg -l | grep flash
ii  flashplugin-installer                  11.2.202.341ubuntu0.12.04.1               Adobe Flash Player plugin installer

Code: [Select]
You're right, your CPU doesn't support sse2 so the 11.2.202 version of Adobes flash player won't work.

OK, uninstall flashplugin-installer:
Code:
sudo apt-get remove --purge flashplugin-installer

create the necessary directory for the flashplayer plugin:
Code:
mkdir -p ~/.mozilla/plugins

change directory to that directory:
Code:
cd ~/.mozilla/plugins

download the 32bit 11.1 flashplayer archive from my dropbox:
Code:
wget https://dl.dropboxusercontent.com/u/11876059/flashplayer-11.1-32bit.tar.gz

unpack the archive:
Code:
tar xvf flashplayer-11.1-32bit.tar.gz

now close ALL web browser instances and re-open Chromium

Test Flash
« Last Edit: March 10, 2015, 06:35:30 pm by rjm65 »
Robert
Peppermint 9 User

Gateway Solo 9300 Pro
IBM T40

Offline perknh

  • Trusted User
  • Hero
  • *****
  • Posts: 3972
  • Karma: 362
  • Soy un huevo, nada más.
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: Any version of Ubuntu 14.4.2+ That Uses YouTube with Firefox
« Reply #4 on: March 10, 2015, 06:35:03 pm »
Thank you, rjm65! ;)
« Last Edit: March 10, 2015, 08:07:03 pm by perknh »
[T]here are a lot of people happily running Peppermint ICE which hasn't been receiving ANY updates for a while now .. and I personally would STILL consider that MUCH more secure than any version of Windows with up-to-date AV/Anti-malware ;)

--  PCNetSpec, Cornwall, Eng.  Dec 03, 2013 5:18 pm

Offline rjm65

  • Veteran
  • ****
  • Posts: 1013
  • Karma: 310
  • I have Peppermint Fresh Breath. :P
    • View Profile
  • Peppermint version(s): Win-98 /Win-7/ Peppermint 9
Re: Any version of Ubuntu 14.4.2+ That Uses Firefox with YouTube
« Reply #5 on: March 10, 2015, 06:37:22 pm »
no problem like i said though check your processor first for sse2 if it has sse2 then you have another issue mine was old and only had sse and not sse2
Robert
Peppermint 9 User

Gateway Solo 9300 Pro
IBM T40

Offline perknh

  • Trusted User
  • Hero
  • *****
  • Posts: 3972
  • Karma: 362
  • Soy un huevo, nada más.
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: Any version of Ubuntu 14.4.2+ That Uses YouTube with Firefox
« Reply #6 on: March 10, 2015, 08:04:29 pm »
I will check that, rjm65. 

Now I see, at the end of PCNetSpec's instructions, to reopen Chromium.  I suspect the same instructions will apply to Firefox browser too.

A Flash issue is a Flash issue no matter what browser one is using, I hope!

perknh
« Last Edit: March 10, 2015, 08:07:53 pm by perknh »
[T]here are a lot of people happily running Peppermint ICE which hasn't been receiving ANY updates for a while now .. and I personally would STILL consider that MUCH more secure than any version of Windows with up-to-date AV/Anti-malware ;)

--  PCNetSpec, Cornwall, Eng.  Dec 03, 2013 5:18 pm

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Any version of Ubuntu 14.4.2+ That Uses YouTube with Firefox
« Reply #7 on: March 10, 2015, 08:29:00 pm »
before you go any further, please post the output from:
Code: [Select]
uname -a
and
Code: [Select]
dpkg -l | grep flash
and
Code: [Select]
cat /proc/cpuinfo | grep -i flags
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline perknh

  • Trusted User
  • Hero
  • *****
  • Posts: 3972
  • Karma: 362
  • Soy un huevo, nada más.
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: Any version of Ubuntu 14.4.2+ That Uses YouTube with Firefox
« Reply #8 on: March 10, 2015, 08:58:49 pm »
Hello PCNetSpec and thank you.

I will happily do so when I can return to that house.  I hope to be able to do so within a week.  The computer is in another town, and these folks are on a different schedule than me.

By the way, MATE seems to be a little speedier on that old computer than Xubuntu.

Thank you,

perknh
[T]here are a lot of people happily running Peppermint ICE which hasn't been receiving ANY updates for a while now .. and I personally would STILL consider that MUCH more secure than any version of Windows with up-to-date AV/Anti-malware ;)

--  PCNetSpec, Cornwall, Eng.  Dec 03, 2013 5:18 pm

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Any version of Ubuntu 14.4.2+ That Uses YouTube with Firefox
« Reply #9 on: March 10, 2015, 09:16:33 pm »
Okey Dokey pernh .. whenever you're ready :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline rjm65

  • Veteran
  • ****
  • Posts: 1013
  • Karma: 310
  • I have Peppermint Fresh Breath. :P
    • View Profile
  • Peppermint version(s): Win-98 /Win-7/ Peppermint 9
Re: Any version of Ubuntu 14.4.2+ That Uses YouTube with Firefox
« Reply #10 on: March 11, 2015, 08:40:55 am »
I will check that, rjm65. 

Now I see, at the end of PCNetSpec's instructions, to reopen Chromium.  I suspect the same instructions will apply to Firefox browser too.

A Flash issue is a Flash issue no matter what browser one is using, I hope!

perknh
I never used chrome or chromium the first thing i always install is firefox if firefox is not installed by default....
Robert
Peppermint 9 User

Gateway Solo 9300 Pro
IBM T40

Offline perknh

  • Trusted User
  • Hero
  • *****
  • Posts: 3972
  • Karma: 362
  • Soy un huevo, nada más.
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: Any version of Ubuntu 14.4.2+ That Uses YouTube with Firefox
« Reply #11 on: March 11, 2015, 11:54:50 am »
before you go any further, please post the output from:
Code: [Select]
uname -a
and
Code: [Select]
dpkg -l | grep flash
and
Code: [Select]
cat /proc/cpuinfo | grep -i flags

PCNetSpec, 

I did switch from MATE to Lubuntu on this old computer.  The computer was freezing up and unable to shut down with MATE.

perknh

Here's the data you asked for:

uname -a
Spoiler (click here to view / hide)
Linux hamilton 3.16.0-31-generic #41~14.04.1-Ubuntu SMP W dpkg -l | grep flash
ii  flashplugin-installer                       11.2.202.442ubuntu0.14.04.1          i386         Adobe Flash Player plugin installer
ed Feb 11 19:30:43 UTC 2015 i686 athlon i686 GNU/Linux
[close]


dpkg -l | grep flash
Spoiler (click here to view / hide)
ii  flashplugin-installer                       11.2.202.442ubuntu0.14.04.1          i386         Adobe Flash Player plugin installer
[close]

cat /proc/cpuinfo | grep -i flags
Spoiler (click here to view / hide)
flags      : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow vmmcall
[close]
[T]here are a lot of people happily running Peppermint ICE which hasn't been receiving ANY updates for a while now .. and I personally would STILL consider that MUCH more secure than any version of Windows with up-to-date AV/Anti-malware ;)

--  PCNetSpec, Cornwall, Eng.  Dec 03, 2013 5:18 pm

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Any version of Ubuntu 14.4.2+ That Uses YouTube with Firefox
« Reply #12 on: March 11, 2015, 12:34:51 pm »
Yep, as rjm65 suspected you have no sse2 flag so you'll need to downgrade to flashplayer 11.1

Open a terminal and run these commands in sequence
Code: [Select]
sudo apt-get remove --purge flashplugin-installer
then
Code: [Select]
mkdir -p ~/.mozilla/plugins
then
Code: [Select]
cd ~/.mozilla/plugins
then
Code: [Select]
wget https://dl.dropboxusercontent.com/u/11876059/flashplayer-11.1-32bit.tar.gz
then
Code: [Select]
tar xvf flashplayer-11.1-32bit.tar.gz
now close ALL web browser instances and re-open Firefox

Test Flash
« Last Edit: March 11, 2015, 12:40:46 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline perknh

  • Trusted User
  • Hero
  • *****
  • Posts: 3972
  • Karma: 362
  • Soy un huevo, nada más.
    • View Profile
  • Peppermint version(s): Peppermint 10
Re: Any version of Ubuntu 14.4.2+ That Uses YouTube with Firefox
« Reply #13 on: March 11, 2015, 12:47:39 pm »
Thank you, PCNetSpec, we're almost there!

Now I get this message that reads  "Firefox has prevented the outdated plugin "Adobe Flash" from running on www.youtube.com."

I bet rjm65 thinks this computer is an excellent candidate for antiX or MX-14!   ;)
« Last Edit: March 11, 2015, 01:01:19 pm by perknh »
[T]here are a lot of people happily running Peppermint ICE which hasn't been receiving ANY updates for a while now .. and I personally would STILL consider that MUCH more secure than any version of Windows with up-to-date AV/Anti-malware ;)

--  PCNetSpec, Cornwall, Eng.  Dec 03, 2013 5:18 pm

Offline rjm65

  • Veteran
  • ****
  • Posts: 1013
  • Karma: 310
  • I have Peppermint Fresh Breath. :P
    • View Profile
  • Peppermint version(s): Win-98 /Win-7/ Peppermint 9
Re: Any version of Ubuntu 14.4.2+ That Uses YouTube with Firefox
« Reply #14 on: March 11, 2015, 12:58:38 pm »
Thank you, PCNetSpec, we're almost there!

Now I get this message that reads  "Firefox has prevented the outdated plugin "Adobe Flash" from running on www.youtube.com."

I bet rjm65 thinks this computer is a good candidate for antiX or MX-14!  :)
Actually I think they use the same plugin so it is not going to matter, I could be wrong though...  :P
Robert
Peppermint 9 User

Gateway Solo 9300 Pro
IBM T40