Choose style:

Author Topic: [SOLVED] Minimal problem with scrolling after kernel update  (Read 2203 times)

0 Members and 1 Guest are viewing this topic.

Offline MaxPax

  • nOOb
  • *
  • Posts: 23
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 5 x64
[SOLVED] Minimal problem with scrolling after kernel update
« on: February 22, 2015, 03:03:44 am »
So, it's just nagging me. I tend to use the horisontal two-finger scrolling on my peppermint laptop and after kernel update (which always make me a bit nervous because there's always things that gets screwed up with a kenel update, really annoying) the horisontal scrolling doesn't work anymore.

I can go to peppermint control, keyboard & pointer, untick the "tho finger horizontal scrolling" and just tick it again and it works again. I have to do this every restart which gets me wondering if there is any command I could put in autostart that would do the same...
« Last Edit: February 22, 2015, 04:10:19 pm by MaxPax »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26082
  • Karma: 2842
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Minimal problem with scrolling after kernel update
« Reply #1 on: February 22, 2015, 09:56:47 am »
When you boot (before making any changes in peppermint-control-center), what's the contents of:
Code: [Select]
gedit ~/.config/peppermint-control-center/pointer
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline MaxPax

  • nOOb
  • *
  • Posts: 23
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 5 x64
Re: Minimal problem with scrolling after kernel update
« Reply #2 on: February 22, 2015, 01:09:00 pm »
Code: [Select]
#!/bin/bash
#Autogenerated script - Do not edit
xset m 2 2
xmodmap -e "pointer = 1 2 3"
synclient TouchPadOff=0
synclient VertEdgeScroll=0
synclient HorizEdgeScroll=0
synclient TapButton1=1
synclient VertTwoFingerScroll=1
synclient HorizTwoFingerScroll=1

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26082
  • Karma: 2842
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Minimal problem with scrolling after kernel update
« Reply #3 on: February 22, 2015, 02:37:44 pm »
OK, here's the sequence of events that apply the settings in that file at each startup of the desktop environment

the autostart file
~/.config/autostart/peppermint-control-center.desktop
executes the file
/usr/bin/ppmc-startup
which in turn runs the 3 executables at
~/.config/peppermint-control-center/pointer
~/.config/peppermint-control-center/keyboard
~/.config/peppermint-control-center/keyboard_layout


We need to figure out which step of that chain is failing

When you first boot, try running
Code: [Select]
ppmc-startup
did 2 finger scrolling start to work ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline MaxPax

  • nOOb
  • *
  • Posts: 23
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 5 x64
Re: Minimal problem with scrolling after kernel update
« Reply #4 on: February 22, 2015, 03:13:37 pm »
When I run "/usr/bin/ppmcc-startup" yes, it starts to work.

Thanks a bunch so far. I'll put that in my autostart list.
« Last Edit: February 22, 2015, 03:31:03 pm by MaxPax »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26082
  • Karma: 2842
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Minimal problem with scrolling after kernel update
« Reply #5 on: February 22, 2015, 03:43:00 pm »
let me know if adding it to your autostart list works .. otherwise we may just need to add a delay to it.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline MaxPax

  • nOOb
  • *
  • Posts: 23
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 5 x64
Re: Minimal problem with scrolling after kernel update
« Reply #6 on: February 22, 2015, 03:51:11 pm »
i'll try it straight away, hold on.

Offline MaxPax

  • nOOb
  • *
  • Posts: 23
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 5 x64
Re: Minimal problem with scrolling after kernel update
« Reply #7 on: February 22, 2015, 03:53:53 pm »
YES! It works. Should I add "solved" to the subject line? After all I would concider it a workaround but problem is solved in practicality.
« Last Edit: February 22, 2015, 03:58:38 pm by MaxPax »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26082
  • Karma: 2842
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: [SOLVED] Minimal problem with scrolling after kernel update
« Reply #8 on: February 22, 2015, 04:53:45 pm »
It's not really a workaround .. it should have been part of your autostart list to  begin with via the "Load Input Setting" autostart item, so if that wasn't working. manually adding it is a "fix" not a "workaround" ;)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline MaxPax

  • nOOb
  • *
  • Posts: 23
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 5 x64
Re: [SOLVED] Minimal problem with scrolling after kernel update
« Reply #9 on: February 22, 2015, 05:06:07 pm »
So maybe call it a "workafix" ??! No just kidding. Thanks for the help! Happy now!

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26082
  • Karma: 2842
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: [SOLVED] Minimal problem with scrolling after kernel update
« Reply #10 on: February 22, 2015, 05:39:20 pm »
Fixaround :)

But if you think about it, ppmc-startup should have been being run at login via autostart but wasn't .. now it is .. that's a "fix" :)
« Last Edit: February 22, 2015, 05:42:42 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec