Author Topic: Lightlocker and auto-logoff issues  (Read 5379 times)

Offline mattosensei

  • Member
  • ***
  • Posts: 222
  • Karma: 28
  • Linux with 'L' plates
    • View Profile
  • Peppermint version(s): 6
Lightlocker and auto-logoff issues
« on: February 21, 2015, 09:50:11 am »
Hi I have a strange thing going on whereby after a period of activity the computer will log me off.

In preferences I have both "enable light locker - OFF"  and "automatically lock screen - NEVER" set, and yet it still seems to happen.

What is doubly odd is that when I enter my PW to log-back in, all my previously running applications have closed down (Transmission, Chromium, etc). Is getting kind of annoying and I can't figure it out.

I do have ScreensaverX (I think that's what it's called) from the repository installed as I really like the Linux screensavers and that works normally. But if I'm away from desk for say 1hr plus, I appear to get logged out   ???. Is baffling me that LightLocker (my least favourite part of the PM environment if I'm honest) keeps running even after I've tried to stop it.

Can any one help? Thanks  :)
« Last Edit: February 24, 2015, 03:42:00 pm by mattosensei »

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4889
  • Karma: 1058
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 10 (64-bit)
Re: Lightlocker and auto-logoff issues
« Reply #1 on: February 21, 2015, 10:00:20 am »
Hi mattosensei, try removing Light Locker completely.  So many people are finding it problematic right across the Ubuntu world.  In a terminal run the following command:
Code: [Select]
apt remove --purge light-lockerSee if that helps  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline rjm65

  • Veteran
  • ****
  • Posts: 1022
  • Karma: 313
  • I have Peppermint Fresh Breath. :P
    • View Profile
  • Peppermint version(s): Win-98 /Win-7/ Peppermint 9
Re: Lightlocker and auto-logoff issues
« Reply #2 on: February 21, 2015, 10:23:26 am »
Andy you need to remove the light locker settings also, or else it still runs after removal...   Ran into this once...  :)
Robert
Peppermint 9 User

Gateway Solo 9300 Pro
IBM T40

Offline mattosensei

  • Member
  • ***
  • Posts: 222
  • Karma: 28
  • Linux with 'L' plates
    • View Profile
  • Peppermint version(s): 6
Re: Lightlocker and auto-logoff issues
« Reply #3 on: February 21, 2015, 10:28:15 am »
Andy you need to remove the light locker settings also, or else it still runs after removal...   Ran into this once...  :)

Hi Andy - thank you, doing that now!  ;D

Hi rjm65 - how do I remove the settings? Sorry, bit of a n00b here   :-[

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Lightlocker and auto-logoff issues
« Reply #4 on: February 21, 2015, 10:30:25 am »
Code: [Select]
sudo apt-get remove --purge light-locker-settings;)

or to purge both with a single command:
Code: [Select]
sudo apt-get remove --purge light-locker light-locker-settings
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline mattosensei

  • Member
  • ***
  • Posts: 222
  • Karma: 28
  • Linux with 'L' plates
    • View Profile
  • Peppermint version(s): 6
Re: Lightlocker and auto-logoff issues
« Reply #5 on: February 21, 2015, 10:37:04 am »
Thank you to AndyInMokum, rjm65 and Mark. Done! Got rid of that prog now and its settings.

Will do same on my other machines running PM also. Happy days are here again (I hope!)  :P

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4889
  • Karma: 1058
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 10 (64-bit)
Re: Lightlocker and auto-logoff issues
« Reply #6 on: February 21, 2015, 01:58:35 pm »
Andy you need to remove the light locker settings also, or else it still runs after removal...   Ran into this once...  :)

Thanks rjm65, that's good to know ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline mattosensei

  • Member
  • ***
  • Posts: 222
  • Karma: 28
  • Linux with 'L' plates
    • View Profile
  • Peppermint version(s): 6
Re: Lightlocker and auto-logoff issues [SOLVED]
« Reply #7 on: February 23, 2015, 03:15:11 pm »
OK have just come back to the computer and it's done it again - Excel doc (which had unsaved information in it!  :o) plus other stuff all closed down and I return to a computer showing me the user log-in screen because I have been away from it for an hour or so.  :'(

No idea why this machine keeps doing this. Could it be because there was a small software update earlier (which I do not believe needed a reboot????)

I don't get it. I followed all of the commands previously given in this post to purge light-locker at the weekend. But this issue is still going on. :-X

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Lightlocker and auto-logoff issues [SOLVED]
« Reply #8 on: February 23, 2015, 03:20:38 pm »
Can you post the output from:
Code: [Select]
cat ~/.config/autostart/screensaver-settings.desktopand
Code: [Select]
xset -q
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline mattosensei

  • Member
  • ***
  • Posts: 222
  • Karma: 28
  • Linux with 'L' plates
    • View Profile
  • Peppermint version(s): 6
Re: Lightlocker and auto-logoff issues [SOLVED]
« Reply #9 on: February 23, 2015, 03:24:45 pm »
Sure:

Code: [Select]
ms@ms-desktop ~ $ cat ~/.config/autostart/screensaver-settings.desktop
[Desktop Entry]
Name=Screensaver
Comment=Set screensaver timeouts
Exec=xset s 600 dpms 600 0 0
ms@ms-desktop ~ $ xset -q
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000000
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    off    02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  500    repeat rate:  33
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  2
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0
Colors:
  default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  /usr/share/fonts/X11/misc,/usr/share/fonts/X11/Type1,built-ins
DPMS (Energy Star):
  Standby: 7200    Suspend: 7200    Off: 14400
  DPMS is Disabled
ms@ms-desktop ~ $

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Lightlocker and auto-logoff issues [SOLVED]
« Reply #10 on: February 23, 2015, 03:33:45 pm »
Run:
Code: [Select]
sudo gedit ~/.config/autostart/screensaver-settings.desktopand make it read:
Code: [Select]
[Desktop Entry]
Name=Screensaver
Comment=Set screensaver timeouts
Exec=xset s 0 0 dpms 0 0 0
SAVE the file and close gedit.

Now log off/on again

then post the output from:
Code: [Select]
xset -qagain
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline mattosensei

  • Member
  • ***
  • Posts: 222
  • Karma: 28
  • Linux with 'L' plates
    • View Profile
  • Peppermint version(s): 6
Re: Lightlocker and auto-logoff issues [SOLVED]
« Reply #11 on: February 23, 2015, 03:38:04 pm »
Done:

Code: [Select]
ms@ms-desktop ~ $ xset -q
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000000
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    off    02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  500    repeat rate:  33
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  2
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0
Colors:
  default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  /usr/share/fonts/X11/misc,/usr/share/fonts/X11/Type1,built-ins
DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Enabled
  Monitor is On
ms@ms-desktop ~ $


Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Lightlocker and auto-logoff issues [SOLVED]
« Reply #12 on: February 23, 2015, 03:41:26 pm »
OK post the output from:
Code: [Select]
dpkg -l | grep light-lockerand
Code: [Select]
dpkg -l | grep screensaver
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline mattosensei

  • Member
  • ***
  • Posts: 222
  • Karma: 28
  • Linux with 'L' plates
    • View Profile
  • Peppermint version(s): 6
Re: Lightlocker and auto-logoff issues [SOLVED]
« Reply #13 on: February 23, 2015, 03:43:08 pm »
Code: [Select]
ms@ms-desktop ~ $ dpkg -l | grep light-locker
ms@ms-desktop ~ $ dpkg -l | grep screensaver
ii  xscreensaver                                                5.15-3ubuntu1                               amd64        Automatic screensaver for X
ii  xscreensaver-data                                           5.15-3ubuntu1                               amd64        data files to be shared among screensaver frontends
ii  xscreensaver-data-extra                                     5.15-3ubuntu1                               amd64        data files to be shared among screensaver frontends
ii  xscreensaver-gl                                             5.15-3ubuntu1                               amd64        GL(Mesa) screen hacks for xscreensaver
ii  xscreensaver-gl-extra                                       5.15-3ubuntu1                               amd64        GL(Mesa) screen hacks for xscreensaver
ii  xscreensaver-screensaver-bsod                               5.15-3ubuntu1                               amd64        BSOD hack from XScreenSaver
ms@ms-desktop ~ $ ^C
ms@ms-desktop ~ $


Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Lightlocker and auto-logoff issues [SOLVED]
« Reply #14 on: February 23, 2015, 03:49:18 pm »
Hmmm...

When it goes to blank then requires you to log back in .. is the login screen very basic with a flame symbol ?

[EDIT]

What happens if yo run:
xscreensaver-demo
?

Do you get a warning about the daemon not running ?

What are the setttings for
Mode: ?
Blank After: ?
Cycle After: ?

is "Lock screen after" ticked ? .. and what is its setting
« Last Edit: February 23, 2015, 03:54:54 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec