Choose style:

Author Topic: Shared files Network - Blank  (Read 4248 times)

0 Members and 1 Guest are viewing this topic.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26290
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Shared files Network - Blank
« Reply #15 on: February 19, 2015, 06:20:58 pm »
Can you try this...

Set the workgroup on a Windows PC to the same as your routers SSID

Set the workgroup in Peppermint (in /etc/smaba/smb.conf) to the same as the routers SSID

reboot everything (windows PC, router, and Peppermint PC)

Now can the Peppermint PC's shares be accessed when it's on wireless ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline nOObbutReady

  • nOOb
  • *
  • Posts: 19
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Pep 5
Re: Shared files Network - Blank
« Reply #16 on: February 20, 2015, 08:37:28 pm »
Nope. Can't get past step one there as Windows won't allow the Internet connection to be named the same thing as the workgroup.

"the following error occurred validating the name "{SSID of my network}",

You were not connected because a duplicate name exists on the network. If joining a domain, go to System in control Panel to change the computer name and try again. If joining a workgroup, choose another workgroup name"

Plus, that move would also tank out the DNLA box  and both NAS boxes on my network that cannot be set to anything but the default WORKGROUP, something I already have experience with as that was not my original workgroup name either.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26290
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Shared files Network - Blank
« Reply #17 on: February 20, 2015, 09:02:45 pm »
Quote
Nope. Can't get past step one there as Windows won't allow the Internet connection to be named the same thing as the workgroup.

That doesn't make sense .. I said to change the workgroup name to the same as the routers SSID, I *know* that can be done as that's my setup (including the missus Win7 PC)

OK, instead try changing the routers SSID to WORKGROUP .. then reboot everything

I only want to do this as a test, you can alwaays change it back later if you want.

Sommat mighty odd about your NAS if it won't let you change the workgroup  :-\



Have you (in Windows) gone to
Control Panel > Network and Sharing Center > Change advanced settings
and ticked
Turn ON network discovery
Turn ON file and printer sharing
Turn ON sharing so anyone with network access can read and wrie files in the Public folders
Use 128-bit encryption blah, blah, blah
Turn OFF password protected sharing
Allow Windows to manage homegroups, blah, blah, blah
« Last Edit: February 20, 2015, 09:04:29 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline nOObbutReady

  • nOOb
  • *
  • Posts: 19
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Pep 5
Re: Shared files Network - Blank
« Reply #18 on: February 23, 2015, 03:30:07 pm »
changed the router SSID to Workgroup. It didn't change anything in terms of the problem seeing the machines, but did create some nice long lag for the win machines seeing the local network. It also wouldn't do it from the LAN, had to disconnect everything and run a single cable to a laptop to make that accept the Workgroup SSID.

Windows threw the error on the other method..what can I say?

It's not odd at all for the NAS boxes to not be able to be changed. The Seagate Centrals, like the WD LIVE storage systems are extremely stripped, clunky systems, but small, independent, cheap with a TON of storage..and that's the tradeoff. Once they are visible and you don't try to make them do anything beyond their primary purpose, they work well...locally.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26290
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Shared files Network - Blank
« Reply #19 on: February 23, 2015, 03:48:07 pm »
Are the Windows PC's set as above (in the Network and Sharing Center) ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline nOObbutReady

  • nOOb
  • *
  • Posts: 19
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Pep 5
Re: Shared files Network - Blank
« Reply #20 on: February 23, 2015, 04:13:56 pm »
yes, they are. They wouldn't work with the Mac in any other configuration. Additionally, Homegroups are disabled.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26290
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Shared files Network - Blank
« Reply #21 on: February 23, 2015, 05:10:51 pm »
Try this on the Windows PC's....

Go to to User Accounts and enable the Guest account

Now go to a folder you're sharing and right click it, then select Properties > Security and make sure the "Guest" account is included.

Now see if the Peppermint PC is still prompted for credentials for the Windows share.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline nOObbutReady

  • nOOb
  • *
  • Posts: 19
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Pep 5
Re: Shared files Network - Blank
« Reply #22 on: February 23, 2015, 08:41:47 pm »
The guest account is not included under security settings after enabling and a restart.

It does make the machine startup much slower, so that's fun.

The peppermint box behaves the same way as before. Have to navigate to a specific address and then prompted for password signin with each folder open.