Choose style:

Author Topic: [SOLVED]Random video blackouts[SOLVED]  (Read 2631 times)

0 Members and 1 Guest are viewing this topic.

Offline robertsala

  • Jr. Member
  • **
  • Posts: 85
  • Karma: 8
  • New Forum User
    • View Profile
[SOLVED]Random video blackouts[SOLVED]
« on: January 24, 2015, 10:39:51 am »
Hi guys!

I've been experiencing few random video blackouts with my HP Pavillion dv2000 and a Dell Mini Inspirion 1012 of a friend of mine. Her mini Dell Inspirion experiences this event more than my HP laptop. So here's the scenario, when using the laptop, unexpectedly the monitor blacks-out but the laptop is still powered. Both laptops have been checked for video chips overheating and they are in the normal range. Both laptops have been opened and the video chips don't need a reflow process. I'm suspecting it is more of a software driver issue than the hardware itself. However, I'm posting this in the hardware topic. Any help is appreciated :)

UPDATE
It's been several weeks and I haven't seen my laptop blackout. If it should, chances are it would be a hardware issue since the HP DV2000 is infamous for overheating. 
« Last Edit: February 26, 2015, 07:07:37 am by robertsala »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26290
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Random video blackouts
« Reply #1 on: January 24, 2015, 11:47:25 am »
Are you sure this isn't screen blanking due to the power manager ?

What are you doing when blanking occurs ?
ie. (is this Chrome/Chromium related ?)

What's the output from:
Code: [Select]
xset -q
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline robertsala

  • Jr. Member
  • **
  • Posts: 85
  • Karma: 8
  • New Forum User
    • View Profile
Re: Random video blackouts
« Reply #2 on: January 24, 2015, 12:08:56 pm »
Standby: 0, Suspend: 0, Off: 0, DPMS is Enabled, Monitor is On

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26290
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Random video blackouts
« Reply #3 on: January 24, 2015, 12:44:36 pm »
I was kinda hoping for the FULL output (not just DPMS), so I cold also see the screensaver settings too

And how about my other question(s) .. could this be Chrome/Chromium related ? .. what are you doing when the blanking occurs  ?
« Last Edit: January 24, 2015, 12:47:31 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline robertsala

  • Jr. Member
  • **
  • Posts: 85
  • Karma: 8
  • New Forum User
    • View Profile
[SOLVED]Re: Random video blackouts[SOLVED]
« Reply #4 on: January 25, 2015, 10:09:03 am »
The screensaver is disabled, its OFF. I believe its not Google Chrome since this has happened without launching a browser. I can be working on a document and then it blanks out.
« Last Edit: February 26, 2015, 07:09:13 am by robertsala »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26290
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Random video blackouts
« Reply #5 on: January 25, 2015, 10:40:56 am »
Can you please post the output from:
Code: [Select]
xset -q

You can copy/paste from the terminal.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline robertsala

  • Jr. Member
  • **
  • Posts: 85
  • Karma: 8
  • New Forum User
    • View Profile
[SOLVED]Re: Random video blackouts[SOLVED]
« Reply #6 on: January 27, 2015, 07:13:57 am »
Full output
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000000
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    off    02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  500    repeat rate:  20
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  2
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  600
Colors:
  default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  /usr/share/fonts/X11/misc,/usr/share/fonts/X11/Type1,built-ins
DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Enabled
  Monitor is On
« Last Edit: February 26, 2015, 07:09:40 am by robertsala »

Offline robertsala

  • Jr. Member
  • **
  • Posts: 85
  • Karma: 8
  • New Forum User
    • View Profile
[SOLVED]Re: Random video blackouts[SOLVED]
« Reply #7 on: January 27, 2015, 07:24:03 am »
I entered at the terminal the following commands:

xset s off
xset -dpms

DPMS is Disabled is now disabled.

But the Screen Saver:
 prefer blanking:  yes    allow exposures:  yes
still says "yes"
« Last Edit: February 26, 2015, 07:10:07 am by robertsala »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26290
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Random video blackouts
« Reply #8 on: January 27, 2015, 07:44:51 am »
Can you post the output from:
Code: [Select]
gedit ~/.config/autostart/screensaver-settings.desktop
and
Code: [Select]
gedit ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfcce4-power-manager.xml
and the output from:
Code: [Select]
dpkg -l | grep light-locker
and
Code: [Select]
dpkg -l | grep xscreensaver
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline robertsala

  • Jr. Member
  • **
  • Posts: 85
  • Karma: 8
  • New Forum User
    • View Profile
[SOLVED]Re: Random video blackouts[SOLVED]
« Reply #9 on: January 28, 2015, 08:29:51 am »
gedit ~/.config/autostart/screensaver-settings.desktop
[Desktop Entry]
Name=Screensaver
Comment=Set screensaver timeouts
Exec=xset s 0 dpms 0 0 0

gedit ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfcce4-power-manager.xml
Completely blank....

dpkg -l | grep light-locker
ii  light-locker                               1.4.0-0ubuntu1                           i386         simple session-locker for lightdm
ii  light-locker-settings                      1.2.1-0ubuntu1.1                         all          simple configuration tool for light-locker

dpkg -l | grep xscreensaver
Nothing happenned....
« Last Edit: February 26, 2015, 07:10:40 am by robertsala »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26290
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Random video blackouts
« Reply #10 on: January 28, 2015, 09:10:26 am »
Sorry typo .. what's the contents of:
Code: [Select]
gedit ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-power-manager.xml

And have you set all sliders in lightlocker-settings to the left, and turned OFF lightlocker
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1013
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Random video blackouts
« Reply #11 on: January 28, 2015, 09:33:09 am »
Hi robertsala, I had a problem with the screen blanking out every 10 mins.  It was driving me nuts too  >:(.  I found that this edit to the: ~/.profile file stopped the blanking.  Open it with:
Code: [Select]
gedit ~/.profile
Add the lines highlighted in red.
Quote
# ~/.profile: executed by the command interpreter for login shells.
# This file is not read by bash(1), if ~/.bash_profile or ~/.bash_login
# exists.
# see /usr/share/doc/bash/examples/startup-files for examples.
# the files are located in the bash-doc package.

# the default umask is set in /etc/profile; for setting the umask
# for ssh logins, install and configure the libpam-umask package.
#umask 022

#To stop screen blanking after 10 minutes and disable dpms
xset s 0 0 dpms 0 0 0


# if running bash
if [ -n "$BASH_VERSION" ]; then
    # include .bashrc if it exists
    if [ -f "$HOME/.bashrc" ]; then
   . "$HOME/.bashrc"
    fi
fi

# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/bin" ] ; then
    PATH="$HOME/bin:$PATH"
fi
Save the file and logout and back in.  It worked for me, I hope it helps  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline robertsala

  • Jr. Member
  • **
  • Posts: 85
  • Karma: 8
  • New Forum User
    • View Profile
Re: Random video blackouts
« Reply #12 on: January 28, 2015, 10:58:37 am »
gedit ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-power-manager.xml
RESULTS:
<?xml version="1.0" encoding="UTF-8"?>

<channel name="xfce4-power-manager" version="1.0">
  <property name="xfce4-power-manager" type="empty">
    <property name="power-button-action" type="empty"/>
    <property name="dpms-on-battery-sleep" type="uint" value="0"/>
    <property name="dpms-on-ac-off" type="uint" value="0"/>
    <property name="lock-screen-suspend-hibernate" type="bool" value="false"/>
    <property name="dpms-enabled" type="bool" value="true"/>
    <property name="dpms-on-battery-off" type="uint" value="0"/>
    <property name="dpms-on-ac-sleep" type="uint" value="0"/>
    <property name="brightness-on-battery" type="uint" value="9"/>
    <property name="logind-handle-lid-switch" type="bool" value="true"/>
  </property>
</channel>

Offline robertsala

  • Jr. Member
  • **
  • Posts: 85
  • Karma: 8
  • New Forum User
    • View Profile
Re: Random video blackouts
« Reply #13 on: January 28, 2015, 11:01:15 am »
Yes, all sliders in lightlocker-settings are to the left, and turned OFF lightlocker.

Offline robertsala

  • Jr. Member
  • **
  • Posts: 85
  • Karma: 8
  • New Forum User
    • View Profile
Re: Random video blackouts
« Reply #14 on: January 28, 2015, 11:06:12 am »
Hi AndyInMokum, I'll give it a try.... Will report back after using it during the week.