Author Topic: Audio not working in Virtual Box [Solved]  (Read 1227 times)

Offline mobibike

  • Newly Subscribed
  • *
  • Posts: 9
  • Karma: 3
  • New Forum User
    • View Profile
  • Peppermint version(s): peppermint5 64bit
Audio not working in Virtual Box [Solved]
« on: January 21, 2015, 09:11:47 pm »
I have been running 1 program inside of WinXP using Virtual Box. It uses audio and has been working great since I installed Peppermint 5. Now today after installing the last batch of Peppermint updates, Audio in Virtual Box (win xp) no longer works, but audio does still work in the regular desktop environment such as Guayadeque and youtube and so on.

Any ideas what might have happened?
« Last Edit: January 22, 2015, 09:38:38 am by mobibike »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Audio not working in Virtual Box
« Reply #1 on: January 22, 2015, 02:55:08 am »
Have you tried running:
Code: [Select]
sudo /etc/init.d/vboxdrv setupto rebuild the kernel modules ?

Or reinstalling virtualbox ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline mobibike

  • Newly Subscribed
  • *
  • Posts: 9
  • Karma: 3
  • New Forum User
    • View Profile
  • Peppermint version(s): peppermint5 64bit
Re: Audio not working in Virtual Box [Solved]
« Reply #2 on: January 22, 2015, 09:46:48 am »
Thank you for the great suggestion! I managed to use the settings for the VM (xp in my case) in Virtual Box with the "machine" turned off, and changed the Host Audio Driver from PulseAudio to Null Audio Driver and start the machine. That didn't work, but when I changed the Host Audio Driver back to PulseAudio after turning off the machine, and starting it again... audio in the VM now works again.  :)

Your 1st way would have probably worked easier and faster, so If it happens again I'll try that first next time and post how it goes.
Thank you again for your excellent help!!