Author Topic: quickcam messenger  (Read 2207 times)

Offline willy

  • Newly Subscribed
  • *
  • Posts: 8
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 5
quickcam messenger
« on: December 28, 2014, 08:08:41 am »
Hello,
I just installed peppermint 5. I would like to use my old webcam (logitech quickcam messenger), but it is not recognised so I cannot use it in skype.
I have downloaded the qc-usb-0.6.6 package and tried to make the "executable" with 'make all' without success (complains that it cannot read "/lib/modules/3.13.0-29-generic/build/include/linux/version.h"). Can anyone help me tp deal with this problem and get this webcam installed?
Thanks

[EDITED]
The camera is recognized by Cheese so it seems that I do not need to instal its drivers... any ideas on how to fix the problem with skype?
again thanks!
« Last Edit: December 28, 2014, 11:28:27 am by willy »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: quickcam messenger
« Reply #1 on: December 28, 2014, 11:52:37 am »
Check if this command starts Skype and it recognises your webcam .. if it does, we'll change the launcher to reflect the command

If you're running 32bit Peppermint:
Code: [Select]
LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skypeif you're running 64bit Peppermint:
Code: [Select]
LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libv4l/v4l1compat.so skypedid either of those cause Skype to start and your webcam to be recognised ?

Remember Linux commands ARE case sensitive, so enter it exactly as shown .. in fact best to copy/paste the command into the terminal ;)
« Last Edit: December 28, 2014, 11:55:50 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline willy

  • Newly Subscribed
  • *
  • Posts: 8
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 5
Re: quickcam messenger
« Reply #2 on: December 29, 2014, 12:10:16 am »
Thanks!

That helped a lot. :-)
I complemented your command ("LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so") with "/usr/bin/skype" and saved it as skype.sh
After that I edited the skype shortcut to  "sh skype.sh". that solved the problem....I can now do video conferences using skype.
However, the videos are flashing/blinking blue...what could be the problem now?

again thanks
PS:  I only edited the shortcut in the desktop...is it also possible to edit the link from the menu bar?


 

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: quickcam messenger
« Reply #3 on: December 29, 2014, 01:49:27 am »
Where did you get Skype ?

Did you download it or get it through your package manager(s) ?

[EDIT]

Can you please read this bug report:
https://bugs.launchpad.net/ubuntu/+source/skype/+bug/1078068
and confirm if the last entry (workaround) works .. the one where the guy says covering the picture in picture with another window stops the blue flashing.
« Last Edit: December 29, 2014, 01:59:12 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline willy

  • Newly Subscribed
  • *
  • Posts: 8
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 5
Re: quickcam messenger
« Reply #4 on: December 29, 2014, 02:59:38 am »
hi,

I downloaded skype from the official skype site. I have version 4.3 for ubuntu (so it was a .deb file).

I have tried the workaround (window over window) but the skype video window is always on top / active (I cannot cover it with another windo) so the flashing in blue remains ....  :'(

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: quickcam messenger
« Reply #5 on: December 29, 2014, 05:21:37 am »
a) stop downloading things from the web .. that's a bad Windows habit you'll need to break (and should only be done as a last resort) ;) .. skype is available in your package manager(s) if you enable the "Canonical Partners" and "Independent" repositories.

b) is there anything in the skype options/settings that allows you to disable "always on top" ?
« Last Edit: December 29, 2014, 05:26:23 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4889
  • Karma: 1058
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 10 (64-bit)
Re: quickcam messenger
« Reply #6 on: December 29, 2014, 08:00:50 am »
Hi Willie, how's it going.  If I remember correctly, the "Official Download" from Skype is really buggy.  You really need to remove it and install the one from the, Canonical Partners repository.  First lets remove the one you have installed.  I am assuming you downloaded the Skype Deb to your Downloads folder.  Open a terminal window with the following keystrokes, Ctrl+Alt+t.  Enter the following commands in sequence; entering your user password when asked.

Tip:  Linux is case sensitive.  To reduce the possibility of typographical errors, please use the Code: [Select] function below to highlight the contents. Click on the centre mouse button/wheel while in the terminal window to paste the contents.

Note: For enhanced security, passwords are entered invisibly.  There is NO indication of any user input.  You may enter an incorrect password 3 times before you have to repeat the action you are trying to apply.

Code: [Select]
cd ~/DownloadsHit enter.
Code: [Select]
sudo dpkg -r skype*Hit enter.  We shall remove to the Skype configuration folder with the following command.
Code: [Select]
cd ~/.config && sudo rm -rv SkypeHit enter.  Now clean up the Deb file.
Code: [Select]
cd ~/Downloads && rm -v skype*Hit enter.  That is the old Skype removed.

To enable the, Canonical Partners repository and download Skype.  Navigate to menu>Preferences>Software & Updates.  After the window opens, select Other Software and check/tick the Canonical Partners box. You will be asked for your user password when you close the window.  It will update the cache.  You will now be able to download Skype from the terminal
Code: [Select]
apt update && apt install skype -yHit enter and do the password thing if asked.  That should clear up your problem  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline willy

  • Newly Subscribed
  • *
  • Posts: 8
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 5
Re: quickcam messenger
« Reply #7 on: December 29, 2014, 12:54:14 pm »
@PCNetSpec

a) OK. Understood.
b) I could not find any option to remove the "always on top"

@AndyinMokum

Thanks for your tips. Indeed, skype was in the downloads folder. however I already deleted it (another bad windows habit?)
I went to the /usr/bin folder and did:
sudo dpkg -r skype*
and then
cd ~./.config && sudo rm -rv skype (notice the lowercase S)
that removed skype
then i used
apt update && apt install skype -y
to get it back from the official repository
this installed skype but not in usr/bin....
the shortcut in menu and in my desktop do not work and i cannot find skype anymore...
i went to the software manager, which says that skype is installed but there is no button to lauch it...

Thanks

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: quickcam messenger
« Reply #8 on: December 29, 2014, 01:28:36 pm »
Try running:
Code: [Select]
sudo apt-get remove --purge skypethen
Code: [Select]
sudo apt-get remove --purge skype-bin(don't worry if that last command fails, just carry on below)
then
Code: [Select]
sudo apt-get install --reinstall skype skype-binnow post the output from:
Code: [Select]
dpkg -l | grep skype
hr]

See if one of these stops Skype from always being on top during a call

Tools > Options > Call settings > Show advanced options ..  and deselect “Show call controls when Skype is in the background”.
or deselect "Show current calls when Skype is in the background"
« Last Edit: December 29, 2014, 01:58:15 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec