Choose style:

Author Topic: Nvidia graphic card not working  (Read 4261 times)

0 Members and 1 Guest are viewing this topic.

Offline drumanart

  • Newly Subscribed
  • *
  • Posts: 23
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint Five
Nvidia graphic card not working
« on: January 09, 2015, 05:04:07 am »
Hello.
I have a fresh installed peppermint version 5.

lsb_release -a
Distributor ID:   Peppermint
Description:   Peppermint Five
Release:   5
Codename:   trusty
drumanart@drumanart-Syst

I installed the driver for my NVIDIA Corporation G98  (GeForce 8400)

lspci -vnn | grep -i VGA -A 12
02:00.0 VGA compatible controller [0300]: NVIDIA Corporation G98 [GeForce 8400 GS Rev. 2] [10de:06e4] (rev a1) (prog-if 00 [VGA controller])
   Flags: fast devsel, IRQ 17
   [virtual] Memory at df000000 (32-bit, non-prefetchable) [size=16M]
   Memory at c0000000 (64-bit, prefetchable) [size=256M]
   Memory at dc000000 (64-bit, non-prefetchable) [size=32M]
   I/O ports at ec00 [size=128]
   [virtual] Expansion ROM at defe0000 [disabled] [size=128K]
   Capabilities: <access denied>

The card want work.

thanks Martin


Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Nvidia graphic card not working
« Reply #1 on: January 09, 2015, 06:07:12 am »
What do you mean by the card "won't work" ?

Do you mean it'll work with the nouveau driver,but not with the proprietary nvidia driver ?

What exactly happens when you switch to the nvidia driver .. black screen at boot ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline drumanart

  • Newly Subscribed
  • *
  • Posts: 23
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint Five
Re: Nvidia graphic card not working
« Reply #2 on: January 09, 2015, 08:00:14 am »
Actually I'm not sure weather the nouveau driver is active or the nvidia. If I start the computer I have a very bad resolution (640 *480).
This is so since I installed the nvidia driver.

Thanks Martin

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Nvidia graphic card not working
« Reply #3 on: January 09, 2015, 06:37:29 pm »
Can you open a terminal and post the output from:
Code: [Select]
sudo lshw -C display
and
Code: [Select]
dpkg -l | grep nvidia
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline drumanart

  • Newly Subscribed
  • *
  • Posts: 23
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint Five
Re: Nvidia graphic card not working
« Reply #4 on: January 11, 2015, 01:59:20 pm »
sudo lshw -C display

[sudo] password for drumanart:
  *-display UNCLAIMED     
       description: VGA compatible controller
       product: G98 [GeForce 8400 GS Rev. 2]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller cap_list
       configuration: latency=0
       resources: memory:df000000-dfffffff memory:c0000000-cfffffff memory:dc000000-ddffffff ioport:ec00(size=128) memory:defe0000-deffffff
  *-display
       description: VGA compatible controller
       product: C68 [GeForce 7025 / nForce 630a]
       vendor: NVIDIA Corporation
       physical id: 12
       bus info: pci@0000:00:12.0
       version: a2
       width: 64 bits
       clock: 66MHz
       capabilities: pm msi vga_controller bus_master cap_list rom
       configuration: driver=nouveau latency=0
       resources: irq:47 memory:da000000-daffffff memory:b0000000-bfffffff memory:d9000000-d9ffffff memory:dbec0000-dbedffff

dpkg -l | grep nvidia
rc  nvidia-340                            340.65-0ubuntu1~xedgers14.04.1        amd64        NVIDIA binary driver - version 340.65
rc  nvidia-opencl-icd-340                 340.65-0ubuntu1~xedgers14.04.1        amd64        NVIDIA OpenCL ICD
ii  nvidia-prime                          0.6.2                                 amd64        Tools to enable NVIDIA's Prime
ii  nvidia-settings                       346.22-0ubuntu1~xedgers14.04.1        amd64        Tool for configuring the NVIDIA graphics driver

Thanks Martin


Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Nvidia graphic card not working
« Reply #5 on: January 12, 2015, 04:20:55 pm »
OK, you're currently running the nouveau driver .. but I'm going to guess the configuration changes are still present.

For some reason you also have nvidia-prime installed which is for hybrid adapters .. any idea why ?
You can uninstall it with:
Code: [Select]
sudo apt-get remove --purge nvidia-prime
You also appear o have 2 nvidia adapters installed .. any particular reason for this ?

If you go to
menu > Preferences > Additional Drivers
what is being offered ffor installation ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline drumanart

  • Newly Subscribed
  • *
  • Posts: 23
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint Five
Re: Nvidia graphic card not working
« Reply #6 on: January 13, 2015, 03:04:07 pm »
Additional Drivers:
NVIDIA Corporation:G98[GeForce8400 GS Rev.2]

Marked is:
Using NVIDIA binary driver-version 340.65 from nvidia-340(open-sourse)

I get a registry error:
sudo nvidia-settings
** Message: PRIME: No offloading required. Abort
** Message: PRIME: is it supported? no

ERROR: nvidia-settings could not find the registry key file. This file should
       have been installed along with this driver at
       /usr/share/nvidia/nvidia-application-profiles-key-documentation. The
       application profiles will continue to work, but values cannot be
       preopulated or validated, and will not be listed in the help text.
       Please see the README for possible values and descriptions.


the output of:
sudo ubuntu-drivers devices
== /sys/devices/pci0000:00/0000:00:0b.0/0000:02:00.0 ==
vendor   : NVIDIA Corporation
model    : G98 [GeForce 8400 GS Rev. 2]
modalias : pci:v000010DEd000006E4sv00000000sd00000000bc03sc00i00
driver   : xserver-xorg-video-nouveau - distro free builtin
driver   : nvidia-173 - distro non-free
driver   : nvidia-331 - third-party free
driver   : nvidia-331-updates - distro non-free
driver   : nvidia-304 - third-party free
driver   : nvidia-340 - third-party free recommended
driver   : nvidia-304-updates - distro non-free

My PC has an onboard graphic card and  I installed the Nvidia GeForce8400 after installing the fresh OS.

Thanks Martin


Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Nvidia graphic card not working
« Reply #7 on: January 13, 2015, 03:11:02 pm »
What is being listed by additional drivers as options ?

WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline drumanart

  • Newly Subscribed
  • *
  • Posts: 23
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint Five
Re: Nvidia graphic card not working
« Reply #8 on: January 13, 2015, 04:31:01 pm »
All entries:

NVIDIA Corporation:G98[GeForce8400 GS Rev.2]

Using X.Org X server -- Nouveau display driver from xserver-xorg-video-nouveau (open-sourse)
Using NVIDIA binary driver-version 331.113 from nvidia-331 (open-sourse)
Using NVIDIA binary driver-version 340.65 from nvidia-340 (open-sourse)
Using NVIDIA binary driver-version 331.113 from nvidia-331-updates (proprietary)

Thanks Martin

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Nvidia graphic card not working
« Reply #9 on: January 13, 2015, 04:47:56 pm »
if I were you I'd switch back to the nouveau driver.

Once you've switched, REBOOT

Then check it's still using nouveau .. then run:
Code: [Select]
sudo apt-get remove --purge nvidia*

Once that's done you can try switching back to the 340 driver from 'updates'
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline drumanart

  • Newly Subscribed
  • *
  • Posts: 23
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint Five
Re: Nvidia graphic card not working
« Reply #10 on: January 13, 2015, 05:38:18 pm »
updates:
recommanded updates?


Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Nvidia graphic card not working
« Reply #11 on: January 13, 2015, 06:25:55 pm »
Additional drivers should now hopefully have something like

Using NVIDIA binary driver-version 340.65 from nvidia-340-updates (proprietary)

Choose that one.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline drumanart

  • Newly Subscribed
  • *
  • Posts: 23
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint Five
Re: Nvidia graphic card not working
« Reply #12 on: January 14, 2015, 12:36:29 pm »
No the nvidia-340 has no update option.

Only this drivers have the update option set

Using NVIDIA legacy binary driver-version 304.125 from nvidia-304updates (proprietary)
Using NVIDIA binary driver-version 331.113 from nvidia-331-updates (proprietary)

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Nvidia graphic card not working
« Reply #13 on: January 14, 2015, 01:07:13 pm »
Take your pick from either of these then:

Using NVIDIA binary driver-version 340.65 from nvidia-340 (open-sourse)
Using NVIDIA binary driver-version 331.113 from nvidia-331-updates (proprietary)

They're both supposed to support the 8400GS
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline drumanart

  • Newly Subscribed
  • *
  • Posts: 23
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint Five
Re: Nvidia graphic card not working
« Reply #14 on: January 14, 2015, 02:57:11 pm »
Now it works.

I have to use the NVIDIA legacy binary driver-version 173.14.39 from nvidia-173 (proprietary)

Thanks a lot
Martin