Choose style:

Author Topic: need help with setting up anon ftp server  (Read 861 times)

0 Members and 1 Guest are viewing this topic.

Offline kevinbanjo

  • Jr. Member
  • **
  • Posts: 62
  • Karma: 0
  • New Forum User
    • View Profile
need help with setting up anon ftp server
« on: December 26, 2014, 11:24:19 am »
Hi, I installed proftpd and it asked me if I wanted stand alone or inetd.   I chose inetd because the machine I'm running it on is very ram constricted.   When it was done, there was no inetd running.   Seeing that xinetd was a more advanced version of it, I installed that.  Then under /etc/xinetd.d there was nothing that contained ftp at all, so I created the 'ftp' file with this in it:

service ftp
{
      disable = no
      flags                     = REUSE
      socket_type             = stream
      wait                    = no
      user                    = root
      server                  = /usr/sbin/proftpd
      server_args             = -c /etc/proftpd/proftpd.conf
}


Now when I go to the server's ftp://<ip> site it says website not available then after a while pops up a log in prompt for which no combo of user/password seems to work.

I just want to set up an anon server so I can share files with friends without having to upload them somewhere first (like google drive).

Can anyone help?   Why isn't this easy?   It seems I did this with other distros and it just "worked."

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25725
  • Karma: 2822
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: need help with setting up anon ftp server
« Reply #1 on: December 27, 2014, 08:27:09 am »
I'm going to *guess* that proftpd is set to use the "root" account ? .. this doesn't exist in Ubuntu based distros (or rather it's password is encrypted, so not valid)

Can you post the contents of:
Code: [Select]
gedit /etc/proftpd/proftpd.conf
using ***** for anything you don't want public
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec