Choose style:

Author Topic: Privoxy and Chromium  (Read 3897 times)

0 Members and 1 Guest are viewing this topic.

Offline Grem41

  • Newly Subscribed
  • *
  • Posts: 21
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 3
Privoxy and Chromium
« on: December 24, 2014, 02:56:22 pm »
Hope someone can help.

I'm looking to improve my browsing experience by blocking the annoying adverts that load automatically and some start as I mistakenly roll over them.

I choose privoxy for system wide functionality so that whatever browser I might use in the future would just need to change the  proxy browser setting.  Currently use  Chromium version 30.0.1599 on Peppermint 3

My idea was to block these adverts by inserting privoxy (on this laptop) to connect to my router so it would filter the adverts

So far I am attempting to following link

http://www.privoxy.org/user-manual/startup.html that tells  to set the proxy manually to 127.0.0.1:Port 8118 of my laptop which works O.K and I can restart privoxy from the command line

My problem is I believe I need to change the proxy settings that Chromium uses to that IP address and port ie 127.0.0.1:8118 on my laptop, how do I use on this version ?

When I attempt to do a message as follows

When running Chromium under a supported desktop environment, the system proxy settings will be used. However, either your system is not supported or there was a problem while launching your system configuration.
But you can still configure via the command line. Please see man chromium-browser for more information on flags and environment variables.

Thanks and Happy Xmas

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Privoxy and Chromium
« Reply #1 on: December 24, 2014, 05:17:57 pm »
Does it work if you open a terminal (Ctrl+Alt+T), then start Chromium from the command line with:
Code: [Select]
chromium-browser --proxy-server=127.0.0.1:8118
if that works as expected I'll tell you how to apply that permanently
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Grem41

  • Newly Subscribed
  • *
  • Posts: 21
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 3
Re: Privoxy and Chromium
« Reply #2 on: December 28, 2014, 06:18:24 am »
I can confirm am able to start Chromium from the command using the you gave

ie  chromium-browser --proxy-server=127.0.0.1:8118
This gives a message "Created new window in existing browser session."

However there appears no difference in a site appearance (ie pesky ads) between

1.  Having Chromium run normally
2. Restarting Privoxy and running start Chromium from the command line as advised thereby pointing to the proxy server 127.0.0.1 port 8118
« Last Edit: December 28, 2014, 06:35:14 am by Grem41 »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Privoxy and Chromium
« Reply #3 on: December 28, 2014, 08:25:42 am »
Quote
This gives a message "Created new window in existing browser session."

That suggests you already had a chromium instance open when you started chromium from the command line .. try it with ALL chromium instances closed.

Quote
However there appears no difference in a site appearance (ie pesky ads) between

Suggests the proxy is working (or you'd get "unable to connect" in chromium), anything beyond that is most likely a privoxy config issue .. this:
http://ubuntuforums.org/showthread.php?t=1715115
suggests you have to add your own block rules
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec