Choose style:

Author Topic: problem with LVM / LUKS encrypted installation  (Read 1276 times)

0 Members and 1 Guest are viewing this topic.

Offline Karl

  • nOOb
  • *
  • Posts: 1
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 5
problem with LVM / LUKS encrypted installation
« on: December 18, 2014, 08:40:38 am »
Pepermint 5, 32bit on netbook Intel Classmate  (2GB RAM, N270 processor, 16GB SSD)


Hi there.
I am trying out Peppermint now for a couple of days and as far as I can see it works really good.

There is one exception:
I installed with LVM encryption to have my data protected.
But when the computer awakes from STANDBY mode, it does not ask for the password phrase.
For people needing encryption this is an important mistake.

Does somebody know a solution or workaround?

I am from Germany, so I apologize for making mistakes in spelling and grammar.

Sincerely
Karl
« Last Edit: December 18, 2014, 08:44:46 am by Karl »

Offline cavy

  • Trusted User
  • Member
  • *****
  • Posts: 420
  • Karma: 55
  • Caveman
    • View Profile
    • PeppermentOS Pixies
  • Peppermint version(s): Peppermint Eight
Re: problem with LVM / LUKS encrypted installation
« Reply #1 on: December 30, 2014, 01:55:05 pm »
Hi Karl, the encryption password is only required during the initial boot up process, like unlocking your front door.

Once you are using your computer, to open certain system tools/apps you have to use your USER password. Coming out of standby mode..? Suggests your computer has gone into sleep mode, showing a black screen controlled by the LIGHT LOCKER.

Go to Menu > Preferences > Light Locker Settings and enable it lock screen, so you have to enter USER password to re-open your last session. Also you can control the lenght of time before your computer goes into sleep mode.

Menu = Menü or Speisekarte (Google translate)

Preferences = Einstellungen

Light Locker Settings = Licht Umkleide Einstellungen.

If you would prefer a more traditional screen saver you could use guide http://forum.peppermintos.com/index.php/topic,1009.msg8722.html#msg8722
“We know what we are, but not what we may be.”

Desktop Dell 7040 i7-6700 500Gb-SSD 32Gb ram
Laptop    Dell 7470 i5-6300 500Gb-SSD  16Gb ram
Various antiques to sample other OS's etc

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1013
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: problem with LVM / LUKS encrypted installation
« Reply #2 on: December 31, 2014, 02:45:12 pm »
Hi karl, I have the same problem with the suspend function.  The screen doesn't lock if I suspend my computer using the panel icon.  If I use the suspend option from the logout screen, the screen lock is activated.  I guess it is a bug.  Hopefully someone at Ubuntu will fix it.  Good luck - there's nothing wrong with your English  ;).   Happy New Year!!
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.