Choose style:

Author Topic: Cannot Save Keyboard Layout Settings (SOLVED)  (Read 1191 times)

0 Members and 1 Guest are viewing this topic.

Offline TerryWood

  • nOOb
  • *
  • Posts: 2
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 5-20140623
Cannot Save Keyboard Layout Settings (SOLVED)
« on: December 09, 2014, 02:56:26 pm »
Hi All

New user of version 5-20140623.

Have installed 32bit version to flash drive with persistence.

Have setup system to use gb English and UK keyboard layout.

When I reboot the keyboard layout settings revert US layout. At first I thought this was to do with persistence not saving the chosen options.

However I have reset many system options, installed new software and removed unwanted software. All of which has been successfully saved on reboot.

On trying to find a solution, I note that in the past there seems to have been past problems with ubuntu based OSs in saving keyboard settings. Some, but not many,  seem to have resolved the issue, yet following in their footsteps, I cannot retain the UK system settings.

Can anyone help me please?

NOTE as far as linux is concerned I am definitely a newbie!

Thank you for your help

Terry

« Last Edit: December 10, 2014, 09:00:20 pm by PCNetSpec, Reason: Marked as (SOLVED) »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26082
  • Karma: 2842
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Cannot Save Keyboard Layout Settings
« Reply #1 on: December 09, 2014, 03:26:13 pm »
Hi Terry and welcome to the forum :)

Open a terminal (Ctrl+Alt+T) and run:
Code: [Select]
sudo gedit /etc/default/keyboard
and make it read
Code: [Select]
# Check /usr/share/doc/keyboard-configuration/README.Debian for
# documentation on what to do after having modified this file.

# The following variables describe your keyboard and can have the same
# values as the XkbModel, XkbLayout, XkbVariant and XkbOptions options
# in /etc/X11/xorg.conf.

XKBMODEL="pc105"
XKBLAYOUT="gb"
XKBVARIANT=""
XKBOPTIONS=""

# If you don't want to use the XKB layout on the console, you can
# specify an alternative keymap.  Make sure it will be accessible
# before /usr is mounted.
# KMAP=/etc/console-setup/defkeymap.kmap.gz
SAVE the file and exit gedit.

Back in the terminal run:
Code: [Select]
gedit ~/.config/peppermint-control-center/keyboard_layout
and make it read:-
Code: [Select]
#!/bin/sh
setxkbmap gb
SAVE the file.

Reboot to test.

--
« Last Edit: December 09, 2014, 03:28:28 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1013
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Cannot Save Keyboard Layout Settings
« Reply #2 on: December 09, 2014, 06:17:44 pm »
Hi Terry, Welcome to Planet Peppermint  8).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline TerryWood

  • nOOb
  • *
  • Posts: 2
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 5-20140623
Re: Cannot Save Keyboard Layout Settings
« Reply #3 on: December 09, 2014, 06:35:12 pm »
Hi All

Wow what a welcome thank you, AND I now have a UK keyboard that is saved.

Thank you very much.

Super service.

Terry

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26082
  • Karma: 2842
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Cannot Save Keyboard Layout Settings
« Reply #4 on: December 10, 2014, 08:59:41 pm »
You're most welcome :)

Can you please remember to mark topics (SOLVED) if/when you consider them so.

You can do this by editing the FIRST posting in the topic and changing:

Subject: Cannot Save Keyboard Layout Settings (SOLVED)

I've done this one for you :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec