Author Topic: Intel graphic card driver problem??? (SOLVED)  (Read 3329 times)

Offline Rens

  • Newly Subscribed
  • *
  • Posts: 22
  • Karma: 0
  • IBM Thinkpad X30 tasting fresh
    • View Profile
    • google+ profile
  • Peppermint version(s): 4
Intel graphic card driver problem??? (SOLVED)
« on: May 08, 2014, 03:26:28 pm »
Hi,
I have recently installed peppermint 4 on an IBM Thinkpad X30 and it is running but.... too often the screen goes black while I am working on it. It is not black black, but slightly lighter than black, because when I hold the power button for x seconds the computer switches off and then it becomes really black. It stays that way and keeping the power button pressed is my way out. I suspect it is some incompatibility with the Intel graphics card, but am not sure as I know very little of these things. I will paste some details below in the hope somebody will be so kind to help me out. I love peppermint though and will buy one of the Peppermint memory sticks as soon as I have got this issue sorted!
Best wishes,
Rens

System:    Host: rens-laptop Kernel: 3.8.0-35-generic i686 (32 bit) Desktop: N/A Distro: Peppermint Four
Machine:   Mobo: IBM model: 2673EG2 Bios: IBM version: 1KET43WW (1.04 ) date: 03/14/2003
CPU:       Single core Mobile Intel Pentium III CPU - M (-UP-) cache: 512 KB flags: (sse) clocked at 798.00 MHz
Graphics:  Card: Intel 82830M/MG Integrated Graphics Controller
           X.Org: 1.13.3 drivers: intel (unloaded: fbdev,vesa) Resolution: 1024x768@60.0hz
           GLX Renderer: Mesa DRI Intel 830M x86/MMX/SSE GLX Version: 1.3 Mesa 9.1.7
Audio:     Card: Intel 82801CA/CAM AC'97 Audio Controller driver: snd_intel8x0 Sound: ALSA ver: k3.8.0-35-generic
Network:   Card-1: Intel 82801CAM (ICH3) PRO/100 VE (LOM) Ethernet Controller driver: e100
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: 00:09:6b:cd:34:dc
           Card-2: Cisco Aironet Wireless Cisco Aironet Wireless 802.11b driver: airo
           IF: eth1
wifi0 state: N/A mac: N/A
Drives:    HDD Total Size: 40.0GB (6.2% used) 1: id: /dev/sda model: IC25N040ATCS04 size: 40.0GB
Partition: ID: / size: 37G used: 2.4G (7%) fs: ext4 ID: swap-1 size: 0.53GB used: 0.01GB (2%) fs: swap
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 55.0C mobo: 55.0C
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 130 Uptime: 14 min Memory: 269.1/487.6MB Client: Shell inxi: 1.8.4



rens@rens-laptop ~ $ sudo lshw -c video
[sudo] password for rens:
  *-display:0             
       description: VGA compatible controller
       product: 82830M/MG Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 04
       width: 32 bits
       clock: 33MHz
       capabilities: pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:11 memory:e0000000-e7ffffff memory:d0000000-d007ffff
  *-display:1 UNCLAIMED
       description: Display controller
       product: 82830M/MG Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2.1
       bus info: pci@0000:00:02.1
       version: 00
       width: 32 bits
       clock: 33MHz
       capabilities: pm cap_list
       configuration: latency=0 maxlatency=11
       resources: memory:e8000000-efffffff memory:d0080000-d00fffff
rens@rens-laptop ~ $


« Last Edit: May 10, 2014, 02:33:56 am by Rens »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Intel graphic card driver problem???
« Reply #1 on: May 09, 2014, 07:49:30 am »
I'm "fairly" sure it's this bug:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/1186800

If so, I'm afraid it'll not be fixed in 13.04/Peppermint 4 .. and unless it's a regression that someone who submits patches actually comes across personally, I doubt if it ever will be.

For now you could go back to Peppermint 3 which being based on Ubuntu 12.04 shouldn't suffer this bug.

Your other option is to wait for Peppermint 5 and cross your fingers.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Rens

  • Newly Subscribed
  • *
  • Posts: 22
  • Karma: 0
  • IBM Thinkpad X30 tasting fresh
    • View Profile
    • google+ profile
  • Peppermint version(s): 4
Re: Intel graphic card driver problem???
« Reply #2 on: May 09, 2014, 08:14:46 am »
Thank you  PCNetSpec! In the URL of the bug you mentioned two workarounds are mentioned. Do you think one of these workarounds or another (use vesa driver for example??) could work for me? I don't care much about screen resolution or good graphics. That it doesn't hang is more important.

Kind regards,
Rens

Offline Rens

  • Newly Subscribed
  • *
  • Posts: 22
  • Karma: 0
  • IBM Thinkpad X30 tasting fresh
    • View Profile
    • google+ profile
  • Peppermint version(s): 4
Re: Intel graphic card driver problem???
« Reply #3 on: May 09, 2014, 03:14:51 pm »
Hi,
in the bug url that PCNetSpec posted there was a mention of a possible workaround involving

changing/making the xorg.conf  by

sudo nano /usr/share/X11/xorg.conf.d/xorg.conf

and adding:

Section "Device"
Identifier "Intel Graphics"
Driver "intel"
Option "AccelMethod" "uxa"
EndSection

I have done that and it resolved the problem.

Many thanks for your help,
Rens
« Last Edit: May 10, 2014, 02:37:11 am by Rens »