Choose style:

Author Topic: newbie ICE not working  (Read 5880 times)

0 Members and 1 Guest are viewing this topic.

Offline sogalitno

  • nOOb
  • *
  • Posts: 1
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Four
newbie ICE not working
« on: April 06, 2014, 04:21:26 pm »
i searched all over and can not find an any reference to this.

The ICE utility has stopped working. 
i installed Peppermint on a computer that had win xp (as its being sunsetted).

anyway, the install is fine and i used ICE to set up some programs in INTERNET.  now however it will NOT open.  I click and click and click
nothing happens

i have rebooted several times

i am able to install packages.
internet access is fine.

help?

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1013
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: newbie ICE not working
« Reply #1 on: April 06, 2014, 05:08:37 pm »
Hi sogalitno, how's it going?  Try removing Ice and re-installing it.
Code: [Select]
sudo apt-get remove --purge ice -y
Code: [Select]
sudo apt-get install ice -y
Now try to make an SSB.  I hope this helps   :).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline emegra

  • Global Moderator
  • Veteran
  • *****
  • Posts: 1916
  • Karma: 415
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 9 64bit
Re: newbie ICE not working
« Reply #2 on: April 06, 2014, 05:15:38 pm »
Hi sogalitno

If Andys suggestion doesn't work you can try running Ice from the terminal simply by typing ice at the command prompt and see if it throws up any error messages that would give us a clue




Good luck



Graeme
If you can keep your head while all around are losing theirs then you're not quite grasping the situation

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26273
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: newbie ICE not working
« Reply #3 on: April 06, 2014, 05:44:36 pm »
Something else to try....

Can you remember which was the last shortcut you added ?

If so, open a terminal and run:
Code: [Select]
pcmanfm ~/.local/share/applications
and delete the last one you created
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline nberidze

  • Jr. Member
  • **
  • Posts: 60
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 5
Re: newbie ICE not working
« Reply #4 on: May 08, 2014, 08:04:27 am »
I had the same problem. Fair enough, running pcmanfm ~/.local/share/applications and deleting the last website I added makes Ice work again, but if I try adding it again, Ice stops working as before. How to add that SSB without causing Ice to stop working? (The website I tried to add was http://ipiccy.com )

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26273
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: newbie ICE not working
« Reply #5 on: May 08, 2014, 09:21:38 am »
The problem here is that when ice downloads the icon from the ipiccy website, the website isn't providing an image .. it's returning an html page .. ice then stores that, and attempts to load it as an icon, and crashes.

The workaround is to NOT select "Download Icon"

Instead download this image:



and store it somewhere.

then create your link in ice in the normal way, but instead of choosing to "Download Icon", choose "Select Icon" and point it at the file you downloaded.
« Last Edit: May 08, 2014, 09:23:28 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline nberidze

  • Jr. Member
  • **
  • Posts: 60
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 5
Re: newbie ICE not working
« Reply #6 on: May 08, 2014, 09:55:48 am »
The problem here is that when ice downloads the icon from the ipiccy website, the website isn't providing an image .. it's returning an html page .. ice then stores that, and attempts to load it as an icon, and crashes.

The workaround is to NOT select "Download Icon"

Instead download this image: [...]

and store it somewhere.

then create your link in ice in the normal way, but instead of choosing to "Download Icon", choose "Select Icon" and point it at the file you downloaded.

Thanks, but it does not solve the problem. I also tried converting the icon to jpeg.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26273
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: newbie ICE not working
« Reply #7 on: May 08, 2014, 09:59:32 am »
Can you add ANY new link without it killing ice ?

When ice doesn't work .. what is returned if you run:
Code: [Select]
ice
in a terminal ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline nberidze

  • Jr. Member
  • **
  • Posts: 60
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 5
Re: newbie ICE not working
« Reply #8 on: May 08, 2014, 10:25:19 am »
Traceback (most recent call last):
  File "/usr/bin/ice", line 376, in <module>
    Ice()
  File "/usr/bin/ice", line 292, in __init__
    self.fill_store()
  File "/usr/bin/ice", line 362, in fill_store
    icon = gtk.gdk.pixbuf_new_from_file_at_size(iconline, 16, 16)
glib.GError: Unrecognized image file format

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26273
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: newbie ICE not working
« Reply #9 on: May 08, 2014, 10:38:58 am »
Run:
Code: [Select]
pcmanfm ~/.local/share/ice
and remove anything in there that has "ipiccy" in the name.

then do as previously mentioned to delete the ipiccy shortcut

then recreate it, but do NOT choose to "Download Icon" .. instead either don't choose an icon at all, or select  "Select Icon" and point it at the icon I provided above.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline nberidze

  • Jr. Member
  • **
  • Posts: 60
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 5
Re: newbie ICE not working
« Reply #10 on: May 08, 2014, 10:48:01 am »
Yes, now it works, although the icon doesn't show in the menu. There's a gear symbol instead.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26273
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: newbie ICE not working
« Reply #11 on: May 08, 2014, 09:35:38 pm »
do you want to fix the icon ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline nberidze

  • Jr. Member
  • **
  • Posts: 60
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 5
Re: newbie ICE not working
« Reply #12 on: May 09, 2014, 04:38:03 am »
Yes, would be nice. How?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26273
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: newbie ICE not working
« Reply #13 on: May 09, 2014, 05:27:17 am »
Run:
Code: [Select]
cd ~/.local/share/ice
then:
Code: [Select]
wget https://c336017.ssl.cf1.rackcdn.com/icon-ipiccy.png
then:
Code: [Select]
pcmanfm ~/.local/share/applications
Now right click on the ipiccy shortcut, and select Open with Text Editor

look for the line that starts with:-

Icon=

and make it read:-

Icon=/home/<username>/.local/share/ice/icon-ipiccy.png

(Obviously, change <username> to your actual username ;) )

SAVE the file .. now restart the panel with:
Code: [Select]
lxpanelctl restart
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline nberidze

  • Jr. Member
  • **
  • Posts: 60
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 5
Re: newbie ICE not working
« Reply #14 on: May 09, 2014, 08:33:08 am »
Thank you!