Choose style:

Author Topic: Disabling and setting a delay on a laptop touchpad.  (Read 5118 times)

0 Members and 1 Guest are viewing this topic.

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1012
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Disabling and setting a delay on a laptop touchpad.
« on: November 16, 2014, 04:09:35 am »
To Disable and Set a Delay on a Laptop's Touchpad While Typing

The skill level for this tutorial is, novice and suitable for all nOObs  ;).  The time delay set for purposes of this tutorial before the touchpad is re-enabled is, 2.5 seconds. 

Open a terminal window with the following keystrokes: Ctrl+Alt+t.  Enter the following command and hit enter.
Code: [Select]
syndaemon -i 2.5 -d
This will disable your touchpad and set the delay when you start to type.  The time delay can be varied in half second increments.  The default value is 2 sec.  In this form, the function is not persistent and will not survive a restart.  To make it persistent, it needs to be added to the autostart folder.  This folder is located at:
Code: [Select]
~/.config/autostart
To add syndaemon -i 2.5 -d to your autostart folder. Copy and paste the following command into the terminal window:
Code: [Select]
gedit ~/.config/autostart/touchpad-pause.desktop
Peppermint 7 users, please substitute gedit with pluma in the command.

Hit enter and copy and paste the following contents into the the empty gedit file.
Code: [Select]
[Desktop Entry]
Type=Application
Name=Touchpad Pause
Comment=touchpad pause whilst typing
Icon=input-touchpad
Exec=bash -c "syndaemon -i 2.5 -d"
Terminal=false
Save and quit the file with the following keystrokes: Ctrl+s and Ctrl+q.

Note:  The time delay set is 2.5 seconds.  You may want to adjust this to suit you own needs.

Logout and log back in and that's it  :).

Further information can be found in the man syndaemon page in the terminal.
« Last Edit: October 15, 2016, 05:14:22 pm by AndyInMokum, Reason: Additional info for PM7 users »
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline VinDSL

  • Global Moderator
  • Hero
  • *****
  • Posts: 5109
  • Karma: 934
  • Peppermint Mod
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Disabling and setting a delay on a laptop touchpad.
« Reply #1 on: November 16, 2014, 10:34:08 am »
GG Andy! 

Boy, could I have used this earlier in the week!?!?!

I was attending a conference in Cali, and my bride couldn't keep her thumbs off the touchpad while typing, on my 'road warrior'.

I finally had to cover the touchpad with a room service menu,  which also works, BTW.   :D

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1012
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Disabling and setting a delay on a laptop touchpad.
« Reply #2 on: November 16, 2014, 10:41:52 am »
GG Andy! 

Boy, could I have used this earlier in the week!?!?!

I was attending a conference in Cali, and my bride couldn't keep her thumbs off the touchpad while typing, on my 'road warrior'.

I finally had to cover the touchpad with a room service menu,  which also works, BTW.   :D
Desperate times call for desperate measures  ;D!!
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline tlgalenson

  • nOOb
  • *
  • Posts: 5
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8
Re: Disabling and setting a delay on a laptop touchpad.
« Reply #3 on: January 23, 2015, 11:40:30 am »
I can't find a place to click for "like" and/or thank you but I wanted to do so.  My cursor has been jumping all over the place until I got to this article/post.  Since I also applied the "permanent" fix I hope to not have to re-visit this article.   :)

Offline mattosensei

  • Member
  • ***
  • Posts: 222
  • Karma: 28
  • Linux with 'L' plates
    • View Profile
  • Peppermint version(s): 6
Re: Disabling and setting a delay on a laptop touchpad.
« Reply #4 on: June 30, 2015, 06:34:56 pm »
Very useful tutorial thank you! Wish I'd spotted it earlier!  :D

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1012
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Disabling and setting a delay on a laptop touchpad.
« Reply #5 on: June 30, 2015, 06:42:51 pm »
Very useful tutorial thank you! Wish I'd spotted it earlier!  :D
I'm glad it helped  ;)!!
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline pepperOS

  • Jr. Member
  • **
  • Posts: 45
  • Karma: 2
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Disabling and setting a delay on a laptop touchpad.
« Reply #6 on: August 24, 2018, 06:34:29 am »
great howto, worked like a charm on a dell E6320

inventiv.us

  • Guest
I don't mean to revive an old thread without good reason, but after this fix was recommended to me, and I reported back that it was far too laggy, even at 0.5sec, it was suggested to me to try 0.1sec.

And it worked!   :)
I realize that the "half-second increments" may have applied to an older version, but I am pleased to report that PM9 seems to accept smaller increments now. (btw, I first tried "0" (before the 0.1 was suggested), and the system seems to interpret zero as "infinity") 

I find 0.1sec to be far more satisfactory. 
There is no noticeable lag before the pointer wakes up, and my typing stopped jumping all over the place.

So just wanted to share that little update.
« Last Edit: January 10, 2019, 02:54:38 am by inventiv.us »

Offline spence

  • Trusted User
  • Veteran
  • *****
  • Posts: 1854
  • Karma: 185
  • peppermint user since 2010
    • View Profile
  • Peppermint version(s): Peppermint 9 Respin
Re: Disabling and setting a delay on a laptop touchpad.
« Reply #8 on: January 10, 2019, 03:41:13 am »
It never hurts to bump an older thread that has provided you a benefit @inventive.us ... it reminds others of the tutorial or fix who may have a similar issue.
spence
PeppermintOS 10installed  on:
'16 Antec Aria rebuild
 '18 Asus VivoBook


Do not despair, grasshopper...
    with patience all will be revealed...
       Through pain, enlightenment will come.

Offline VinDSL

  • Global Moderator
  • Hero
  • *****
  • Posts: 5109
  • Karma: 934
  • Peppermint Mod
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Disabling and setting a delay on a laptop touchpad.
« Reply #9 on: January 10, 2019, 04:02:38 am »
Yeah, this place isn't like the Arch Linux Forums  :D

Quote
Old threads/"necro-bumping"

Do your part to keep the forums tidy. As the wiki is where Arch is documented, posting in old threads ("necrobumping") is generally discouraged in the technical issue subforums, since it can potentially create disjointed "zombie" information; outdated posts with data which is no longer relevant due to Arch's rolling nature, combined with more recent posts reflecting more current circumstance.

Rules of thumb
  • If you have a question, start a new thread and link to the old if relevant. You can also report the old thread so staff can close it.

  • If you have something to add and judge that your information is related, but more up-to-date, start a new thread and link to the old if desired, but avoid duplicating effort by posting information already contained in the Arch wiki.

  • If you have a version-agnostic or corresponding solution, necrobumping may be appropriate if the thread is not more than a year or two old.


LINK: https://wiki.archlinux.org/index.php/Code_of_conduct#Old_threads.2F.22necro-bumping.22

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25082
  • Karma: 2774
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Disabling and setting a delay on a laptop touchpad.
« Reply #10 on: January 10, 2019, 07:14:43 am »
We have no problem with people ADDING to any solution in an old topic .. old topics are still read, so if you have better or newer information it always helps .. so thanks inventiv.us :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline drkmttr

  • Jr. Member
  • **
  • Posts: 28
  • Karma: 5
    • View Profile
  • Peppermint version(s): Ten
Re: Disabling and setting a delay on a laptop touchpad.
« Reply #11 on: July 02, 2019, 09:43:09 am »
In case this helps out anyone, I am providing another option that worked for me. I tried using syndaemon with different options but could not get it to work on my Dell Inspiron 13 7000 series laptop. Here's how I did it with libinput:

First, install X libinput driver. NOTE: this may overwrite some of your other xorg configs if you previously manually changed them.

Code: [Select]
sudo apt install xserver-xorg-input-libinput

Edit the libinput configuration file (I used nano)

Code: [Select]
sudo nano /usr/share/X11/xorg.conf.d/40-libinput.conf

Add Option "DisableWhileTyping" "true" to the bottom of the touchpad block. It should look like this:

Code: [Select]
Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
        Option "DisableWhileTyping" "true"
EndSection

Finally, restart your computer. Hope this helps others where syndaemon didn't work. Maybe there was a better way with synaptics but this worked for me.  :)
Also, check out the libinput man page for more options such as "tapping" which enables tap-to-click.
« Last Edit: July 02, 2019, 10:17:08 am by drkmttr »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25082
  • Karma: 2774
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Disabling and setting a delay on a laptop touchpad.
« Reply #12 on: July 02, 2019, 03:08:44 pm »
Cool, options are always a good thing :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec