Author Topic: No wifi on Lenovo 3000-v100 (SOLVED)  (Read 3436 times)

Offline Freiter

  • Newly Subscribed
  • *
  • Posts: 7
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 5
No wifi on Lenovo 3000-v100 (SOLVED)
« on: November 12, 2014, 01:39:25 am »
Hi

I'm installing a new OS on my friends laptop. It's an Lenovo 3000-v100. I decided to try Peppermint because it's so light-weight.
Everything seems to be working except one thing - no wifi.. at all! it's completely dead. Dosn't work with an ethernet either.
I'm not very experienced in Linux, but I would really like it to work, so I don't have to install Windows XP on it again.

I looked at another thread about wifi problems and followed the instructions there:

jannie@jannie-LENOVO3000-V100 ~ $ sudo lshw -C network
  *-network DISABLED     
       description: Wireless interface
       product: PRO/Wireless 3945ABG [Golan] Network Connection
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: wlan0
       version: 02
       serial: 00:1b:77:05:ce:07
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwl3945 driverversion=3.13.0-29-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11abg
       resources: irq:43 memory:d6000000-d6000fff
  *-network
       description: Ethernet interface
       product: RTL-8100/8101L/8139 PCI Fast Ethernet Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 7
       bus info: pci@0000:0a:07.0
       logical name: eth0
       version: 10
       serial: 00:16:d3:b1:f6:2f
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=half latency=32 link=no maxlatency=64 mingnt=32 multicast=yes port=MII speed=10Mbit/s
       resources: irq:20 ioport:4000(size=256) memory:d8001800-d80018ff

jannie@jannie-LENOVO3000-V100 ~ $ lspci -vnn | grep -i net
04:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection [8086:4227] (rev 02)
0a:07.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL-8100/8101L/8139 PCI Fast Ethernet Adapter [10ec:8139] (rev 10)
jannie@jannie-LENOVO3000-V100 ~ $ lsusb
Bus 001 Device 002: ID 0402:5602 ALi Corp. M5602 Video Camera Controller
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 08ff:1600 AuthenTec, Inc. AES1600
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
jannie@jannie-LENOVO3000-V100 ~ $ iwconfig
wlan0     IEEE 802.11abg  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
         
lo        no wireless extensions.

eth0      no wireless extensions.

jannie@jannie-LENOVO3000-V100 ~ $ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:16:d3:b1:f6:2f 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:752 errors:0 dropped:0 overruns:0 frame:0
          TX packets:752 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:59600 (59.6 KB)  TX bytes:59600 (59.6 KB)

jannie@jannie-LENOVO3000-V100 ~ $ iwlist scanning
wlan0     Failed to read scan data : Network is down

lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

jannie@jannie-LENOVO3000-V100 ~ $ rfkill list
0: acer-wireless: Wireless LAN
   Soft blocked: yes
   Hard blocked: no
1: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: yes

I Would really appreciate it, if anyone could help.
« Last Edit: November 13, 2014, 09:50:15 am by Freiter »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: No wifi on Lenovo 3000-v100
« Reply #1 on: November 12, 2014, 06:00:44 am »
Is there a physical hardware switch on the PC somewhere .. or a key combo (such as Fn+F8 or similar) ?

If not, what happens if you run:
Code: [Select]
sudo rfkill unblock alldoes wireless spring to life ?

If not, can you post the output from:
Code: [Select]
lsmod | grep wmi
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Freiter

  • Newly Subscribed
  • *
  • Posts: 7
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 5
Re: No wifi on Lenovo 3000-v100
« Reply #2 on: November 12, 2014, 07:31:15 am »
thx for quick reply.

Fn+F5 seems to have something to do with wifi, but it does not respond. The Fn does work, but not this one.
Here is  output:

jannie@jannie-LENOVO3000-V100 ~ $ sudo rfkill unblock all
jannie@jannie-LENOVO3000-V100 ~ $ lsmod | grep wmi
acer_wmi               31735  0
sparse_keymap          13708  1 acer_wmi
snd_rawmidi            25135  1 snd_seq_midi
snd_seq_device         14137  3 snd_seq,snd_rawmidi,snd_seq_midi
snd                    60871  17 snd_hda_codec_realtek,snd_hda_codec_si3054,snd_hwdep,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_seq_device,snd_seq_midi
wmi                    18673  1 acer_wmi
video                  18903  2 i915,acer_wmi

Offline Freiter

  • Newly Subscribed
  • *
  • Posts: 7
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 5
Re: No wifi on Lenovo 3000-v100
« Reply #3 on: November 12, 2014, 07:36:32 am »
I've read somewhere, that Lenovo used to put some really bad cards in some of there laptops, that wouldn't last very long. Could it be, that it simply dosn't work anymore?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: No wifi on Lenovo 3000-v100
« Reply #4 on: November 12, 2014, 09:15:03 am »
Possibly,  .. but I'm more of the opinion it has something to do with acer-wmi ..  is there any option in the BIOS to enable wireless switching (or similar) ?

What happens if you run:
Code: [Select]
sudo modprobe -r sparse_keymap acer-wmi wmi iwl3945then
Code: [Select]
sudo rfkill unblock all?
« Last Edit: November 12, 2014, 09:36:15 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

rjm65

  • Guest
Re: No wifi on Lenovo 3000-v100
« Reply #5 on: November 12, 2014, 09:26:23 am »
depending on what model lenovo this is, my lenovos all have a hard switch on the front of them, that can sometimes be mistaken for the cover release and flipped off when trying to open the laptop up....   ;)

rjm65

  • Guest
Re: No wifi on Lenovo 3000-v100
« Reply #6 on: November 12, 2014, 09:33:26 am »
depending on what model lenovo this is, my lenovos all have a hard switch on the front of them, that can sometimes be mistaken for the cover release and flipped off when trying to open the laptop up....   ;)
I did a little digging on google and found this picture hope it helps you there is a switch on the machine for the wifi on the side by the cd/dvd rom drive....

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: No wifi on Lenovo 3000-v100
« Reply #7 on: November 12, 2014, 09:39:29 am »
Nice find rjm65 :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Freiter

  • Newly Subscribed
  • *
  • Posts: 7
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 5
Re: No wifi on Lenovo 3000-v100
« Reply #8 on: November 12, 2014, 09:54:30 am »
Okay, so I switched the wifi on and it says in the BIOS that wifi is enabled, but nothings changed.
This is the output from the terminal:

jannie@jannie-LENOVO3000-V100 ~ $ sudo modprobe -r sparse_keymap acer-wmi wmi iwl3945
modprobe: FATAL: Module sparse_keymap is in use.
jannie@jannie-LENOVO3000-V100 ~ $ sudo rfkill unblock all
jannie@jannie-LENOVO3000-V100 ~ $


Offline Freiter

  • Newly Subscribed
  • *
  • Posts: 7
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 5
Re: No wifi on Lenovo 3000-v100
« Reply #9 on: November 13, 2014, 08:48:17 am »
Does it look hopeless? Should I just tell her to buy a new laptop?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: No wifi on Lenovo 3000-v100
« Reply #10 on: November 13, 2014, 09:24:13 am »
NO .. a USB wireless adapter is MUCH cheaper than a new laptop ;)

That said we're not finished here yet...

What's the output from:
Code: [Select]
rfkill listnow ?

If it's still hardblocked, and the Fn+F5 key combo still refuses to enable it .. try below...

Run:
Code: [Select]
sudo gedit /etc/modprobe.d/blacklist.confwhen gedit opens, add a single NEW LINE at the bottom that reads:-

blacklist acer-wmi

SAVE the file and exit gedit

Now REBOOT

Now what;s the output from:
Code: [Select]
rfkill list?
« Last Edit: November 13, 2014, 09:26:54 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Freiter

  • Newly Subscribed
  • *
  • Posts: 7
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 5
Re: No wifi on Lenovo 3000-v100
« Reply #11 on: November 13, 2014, 09:49:54 am »
Now all of a sudden the wifi works!  :) it said something about scanning for brstf something when I started it up right now, and then it just worked..
thank you very much for your help!

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: No wifi on Lenovo 3000-v100 (SOLVED)
« Reply #12 on: November 13, 2014, 10:30:50 am »
Without you doing anything ? .. or after blacklisting acer-wmi ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Freiter

  • Newly Subscribed
  • *
  • Posts: 7
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 5
Re: No wifi on Lenovo 3000-v100 (SOLVED)
« Reply #13 on: November 13, 2014, 11:31:24 am »
it must be some of the things I did yesterday..

anyway, thx very much!