Choose style:

Author Topic: [SOLVED] Resetting default size of LXTerminal  (Read 4069 times)

0 Members and 1 Guest are viewing this topic.

Offline Cleaver

  • Jr. Member
  • **
  • Posts: 27
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 5
[SOLVED] Resetting default size of LXTerminal
« on: October 28, 2014, 01:49:32 am »
Hi,

I swear I've looked at many forums outside of this one to figure out how to reset the default size for LXTerminal in Peppermint 5, but I can't seem to find one that works. Generally, they seem to refer to folders I don't have(since most are Lubuntu user forums.) Any pointers on how to set it so that it'll be wide enough for my liking?  My main reason is that I want Screenfetch to display properly upon opening the terminal with Ctrl+Alt+T. Currently, the size is off and makes text wrap in an unsightly and somewhat confusing way. Thanks in advance!
« Last Edit: October 28, 2014, 05:56:57 pm by Cleaver »

Offline iamesperambient

  • Veteran
  • ****
  • Posts: 1269
  • Karma: 89
  • a totally awesome dude
    • View Profile
    • i AM esper (drone ambient music)
  • Peppermint version(s): Peppermint 8 64 bit
Re: Resetting default size of LXTerminal
« Reply #1 on: October 28, 2014, 01:59:57 am »
i tried looking in preferences to see if there was anything about changing the size maybe someone else can help im actually curious myself.
I did see a hide scrollbar option but i wonder if it will still scroll with the mouse wheel still?
http://iamesper.bandcamp.com
boring drone music from NJ

Offline iamesperambient

  • Veteran
  • ****
  • Posts: 1269
  • Karma: 89
  • a totally awesome dude
    • View Profile
    • i AM esper (drone ambient music)
  • Peppermint version(s): Peppermint 8 64 bit
http://iamesper.bandcamp.com
boring drone music from NJ

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1013
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Resetting default size of LXTerminal
« Reply #3 on: October 28, 2014, 04:10:22 am »
Hi Cleaver, how's it going?  Try this.  Open a terminal window and enter the following command:
Code: [Select]
gksudo gedit /etc/usr/share/applications/lxterminal.desktop
Enter your user password in the the popup window.  Scroll to the bottom of the opened file to where it looks like this:
Code: [Select]
TryExec=lxterminal
Exec=lxterminal
Icon=lxterminal
Type=Application
Categories=GTK;Utility;TerminalEmulator;

Edit it to make it look like this, (use your own dimensions)
Code: [Select]
TryExec=lxterminal
Exec=lxterminal --geometry=114x38
Icon=lxterminal
Type=Application
Categories=GTK;Utility;TerminalEmulator;

Save the file.  Navigate to: menu > applications > Terminal to test.  I hope this helps - have fun  ;)!!
« Last Edit: October 28, 2014, 06:34:55 am by AndyInMokum, Reason: Typo in command »
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline Cleaver

  • Jr. Member
  • **
  • Posts: 27
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 5
Re: Resetting default size of LXTerminal
« Reply #4 on: October 28, 2014, 05:33:03 am »
Hi Cleaver, how's it going?  Try this.  Open a terminal window and enter the following command:
Code: [Select]
gksudo gedit /etc/share/applications/lxterminal.desktop
Enter your user password in the the popup window.  Scroll to the bottom of the opened file to where it looks like this:
Code: [Select]
TryExec=lxterminal
Exec=lxterminal
Icon=lxterminal
Type=Application
Categories=GTK;Utility;TerminalEmulator;

Edit it to make it look like this, (use your own dimensions)
Code: [Select]
TryExec=lxterminal
Exec=lxterminal --geometry=114x38
Icon=lxterminal
Type=Application
Categories=GTK;Utility;TerminalEmulator;

Save the file.  Navigate to: menu > applications > Terminal to test.  I hope this helps - have fun  ;)!!

Hi AndyInMokum,

It's going OK in most respects with Peppermint, but this one's not working as it should with your instructions.  When I type that first command you pasted, it opens up a *completely* blank text file. Any idea why this would be? Thanks!

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1013
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Resetting default size of LXTerminal
« Reply #5 on: October 28, 2014, 06:33:54 am »
Hi Cleaver,  My apologies for my "caffeine deprived" state when I posted.  There is a typo in the command.  Try this:
Code: [Select]
gksudo gedit /usr/share/applications/lxterminal.desktop
Sorry about that  :-[!!

Note: For future readers, the original post has been corrected.
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline Cleaver

  • Jr. Member
  • **
  • Posts: 27
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 5
Re: Resetting default size of LXTerminal
« Reply #6 on: October 28, 2014, 02:45:15 pm »
Hi Cleaver,  My apologies for my "caffeine deprived" state when I posted.  There is a typo in the command.  Try this:
Code: [Select]
gksudo gedit /usr/share/applications/lxterminal.desktop
Sorry about that  :-[!!

Note: For future readers, the original post has been corrected.

Hi AndyInMokum, and thanks again. That *does* work on the window, but my original intent here was to get it working when I press Ctrl+Alt+T. I read somewhere that this is a different process from getting it to simply run via the menu, but those are the very forums that aren't about Peppermint, so they didn't work when I tried their methods. Any pointers on this specific aspect of the terminal?

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1013
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Resetting default size of LXTerminal
« Reply #7 on: October 28, 2014, 03:20:34 pm »
Hi Cleaver, that is a very good question, try this.  Navigate to menu > Preferences > Peppermint Control Center.  Click on the Keyboard Shortcuts tab. Double click on the x-terminal-emulator.  Delete it.  Click on any of the other tabs and return to Keyboard Shortcuts.  Click on Add New.  Enter in the empty field:
Code: [Select]
x-terminal-emulator --geometry=YxX
Y and X being your desired dimensions.  Click Ok.  In the new window click on the Control then the Alt buttons and then enter t in the empty field.  Click on Apply and then test it.  It worked for me.  I hope this helps  ;)!!
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25473
  • Karma: 2803
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Resetting default size of LXTerminal
« Reply #8 on: October 28, 2014, 03:50:31 pm »
Run:
Code: [Select]
gedit ~/.config/peppermint-control-center/xbindkeys.conf
find the section that reads
Code: [Select]
#Terminal
"x-terminal-emulator"
   Control+Alt + t
and change it to:-
Code: [Select]
#Terminal
"lxterminal --geometry=114x38"
   Control+Alt + t
(or whatever size you want)

SAVE the file.

Log off/on (or reboot) to apply the chages

Test.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Cleaver

  • Jr. Member
  • **
  • Posts: 27
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 5
Re: Resetting default size of LXTerminal
« Reply #9 on: October 28, 2014, 05:36:46 pm »
Thanks! The keyboard shortcut editing menu stuff worked like charm. Triple checked it. No idea why it was too narrow this time--on my last install of P5 it fit Screenfetch beautifully by default.  :-\

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1013
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Resetting default size of LXTerminal
« Reply #10 on: October 28, 2014, 05:53:42 pm »
Cool  8)!  Could you please remember to mark the topic as [SOLVED] in the Subject line of the original post.  Many thanks  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline Cleaver

  • Jr. Member
  • **
  • Posts: 27
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 5
Re: Resetting default size of LXTerminal
« Reply #11 on: October 28, 2014, 05:57:29 pm »
Cool  8)!  Could you please remember to mark the topic as [SOLVED] in the Subject line of the original post.  Many thanks  ;).

Done! Thanks again. :)